Can not connect to WLAN access point

Here is my problem:

openSUSE 13.1 KDE, up to date as of 2013-12-17 03:00 UTC (including updates today for the plasmoid-networkmanagement, NetworkManager-vpnc-kde4, NetworkManager-pptp-kde4, NetworkManager-openvpn-kde4, NetworkManager-kde4-libs-lang, NetworkManager-kde4-libs all version 0.9.0.10)
Acer Aspire 4755G
WLAN chip Broadcom BCM43227
Driver broadcom-wl 6.30.223.141-2.6 with broadcom-wl-kmp-desktop installed (matching the kernel)

The WLAN access point is usually recognized.

Configuring the network connection:
SSID taken from scan
Mode: infrastructure
BSSID: with select
Restrict to interface: any
Cloned MAC address: with random
MTU automatic
Filling in the password

The typical scenario is this:
The KDE daemon repeatedly asks for the WLAN password.
A connection is not established.

Networkmanager log:

2013-12-17T14:21:53.221999+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: inactive → disconnected
2013-12-17T14:22:03.157804+08:00 linux NetworkManager[897]: <info> Auto-activating connection ‘WLAN-2013’.
2013-12-17T14:22:03.158256+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) starting connection ‘WLAN-2013’
2013-12-17T14:22:03.158581+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: disconnected → prepare (reason ‘none’) [30 40 0]
2013-12-17T14:22:03.158910+08:00 linux NetworkManager[897]: <info> NetworkManager state is now CONNECTING
2013-12-17T14:22:03.159556+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) scheduled…
2013-12-17T14:22:03.160048+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) started…
2013-12-17T14:22:03.160678+08:00 linux NetworkManager[897]: <info> (wlp3s0): taking down device.
2013-12-17T14:22:03.163069+08:00 linux NetworkManager[897]: <warn> (wlp3s0): failed to change interface MAC address
2013-12-17T14:22:03.163806+08:00 linux NetworkManager[897]: <warn> (wlp3s0): failed to set MAC address to 25:37:2D:57:36:38
2013-12-17T14:22:03.164328+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) scheduled…
2013-12-17T14:22:03.164788+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) complete.
2013-12-17T14:22:03.166629+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) starting…
2013-12-17T14:22:03.167331+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: prepare → config (reason ‘none’) [40 50 0]
2013-12-17T14:22:03.167891+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0/wireless): connection ‘WLAN-2013’ has security, and secrets exist. No new secrets needed.
2013-12-17T14:22:03.168420+08:00 linux NetworkManager[897]: <info> Config: added ‘ssid’ value ‘WLAN-2013’
2013-12-17T14:22:03.168958+08:00 linux NetworkManager[897]: <info> Config: added ‘scan_ssid’ value ‘1’
2013-12-17T14:22:03.169466+08:00 linux NetworkManager[897]: <info> Config: added ‘bssid’ value ‘00:19:5b:dd:b8:7a’
2013-12-17T14:22:03.170005+08:00 linux NetworkManager[897]: <info> Config: added ‘key_mgmt’ value ‘WPA-PSK’
2013-12-17T14:22:03.170539+08:00 linux NetworkManager[897]: <info> Config: added ‘psk’ value ‘<omitted>’
2013-12-17T14:22:03.171018+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) complete.
2013-12-17T14:22:03.171909+08:00 linux NetworkManager[897]: <info> Config: set interface ap_scan to 1
2013-12-17T14:22:03.192086+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: disconnected → inactive
2013-12-17T14:22:03.197837+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: inactive → scanning
2013-12-17T14:22:04.315821+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: scanning → associating
2013-12-17T14:22:04.316421+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: associating → associated
2013-12-17T14:22:04.488137+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: associated → 4-way handshake
2013-12-17T14:22:07.821879+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: 4-way handshake → disconnected
2013-12-17T14:22:07.822364+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0/wireless): disconnected during association, asking for new key.
2013-12-17T14:22:07.822682+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: config → need-auth (reason ‘supplicant-disconnect’) [50 60 8]
2013-12-17T14:22:07.921487+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: disconnected → inactive
2013-12-17T14:22:09.472917+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) scheduled…
2013-12-17T14:22:09.473484+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) started…
2013-12-17T14:22:09.473914+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: need-auth → prepare (reason ‘none’) [60 40 0]
2013-12-17T14:22:09.474377+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) scheduled…
2013-12-17T14:22:09.474830+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) complete.
2013-12-17T14:22:09.475304+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) starting…
2013-12-17T14:22:09.475782+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: prepare → config (reason ‘none’) [40 50 0]
2013-12-17T14:22:09.476229+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0/wireless): connection ‘WLAN-2013’ has security, and secrets exist. No new secrets needed.
2013-12-17T14:22:09.476717+08:00 linux NetworkManager[897]: <info> Config: added ‘ssid’ value ‘WLAN-2013’
2013-12-17T14:22:09.477153+08:00 linux NetworkManager[897]: <info> Config: added ‘scan_ssid’ value ‘1’
2013-12-17T14:22:09.477568+08:00 linux NetworkManager[897]: <info> Config: added ‘bssid’ value ‘00:19:5b:dd:b8:7a’
2013-12-17T14:22:09.477993+08:00 linux NetworkManager[897]: <info> Config: added ‘key_mgmt’ value ‘WPA-PSK’
2013-12-17T14:22:09.478419+08:00 linux NetworkManager[897]: <info> Config: added ‘psk’ value ‘<omitted>’
2013-12-17T14:22:09.478904+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) complete.
2013-12-17T14:22:09.479459+08:00 linux NetworkManager[897]: <info> Config: set interface ap_scan to 1
2013-12-17T14:22:09.512961+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: inactive → scanning
2013-12-17T14:22:10.499900+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: scanning → associating
2013-12-17T14:22:10.615298+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: associating → associated
2013-12-17T14:22:10.791191+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: associated → 4-way handshake
2013-12-17T14:22:14.120656+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: 4-way handshake → disconnected
2013-12-17T14:22:14.121479+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0/wireless): disconnected during association, asking for new key.
2013-12-17T14:22:14.122152+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: config → need-auth (reason ‘supplicant-disconnect’) [50 60 8]
2013-12-17T14:22:14.219823+08:00 linux NetworkManager[897]: <info> (wlp3s0): supplicant interface state: disconnected → inactive
2013-12-17T14:22:14.952647+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) scheduled…
2013-12-17T14:22:14.953173+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) started…
2013-12-17T14:22:14.953554+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: need-auth → prepare (reason ‘none’) [60 40 0]
2013-12-17T14:22:14.953954+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) scheduled…
2013-12-17T14:22:14.954363+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) complete.
2013-12-17T14:22:14.954730+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) starting…
2013-12-17T14:22:14.955113+08:00 linux NetworkManager[897]: <info> (wlp3s0): device state change: prepare → config (reason ‘none’) [40 50 0]
2013-12-17T14:22:14.955523+08:00 linux NetworkManager[897]: <info> Activation (wlp3s0/wireless): connection ‘WLAN-2013’ has security, and secrets exist. No new secrets needed.

The same applies when the connection is set to “system connection.”

Changing the configuration settings doesn’t help.
Installing b43-firmware doesn’t help.
**
Exceptional case:**
The connection can be established. This happened three times, 2013-12-12, the day when I installed the system, and twice 2013-12-16 when the connection was working for a couple of hours.

Network manager log:

2013-12-16T19:36:29.895746+08:00 linux NetworkManager[902]: <info> (wlp3s0): supplicant interface state: inactive → disconnected
2013-12-16T19:36:38.430872+08:00 linux NetworkManager[902]: <info> Auto-activating connection ‘WLAN-2013’.
2013-12-16T19:36:38.431350+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) starting connection ‘WLAN-2013’
2013-12-16T19:36:38.431777+08:00 linux NetworkManager[902]: <info> (wlp3s0): device state change: disconnected → prepare (reason ‘none’) [30 40 0]
2013-12-16T19:36:38.432120+08:00 linux NetworkManager[902]: <info> NetworkManager state is now CONNECTING
2013-12-16T19:36:38.432457+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) scheduled…
2013-12-16T19:36:38.432797+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) started…
2013-12-16T19:36:38.433145+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) scheduled…
2013-12-16T19:36:38.433476+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) complete.
2013-12-16T19:36:38.433803+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) starting…
2013-12-16T19:36:38.434140+08:00 linux NetworkManager[902]: <info> (wlp3s0): device state change: prepare → config (reason ‘none’) [40 50 0]
2013-12-16T19:36:38.434485+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0/wireless): connection ‘WLAN-2013’ has security, and secrets exist. No new secrets needed.
2013-12-16T19:36:38.436830+08:00 linux NetworkManager[902]: <info> Config: added ‘psk’ value ‘<omitted>’
2013-12-16T19:36:38.437105+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) complete.
2013-12-16T19:36:38.439982+08:00 linux NetworkManager[902]: <info> Config: set interface ap_scan to 1
2013-12-16T19:36:38.462101+08:00 linux NetworkManager[902]: <info> (wlp3s0): supplicant interface state: disconnected → scanning
2013-12-16T19:36:39.476032+08:00 linux NetworkManager[902]: <info> (wlp3s0): supplicant interface state: scanning → associating
2013-12-16T19:36:39.610857+08:00 linux NetworkManager[902]: <info> (wlp3s0): supplicant interface state: associating → associated
2013-12-16T19:36:39.786852+08:00 linux NetworkManager[902]: <info> (wlp3s0): supplicant interface state: associated → 4-way handshake
2013-12-16T19:36:39.816492+08:00 linux NetworkManager[902]: <info> (wlp3s0): supplicant interface state: 4-way handshake → completed
2013-12-16T19:36:39.816923+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network ‘WLAN-2013’.
2013-12-16T19:36:39.817212+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 3 of 5 (IP Configure Start) scheduled.
2013-12-16T19:36:39.817470+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 3 of 5 (IP Configure Start) started…
2013-12-16T19:36:39.817713+08:00 linux NetworkManager[902]: <info> (wlp3s0): device state change: config → ip-config (reason ‘none’) [50 70 0]
2013-12-16T19:36:39.847419+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Beginning DHCPv4 transaction (timeout in 45 seconds)
2013-12-16T19:36:39.877868+08:00 linux NetworkManager[902]: <info> dhclient started with pid 7118
2013-12-16T19:36:40.033798+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 3 of 5 (IP Configure Start) complete.
2013-12-16T19:36:40.067787+08:00 linux NetworkManager[902]: <info> (wlp3s0): DHCPv4 state changed nbi → preinit
2013-12-16T19:36:40.318145+08:00 linux NetworkManager[902]: <info> (wlp3s0): DHCPv4 state changed preinit → reboot
2013-12-16T19:36:40.318442+08:00 linux NetworkManager[902]: <info> address 192.168.0.118
2013-12-16T19:36:40.318676+08:00 linux NetworkManager[902]: <info> prefix 24 (255.255.255.0)
2013-12-16T19:36:40.318891+08:00 linux NetworkManager[902]: <info> gateway 192.168.0.1
2013-12-16T19:36:40.319108+08:00 linux NetworkManager[902]: <info> nameserver ‘192.168.1.1’
2013-12-16T19:36:40.319322+08:00 linux NetworkManager[902]: <info> nameserver ‘192.168.0.1’
2013-12-16T19:36:40.319542+08:00 linux NetworkManager[902]: <info> domain name ‘domain.name’
2013-12-16T19:36:40.319797+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 5 of 5 (IPv4 Configure Commit) scheduled…
2013-12-16T19:36:40.320016+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 5 of 5 (IPv4 Commit) started…
2013-12-16T19:36:41.320120+08:00 linux NetworkManager[902]: <info> (wlp3s0): device state change: ip-config → secondaries (reason ‘none’) [70 90 0]
2013-12-16T19:36:41.320571+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) Stage 5 of 5 (IPv4 Commit) complete.
2013-12-16T19:36:41.320949+08:00 linux NetworkManager[902]: <info> (wlp3s0): device state change: secondaries → activated (reason ‘none’) [90 100 0]
2013-12-16T19:36:41.385891+08:00 linux NetworkManager[902]: <info> NetworkManager state is now CONNECTED_GLOBAL
2013-12-16T19:36:41.386342+08:00 linux NetworkManager[902]: <info> Policy set ‘WLAN-2013’ (wlp3s0) as default for IPv4 routing and DNS.
2013-12-16T19:36:41.389399+08:00 linux NetworkManager[902]: <info> Activation (wlp3s0) successful, device activated.

The 4-way handshake seems to be the crucial point.

Any suggestion to solve this problem would be very much appreciated.

Is this worth a bug report? (I wouldn’t want to bug the awesome openSUSE people with an unnecessary bug report.)

Note: An Acer laptop with an Atheros WLAN chip and openSUSE 12.3 has no problem with connecting to the router.

Additional information:
Following a suggestion on the Arch forum I changed the iPv6 address method to link-local. The WLAN connection worked immediately and stayed. Being excited about this I decided to test if it would still work after a reboot. Unfortunately the the access point is not recognized anymore which happened before.

Try deleting the existing connection and start over. Do you have NM configured to store secrets in secure storage (encrypted)?

I deleted the connection. Even after rebooting no wireless network is detected. I am clueless.
How would I find out if secrets are stored in secure storage?

After a reboot the wireless is being detected (finally). Connection (this time with iPv6 disabled as usual and on our other machine) fails as in most cases before.
I found the requested information in NM: Connection secrets are stored “in file (unencrypted).”

Can you try rebooting your AP router? Sometimes they are the cause of the issue.

Rebooting the WLAN router and the computer didn’t help. Even detecting the wireless network is now very unreliable and unpredictable.
It is a 64-bit system (in case that matters).

On 12/17/2013 04:16 PM, opensuseinmanila wrote:
>
> Rebooting the WLAN router and the computer didn’t help. Even detecting
> the wireless network is now very unreliable and unpredictable.
> It is a 64-bit system (in case that matters).

This problem sounds like a problem with Broadcom’s wl driver. As that one uses
closed source, there is not much we can do. I suggest you complain to them.

Here a question of a non-expert: Can it be that udev is part of the problem? udev renames the network interfaces.

dmesg output:

22.613198] systemd-udevd[448]: renamed network interface eth0 to enp4s0f0
22.805790] eth0: Broadcom BCM4358 802.11 Hybrid Wireless Controller 6.30.223.141 (r415941)
22.819485] systemd-udevd[455]: renamed network interface eth0 to wlp3s0

35.556383] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)
35.556587] ERROR @wl_cfg80211_scan : WLC_SCAN error (-22)

Can that be?

Hi and Marry Christmas to everyone.
I’ve had same problem in KDE of openSuse 13.1 which kick me back to 12.3. Same hardware works on 12.3 without any problem, but in 13.1 not. I’m using 64 bit version of OS and Asus PCE-N15 wireless adapter, which is supported by kernel and detected even by openSuse 13.1 also. Access point also is recognized by 13.1 but as opensuseinmanila wrote:** KDE daemon repeatedly asks for the WLAN password**, without network access.

/usr/bin/lspci results as following:
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 11)

If need more details, let me know.

As far as I am concerned the issue disappeared. Somehow openSUSE 13.1 KDE and the proprietary driver learned to cooperate. WLAN now works more or less reliably on my machine. I have no idea what changed the situation. Anyhow, it is even easier now to really enjoy the system.

The issue reappeared on 2014-01-15. It maybe due to a new WLAN access point, now a WLAN modem. After boot no AP is recognized. Turning on Bluetooth manually brings up the access point. Trying to connect ends up in the authentication loop described above. Then I change the IPv6 settings from “Disabled” to “Automatic” or “Manual” or back and, lo and behold, I can connect. Weird, but I can live with it.