Can not compile scangearmp

hy everybody,

i tried realy hard but i reached the point where I dont know how to do it. I am trying to compile scangear from source, because there isn’t a package provided by canon for the 64 bit version.

Scangear is a nice tool to use your canon scanner and I need it. After resolving all dependencies and executing I get the following error message which I marked bold here. The underlined can be ignored I checked that already at it seems it shouldn’t make a difference. AC_PROG_LIBTOOL is already in and I don’t know what it needs exactly. :smiley:

Ah and something important to mention is that I didn’t find the following libraries:

** * libcncpcmcm (1.0.0 or above)
* libcncpmsimg (1.0.0 or above)
* libcncpmslld (1.0.0 or above)
* libcncpmsui (1.0.0 or above)
* libcncpnet (1.1.0 or above)**

linux-rq5v:/home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp # sh
Warning: I am going to run configure' with no arguments. If you wish to pass any to it, please specify them on the’ command line.

processing .
Creating ./aclocal.m4 …
Running glib-gettextize… Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/

Please add the files
codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
from the /usr/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from

Making ./aclocal.m4 writable …
Running aclocal …
Running autoheader…
autoheader: WARNING: Using auxiliary files such as acconfig.h',’
autoheader: WARNING: and', to define templates for’
autoheader: WARNING: is deprecated and discouraged.
autoheader: WARNING: Using the third argument of AC_DEFINE' and autoheader: WARNING: AC_DEFINE_UNQUOTED’ allows one to define a template without
autoheader: WARNING: acconfig.h': autoheader: autoheader: WARNING: AC_DEFINE([NEED_FUNC_MAIN], 1, autoheader: [Define if a function main’ is needed.])
autoheader: WARNING: More sophisticated templates can also be produced, see the
autoheader: WARNING: documentation.
Running automake --gnu …
backend/ Libtool library used but LIBTOOL' is undefined backend/ The usual way to define LIBTOOL’ is to add AC_PROG_LIBTOOL' backend/ to’ and run aclocal' and autoconf’ again.
backend/ If AC_PROG_LIBTOOL' is in’, make sure
backend/ its definition is in aclocal’s search path.
src/ compiling main.c' with per-target flags requires AM_PROG_CC_C_O’ in'** Running autoconf ... Running ./configure --enable-maintainer-mode ... checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for a thread-safe mkdir -p... /bin/mkdir -p checking for gawk... gawk checking whether make sets $(MAKE)... yes ./configure: line 2663: AC_PROG_LIBTOOL: command not found checking whether to enable maintainer-specific portions of Makefiles... yes checking for style of include used by make... GNU checking for gcc... gcc checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... no checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ISO C89... none needed checking dependency style of gcc... gcc3 checking for library containing strerror... none required checking for gcc... (cached) gcc checking whether we are using the GNU C compiler... (cached) yes checking whether gcc accepts -g... (cached) yes checking for gcc option to accept ISO C89... (cached) none needed checking dependency style of gcc... (cached) gcc3 checking for gcc... (cached) gcc checking whether we are using the GNU C compiler... (cached) yes checking whether gcc accepts -g... (cached) yes checking for gcc option to accept ISO C89... (cached) none needed checking dependency style of gcc... (cached) gcc3 checking how to run the C preprocessor... gcc -E checking for grep that handles long lines and -e... /usr/bin/grep checking for egrep... /usr/bin/grep -E checking for ANSI C header files... yes checking for ranlib... ranlib checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for PACKAGE... yes checking for GIMP... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking png.h usability... yes checking png.h presence... yes checking for png.h... yes checking stdio.h usability... yes checking stdio.h presence... yes checking for stdio.h... yes checking libgimp/gimp.h usability... no checking libgimp/gimp.h presence... no checking for libgimp/gimp.h... no checking libgimp/gimpcompat.h usability... no checking libgimp/gimpcompat.h presence... no checking for libgimp/gimpcompat.h... no checking sane/sane.h usability... yes checking sane/sane.h presence... yes checking for sane/sane.h... yes checking for usb_get_busses in -lusb... no checking usb.h usability... no checking usb.h presence... no checking for usb.h... no checking for deflate in -lz... yes checking zlib.h usability... yes checking zlib.h presence... yes checking for zlib.h... yes checking locale.h usability... yes checking locale.h presence... yes checking for locale.h... yes checking for LC_MESSAGES... yes checking libintl.h usability... yes checking libintl.h presence... yes checking for libintl.h... yes checking for ngettext in libc... yes checking for dgettext in libc... yes checking for bind_textdomain_codeset... yes checking for msgfmt... /usr/bin/msgfmt checking for dcgettext... yes checking if msgfmt accepts -c... yes checking for gmsgfmt... /usr/bin/msgfmt checking for xgettext... no checking for catalogs to be installed... cs da de el es fi fr hu id it ja ko nl nb pl pt ru sv th tr zh zh_TW configure: creating ./config.status **config.status: error: cannot find input file:’

Hope that someone can help.

have you installed libtool? Also don’t build as root user, you only
need to use root or sudo to install.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 7:30, 4 users, load average: 0.06, 0.04, 0.06
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21

cool. thanks a lot - libtool was missing. now the configuration is ok, but make has some errors. Can you help me with these too? Thanks in advance.

mmarkus@linux-rq5v:~/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp> make
make all-recursive
make[1]: Entering directory /home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp' Making all in po make[2]: Entering directory /home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp/po’
make[2]: Für das Ziel »all« ist nichts zu tun.
make[2]: Leaving directory /home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp/po' Making all in backend make[2]: Entering directory /home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp/backend’
/bin/sh …/libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I… -I. -I./include -DV_MAJOR=1 -DV_MINOR=4 -O2 -D__GIMP_PLUGIN_ENABLE__ -MT libsane_canon_mfp_la-canon_mfp.lo -MD -MP -MF .deps/libsane_canon_mfp_la-canon_mfp.Tpo -c -o libsane_canon_mfp_la-canon_mfp.lo test -f 'canon_mfp.c' || echo './'canon_mfp.c
…/libtool: line 752: X–tag=CC: command not found
…/libtool: line 785: libtool: ignoring unknown tag : command not found
…/libtool: line 752: X–mode=compile: command not found
…/libtool: line 902: *** Warning: inferring the mode of operation is deprecated.: command not found
…/libtool: line 903: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
…/libtool: line 1046: Xgcc: command not found
…/libtool: line 1046: X-DHAVE_CONFIG_H: command not found
…/libtool: line 1046: X-I.: command not found
…/libtool: line 1046: X-I…: command not found
…/libtool: line 1046: X-I.: command not found
…/libtool: line 1046: X-I./include: No such file or directory
…/libtool: line 1046: X-DV_MAJOR=1: command not found
…/libtool: line 1046: X-DV_MINOR=4: command not found
…/libtool: line 1046: X-O2: command not found
…/libtool: line 1046: X-D__GIMP_PLUGIN_ENABLE__: command not found
…/libtool: line 1046: X-MT: command not found
…/libtool: line 1046: Xlibsane_canon_mfp_la-canon_mfp.lo: command not found
…/libtool: line 1046: X-MD: command not found
…/libtool: line 1046: X-MP: command not found
…/libtool: line 1046: X-MF: command not found
…/libtool: line 1046: X.deps/libsane_canon_mfp_la-canon_mfp.Tpo: No such file or directory
…/libtool: line 1046: X-c: command not found
…/libtool: line 1097: Xlibsane_canon_mfp_la-canon_mfp.lo: command not found
…/libtool: line 1102: libtool: compile: cannot determine name of library object from ': command not found make[2]: *** [libsane_canon_mfp_la-canon_mfp.lo] Fehler 1 make[2]: Leaving directory /home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp/backend’
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/mmarkus/Downloads/Linux_Scangear_Source_Files/scangearmp-source-1.40-1/scangearmp’
make: *** [all] Fehler 2

../libtool: line 1046: Xgcc: command not found

You need (at least) gcc. To compile you’ll need a compiler.

[Please use code- instead of quote-tags for command line output]

Edit: If I were you I’d try the .rpm-packages of ‘scangearmp’ provided by Canon instead first. In case it won’t work, you can uninstall them easily anyway and then proceed as planned.

gcc and gcc c++ is already installed which compiler do I need? I already tried the package version of canon, but then many packages have to change the architecture from 64 in 32 bit and I don’t want that.

Hi everyone, yes there are problems with the Canon sources, and please, the one who own the Canon hardware, send a complain to Canon.

And now the fix. I was with the same problem, and I asked on #suse on freenode. The user Yaloki checked the src and find out problems with the spec file. And he build an OBS repositorie for us:

Index of /repositories/home:/pbleser:/staging

You can install both, printer and scanner drivers. But be hurry, that repository can be here forever because license issues. the scanner packages are not GPL, they include precompiled libraries without the source code, the printer drivers are GPL but also contain an EULA which is not compatible with it. I have sent an email to support and we are waiting the answer.

After you install the scangearmp you must launch “scangearmp” from terminal, it doen’t work with sane, at least for me, and software launches but it doesn’t work propperly, it always fails to scan.

If you can make it work, drop a line.


From other websites, I have found these steps are needed:

To avoid the faulty parsing “…/libtool: line 752: X–tag=CC: command not found”:

libtoolize --force --copy

Then run:


it seemed to work, but I don’t know if this a really clean solution.

… and other packages I needed to install on a fairly new machine were:

sudo apt-get install automake autoconf libgimp2.0-dev libtool libsane-dev