Can no longer start X because driver seems to be missing

I had to uninstall a proprietary ATI driver because it wrecked my X server. Apparently I removed the wrong package, because now the X server won’t even start, even with the “nomodeset” flag.

How can I configure WiFi on the command line with NetworkManager or ifup, whichever is easier?

Which packages do I need to download to restore the X server?

Wi-fi (assuming no security)

ifconfig wlan0 up
iwlist wlan0 scan
iwconfig wlan0 essid "your net name" ap <your mac address>
          An Example: "iwconfig wlan0 essid "mynetw0rk" ap 00:11:22:34:55:66
dhcpcd wlan0

iwlist lists all available networks, pick yours out and get the essid and bssid (mac address)
If you need to use a WEP or WPA key, check the man on iwconfig and wpa-supplicant.

As for X:

sudo zypper in xorg

Also, in future thread requests please make your title more relevant to the subject of your questions.

My WiFi uses WEP. (Yes, I know it’s insecure, but we have legacy hardware in our household that doesn’t support WPA.)

Here’s what I did:

A ping to failed. What am I doing wrong?

Not a thing wrong.
dhcpcd is being weird. I get that problem sometimes. When you boot, boot with the option “init 3” and then do a

ps -a

If a dhcpcd process is listed, use

kill <pid>

using the <pid> of the dhcp process and try again.

If dhcpcd doesn’t show up, try the above commands again.

*Just “su” once instead of “sudo” multiple times. Use “exit” to stop "su"ing.

Can you post the output of:

route -n

Still no luck with dhcpcd.

My router is supposed to hand out IP addresses in the form of 192.168.1.x, which makes it weird that dhcpcd obtained a completely different address.

route -n

ifconfig for wlan0


Try this:
Internet loss when changing networks
And also make sure the IP address for your router is correct in /etc/resolv.conf.

Someone in that thread mentioned nmcli, a tool that can configure NetworkManager on the command line. Seems a lot easier than messing with ifup, so I was able to get eth0 up and running (had to sit next to my router) and do some additional research.

sudo startx mentioned that the fglrx driver was missing, which appeared to be a configuration leftover from when I had the non-functioning ATI driver. Then I backed up my current Xorg.conf and let startx start with default settings. Worked fine! I assume that my computer is back to using the non-proprietary radeon driver now.

can you check which kernel you are using; if you are using 2.38 from the tumbleweed then there is a problem with the new kernel/ati driver and ati repositories. It happened to me and there is a solution.

  1. if you have all the two, i.e 2.38 kernel and ati repository then ati repository in your yast, it removes kernel-desktop-base of 2.38 and installs from 2.37. (after this I had no internet connection).

  2. I disabled ati repository and reinstalled kernel-desktop-base for 2.38 and used the following patch to install the proprietary ati driver … follow the link for patch and the file to take care of.

ati driver issues on tumbleweed 2.6.38-18-desktop kernel


I was able to get the proprietary ATI driver to work. I have kernel-desktop-, so no issues here. I used the repository listed on SDB:ATI drivers - openSUSE.

good if all is working for you. I had network problems with the kernel-desktop- and 2.6.38 kernel.