Can no longer read CDROM's or USB Devices


I have a Dell laptop running XP Pro with VM Player running SUSE Linux 9 (SP4).

I recently upgraded SUSE to SP4 from CD and although I cant confirm 100% it seems since this the USB drive or CD drive will not work within the OS.

If I open My Computer (SUSE) I only see the FDD. Under /media I see cdrom, cdrecorder, floppy, usb-********* but when opening the directories they are blank.

This used to work with SUSE SP3 and I loaded SP4 from CDROM so really confused as to what has gone wrong here.

fstab entries

/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/cdfd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/cdrom /media/cdrom subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Hope somebody can help this is driving me mad!!

You appear to be using SLES/SLED or similar, so you’d be better off posting here:


This forum is for openSUSE.

Firstly, Version 9 is old and you are probably better switching to one of the latest versions.
As a first attempt, try removing the fstab entries and see if the cdrom is mounted.
Most of the latest versions automount the media in the /media directory. If this doesn’t work, try forcing a cd to mount with something like:
mount -t iso9660 /dev/cdrom /media/cd
(make sure you have created the directory cd)

Thanks - Will move post

Unfortunately I cant upgrade due to an app that needs to run on this version. I have tried removing the entries in fstab no luck.
Mounting it manually returns not a valid block device!
I have logged in as root and tried to run the patch update direct from cd but receive device: not attached. Its not happy!

If you look at the boot messages, you should get a message that says the cd drive and usb ports are recognised and the name of the cdrom device.
Instead of using /dev/cdrom try /dev/dvd.

You can’t get the app source and recompile it for the new version?