Can no longer mount nfs to remote NAS

I can no longer make working connection to remote NAS with nfs.
I have been using Yast NFS client configuration page. Selecting Add and using the IP address of the remote NAS (which is on the same subnet) I can browse to the nfs exported directories and select the directory I want. I have then selected Force NFSv4 as advised here and enabled nfsv4 on the NAS.
I have created a directory /usr/local/Nas3_W530_backup and selected OK. This appears to complete the configuration successfully but when I then select OK the mount fails with the message:-

command ‘/bin/mount -t nfs -o ‘nfsvers=4’ ‘192.168.169.131:/W530_backup’
‘/usr/local/Nas3_W530_backup’’ failed:

stderr:
mount.nfs: mounting 192.168.169.131:/W530_backup failed, reason given by
server: No such file or directory

exit code:
32

I have tried this with firewall stopped and this still does not work. The error message suggests there is something at the server end stopping the connection but only a guess.

In desperation I have tried using samba and if I stop the firewall the shares can be seen and I can copy files from the NAS to local folder but I cannot work out which services to enable. I have tried samba and samba-client (which is correct I do not know) but neither nor both work. Am reluctant to work without firewall so am asking again for help please.

Please show


cat /etc/fstab

and the actual location and settings of the share on the NAS.

Show the export(s) available from the NAS eg

sudo showmount -e 192.168.169.131

Show us what happens when you attempt to mount manually eg

sudo mount -t nfs4 192.168.169.131:/W530_backup /var/nfs_share/
alastair@localhost:~> cat /etc/fstab
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /                       btrfs  defaults                      0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=10A2-1035                             /boot/efi               vfat   utf8                          0  2
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=d3acdb3b-fed4-4676-bb15-dc32dfd6c835  swap                    swap   defaults                      0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /var                    btrfs  subvol=/@/var                 0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /root                   btrfs  subvol=/@/root                0  0
UUID=ab51d09c-1257-45c0-938d-792fedccde55  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=e3a09502-9453-4a94-a88d-07c5119d13ed  /home                   ext4   data=ordered                  0  2
alastair@localhost:~> 

https://susepaste.org/48445696

I have lost my message but here is raw data and I can give more on NAS as required.

alastair@localhost:~> sudo showmount -e 192.168.169.131
[sudo] password for root: 
Export list for 192.168.169.131:
/ibmserver2             
/homes                  
/X3400_Home_Backup      
/Web                    
/W530_backup            
/Usb                    
/Temp_Linux_Data        
/Scanned_Docs           
/SageBRP                
/Recordings             
/QB_Files               
/Public                 
/New_X3400_Home_Backup  
/Network Recycle Bin 1  
/Multimedia             
/Iris_T530_Backup       
/Download               
/Delltop_Files          
/Dell_Office_Backup     
/AsusA7V_Archive        
alastair@localhost:~> 

alastair@localhost:~> sudo mount -t nfs4 192.168.169.131:/W530_backup /var/nfs_share/
mount.nfs4: mount point /var/nfs_share/ does not exist
alastair@localhost:~> 

This makes sense because I created a folder at /usr/local/nas3_data and used it in the NFS client setup. When does /var/nfs_share get created?

It was based on a post in your last thread. Change it to reflect your actual mountpoint, and demonstrate to us that you can mount the NFS filesystem.

Just an idea…

@Budgie2: Can you try leaving the export path out ie like this…

sudo mount -t nfs4 192.168.169.131:/ /usr/local/nas3_data

and not this

sudo mount -t nfs4 192.168.169.131:/W530_backup /usr/local/nas3_data

Does the first mount command work successfully?

While waiting for the output of his manual mount, could there be a missmatch of NFS versions?

Absolutely, although the OP mentioned that they had enabled NFSv4 on the NAS.

Here are results pointing at mount point I had created, with and without the end slash as I cannot recall which it should be.

alastair@localhost:~> sudo mount -t nfs4 192.168.169.131:/W530_backup /usr/local/nas3_data/
[sudo] password for root: 
mount.nfs4: mounting 192.168.169.131:/W530_backup failed, reason given by server: No such file or directory
alastair@localhost:~> sudo mount -t nfs4 192.168.169.131:/W530_backup /usr/local/nas3_data
mount.nfs4: mounting 192.168.169.131:/W530_backup failed, reason given by server: No such file or directory
alastair@localhost:~> 

After a fashion. I seem to have a few other shares I use but not the wanted target. Here is what I have now:-

alastair@localhost:~> sudo mount -t nfs4 192.168.169.131:/ /usr/local/nas3_data
[sudo] password for root: 
alastair@localhost:~> cd /usr/local/nas3_data
alastair@localhost:/usr/local/nas3_data> ls
ibmserver2  Multimedia  Public
alastair@localhost:/usr/local/nas3_data> 

Hi Henk,
I have checked this as far as I can. Here is the screenshot of the control page:-

https://susepaste.org/69059208

Should be OK on nas but there is a whole lot of security stuff which can be associated with nfs4 which I have never set up.

Since the mount works without the W530_backup path and it does not show up in the mountpoint, I assume it is

  1. Not in the location you reported
  2. Has no access rights.
  3. The NAS configs that you should be looking at, not the openSUSE NFS config.

There you go. You need to look at your NAS setup.