Can linux not play video?

I don’t know what I am doing wrong but I have 3 computers running open suse and all of then do not play video over a network without skipping.

I am starting to think that opensuse just can’t play video over a network.

What could possibly be the problem. I have spent hours playing with settings with no solution.

Yes, openSUSE can play video over a network.

You should provide a bit more information on what you’ve tried. Using videolan (vlc) is an easy way to achieve that.

I have. A week ago I posted a long detailed post that no one replied to. Now I am just frustrated.

I have a Windows media center that the video files are stored on. I Thought maybe the DVR_MS file format might be the problem so now I have a program on the windows system automatically converting all the videos to MPG. I tried VLC with no luck right now I am using Kaffene. There is constant skipping, I mean constant. Like watching a movie on a bad drive through window.

The system I am using is well within the system specs for video.

AMD 2800+, A7N8X-Deluxe, 1G Ram etc.

I have completely given up on the computer in my garage. It just keeps getting slower. its a 1.2Ghz AMD with 512Mb of ram with opensuse 11.1 and KDE 4.1 Its so slow you can barley surf the web. I think I am going to load KDE 3.5 on that one.

I wonder if all my problems are just KDE 4.1.

I’m assuming that since your server is Windows-based that you’re using Samba to interconnect the machines. Correct me if this is not the case.

  • What link-layer protocol are you using to transfer the files? (standard Ethernet, wireless, etc.) If you’re using wireless, are there any devices that might cause slowdowns, like bridges?

  • How exactly are you opening the files? Are you opening them from Network Places, streaming them over a SMB- or CIFS-mounted directory, etc.?

  • Have you tested simply copying a large file from your Windows machine to your SUSE box and observing the data transfer rate for overall speed and hiccups? It’s possible your problem is related to your network setup.

  • Have you tested setting up Samba server on one of your other SUSE machines, putting a video file on it and attempting to stream from another SUSE machine?

  • Tried mounting the Windows file share manually and using mplayer from the command line to stream a video file from the network mount?

  • Tried using a different networking protocol like an FTP folder?

  • Tried reading your system logs for errors?

I use openSUSE 11.1 on a network with two XP machines and have no problems with streaming media using any player. But Linux is Linux, and as much as I love it it’s not without its… nuances. :slight_smile:

It could be KDE related, however it could also be network related. Try
running xrestop, top or the system monitor to investigate.

Are all your network interfaces setup at optimal settings eg
full-duplex 100MBs etc. Use ethtool eth(x) as root user to investigate.

Not getting bursts of broadcast traffic or are packets getting
dropped causing the stuttering. Use wireshark to investigate by running
a capture.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 8:34, 2 users, load average: 0.50, 0.54, 0.35
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

To answer your questions

The network is hardwired through a wrt5gG running DDwrt firmware

I am running the files just by dubble clicking on them. I have the Windows shares mounted localy.

sudo mount -t cifs -o username=administrator,password=***** //PVR/music /home/rich/Desktop/Shares/Music"

I have copied the files over and they play much better. I am sure it is network related but I have not been able to determine why because the network runs very well if not playing video. Transferring files is very quick. Transferring a video file not playing moves twice as fast as when its playing.

I have not tried playing a file from another suse machine but I can.

Shares are mounted locally. Not sure how to use mplayer to mount a share?

No FTP available on the windows MCE. I don’t want to add to many programs to it because its primary job is running my TV in my living room. Plan on using Myth soon if I can solve this.

Logs no, Honestly I am not sure where I would look for anything video related.

I have ran top, I don’t believe its system resources. While playing a movie My CPU will rest at around 50% and I normaly have free physical mem.

I assume all network is setup correctly, It works great in everything else. At this point I am thinking it has to be network related but to what extent I cannot figure out.

Not sure how to run wireshark.

It should put an icon in the menu system, run this and it should ask
for the root password (needs to be root user to set the interfaces in
promiscuous mode) then select the ‘Capture’ menu item -> interfaces and
select your active interface. It will start capturing then, observe the
output for a period to see what is normal. Then start your streaming
application to see the activity.
I would also setup the monitoring on the media server to observe the
system load/processes etc as well.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 9:18, 2 users, load average: 0.08, 0.04, 0.06
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

If running wireshark doesn’t turn up anything, then try these.

Shares are mounted locally. Not sure how to use mplayer to mount a share?

My mistake – I meant, mount the share, then play the video on the share using mplayer:

> mount -t cifs etc. //share/name /local/path
> mplayer /local/path/video.mpeg

Logs no, Honestly I am not sure where I would look for anything video related.

You wouldn’t be necessarily looking for video-related errors. Check /var/log/messages and maybe /var/log/warn for networking-related errors.

Also, what bitrate are these videos encoded/transcoded at?

And yes, if you are using KDE4.1 the network speed problem could be KDE related, using networkmanager?
If you want better performance either use 4.2 from factory (huge difference since 4.1) or stop using beta software and use 3.5

I wanted to wait for 4.2 untill beta was over. I am not using networkmanager. I have the network setup through yast.

I really like KDE4 I don’t want to go back to 3 on this system. I plan on going back to KDE3 on another system I have.

I will look at the logs tonight when I get home. I am at work right now.

The video is recorded at the highest quality media center can record at. Not sure about the bitrate but the files are about 2G per hour.

Can I install that through yast or does it need to be from source?

The video is recorded at the highest quality media center can record at. Not sure about the bitrate but the files are about 2G per hour.

This might be part of the problem. That’s a phenomenally high bitrate. Just as a test, can you encode one of the videos down to, say, 1800 kb/s and try streaming that? (I know that’ll give bad quality, but this is just a test against your network and media players.)

YaST or zypper in wireshark :slight_smile:

Sounds like it maybe a combination of both DE and network…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 11:24, 1 user, load average: 0.03, 0.46, 0.42
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

I have had the same problems playing an AXXO but not at bad. I am sure its the large file size thats causeing problems becuse a half hour show does not skip as bad as an hour show and above that is unwachable.

I can normaly watch an AXXO movie all the way through.

I have also tried turning off desktop affects and I don’t run conky when playing a video. Both of these don’t make a diffrence.

An added note I am using Nvidia’s drivers with dual head video enabled.

Codec problem then maybe? I’m still thinking it’s network related.

I just tried streaming one of my vids. It’s 3.4 GB and 15 mins long, 24 bpp, 29.97 fps and the bitrate is a respectable 29000kb/s and it’s coming over a mounted CIFS share. I played it all the way through and it never skipped.

The thing that has me wondering is that the same problem is happening with 3 systems, all with diffrent hardware configurations but with the same software. Now the slower system is the worce. It seams to get worce as the systems get slower.

With that in mind I don’t think its fully hardware related becuse on one system the resorces are not maxed when its happening. While on the slower systems the resorces are maxed. I still think all 3 systems sould be capable of streaming video. Atleast all 3 did with winodws before.

Here’s another thought, network chipset getting hot on the router with
the sustained traffic. What happens if you drop the interface speed

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 11:47, 2 users, load average: 0.05, 0.06, 0.12
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22