Can I re-install over broken system?

I’m fairly new to linux, and just managed to seriously mess things up for the first time.

I was trying to resize a partition used as a shared folder by a Windows XP virtual machine. Somewhere in the process of deleting the FAT partition, resizing the ext3 partition, and creating a new FAT partition my system broke. I had to run the system repair funstion from the installation media, which worked well enough to get me back online, obviously.

OpenSuse had been installed into a fresh hard drive. The 2 hard drives from my old machine were then added to the machine. One of those hard drives had been formatted as ext3 then resized to allow the Fat partition. The last hard drive had been left as NTFS for the time being.

My Fat partition refuses to mount. The NTFS drive I did nothing to refuses to mount. VirtualBox says it needs to be reinstalled. Maybe other programs are messed up…I’ve only had time to try a few.

So my question is, can I just do a fresh install of OpenSuse into it’s original swap and root partitions, and solve all my problems? I gather I’ll have to force the ntfs drive to mount then, and I assume I may have to reinstall some programs.

My main concern here is preserving the user settings I have set up for Mozilla, Vuze, Filezilla and etc…99.5% of my data is safe on my main partition on the new drive, and just a tiny amount is left on the NTFS.

Sure you can, but if you have made a separate /home partition for all your data (which you didn’t say if you have made one or not) then reinstalling and keeping all your custom settings in /home is a lot easier than having one big partition for the root where also your /home is as you’ll have to restore every setting from backups, so if you aren’t using a separate /home partition, you should do so upon reinstalling. I recommend this setting

/ --------> 10-20 GB
swap —> 1-5 GB (depending on your needs)
/home → The rest of the disk space (it’s where all your user files will be, including settings)

Also, I am wondering how did you manage to resize an ext3 partition while trying to resize a shared folder partition used under VBox? This is very weird, unless I’m not getting what you did

As for FAT/NTFS not mounting, when you try to mount them from terminal, what massages do you get? Also check in /etc/fstab to see if you have entries for these partitions

That’s great news, thanks. I went with all the defaults when I first installed, so I have a 2GB swap and 20GB root on a 1TB drive, and the rest is /home.

I probably should have gone to bed instead of messing with those partitions last night, but I think the sequence went something like this:

  1. Shrink ext3 partition to make room for bigger fat.
  2. Tried to resize fat, found out I couldn’t, then deleted it.
  3. Resize ext3.
  4. Create fat.
  5. Try to mount both.

I was using the YaST partitioner and the terminal at the same time, and checking Nautilus to see if my changes had any effect. At some point I found that I could no longer launch the system monitor, YaST, or the terminal, and after rebooting I no longer had a desktop.

damascus@linux:~> su root

linux:/home/damascus # mount /dev/sdc2
mount: can’t find /dev/sdc2 in /etc/fstab or /etc/mtab

linux:/home/damascus # mount /dev/sdb1
mount: can’t find /dev/sdb1 in /etc/fstab or /etc/mtab

linux:/home/damascus # modprobe fuse
FATAL: Could not load /lib/modules/ No such file or directory

sdc2 is the fat partition. It shows up in Nautilus as 53.8GB Media and when I try to select it I get an error saying that it uses vfat which is not supported by my system. sdb1 is the NTFS drive. When I try to select it in Nautilus I get an error about not having fuse in NTFS-3G.

Download Parted Magic Downloads - Parted Magic
Boot with it and use the roxterm to get us the output of

fdisk -l

You could open the partitioner too and take a screen of it. Upload the screen to a hosting site and paste the link here.

Managing you partitions from Parted Magic would be a better choice IMO.

Is this what you are looking for? I can run Parted Magic tomorrow. Perhaps I haven’t messed things up as badly as they seem, although I tend to be obsessive about having my operating systems “perfect”.

I need Parted Magic info
Unless you can get fdisk -l from your current running sys?

damascus@linux:~> su root
linux:/home/damascus # fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00025f46

Device Boot Start End Blocks Id System
/dev/sda1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sda2 * 263 2873 20972857+ 83 Linux
/dev/sda3 2874 121601 953682660 83 Linux

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x16141614

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 19456 156280288+ 7 HPFS/NTFS

WARNING: GPT (GUID Partition Table) detected on ‘/dev/sdc’! The util fdisk doesn’t support GPT. Use GNU Parted.

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2d8412ab

Device Boot Start End Blocks Id System
/dev/sdc1 1 32376 260052186+ 83 Linux
/dev/sdc2 * 32376 38914 52519003 c W95 FAT32 (LBA)
/dev/sdc4 1 1 0+ ee GPT

Partition table entries are not in disk order
linux:/home/damascus #

Parted Magic tomorrow. Thank you for all the help. I also have no audio.

Some explanation would help us. Include disk type, internal/external and so forth…](

I installed OpenSuse on a new Western Digital 1TB drive with 2GB swap (sda1), 20GB root (sda2), and the rest a single partition (sda3).

The NTFS drive is a 160GB Seagate with a single partition, sdb1.

The last drive is a 320GB Seagate with approx. 50GB fat partition (sdc2) and the rest ext3 (ext1).

I now am also unable to burn media, but got a copy of Parted Magic burned on another machine and can boot into it later. Thanks.

you need to add yourself to the cdrom and disk groups if you want to burn something. This is a known problem

I can’t see a re-install being necessary. You will need to have mount entries in fstab. Lets see that with:

cat /etc/fstab

After my last post I found myself with a system I was unable to boot, and the other computer here was offline. So I went ahead with a re-install using the existing partitions from the initial install. All my partitions are mounted, I’ve lost no data or user settings, and I’m reinstalling software.

However my initial install was done with only the new TB hard drive in my machine, and the 2 from my old machine were added later. This time all 3 drives were in the machine, and I ended up having an error message during boot (OS not found, then it went to splash anyway). I believe I’ve fixed this myself by editing Grub through YaST. Thank you to everyone who tried to help me.