Can I get GRUB2 to choose OS at start up without having to re-install Leap 15

I still don’t understand the relationship With how Leap boots to being able to ‘read’ the Windows partitions.
I will post some images later to illustrated,
1- But if I booted Leap via Grub2 boot menu first, I was not able to read the Windows partitions and got the big red box with a lot of warning type text.
>> boot from Grub2 menu
2- If I booted Leap via the Windows boot manager (selecting Leap it brings up the Grub2 boot menu) I was able to read the Windows partitions, <without having to disable Fastboot and/or hibernation’.
>> Boot Leap From Windows boot menu

Had to ad more text or it wouldn’t let me complete the post… too short it said(Weird I had already added text!)

When a Windows file system is in a hibernate state Linux can not mount the partition so can not chain to it. Simple as that.

The Windows boot manager is part of Windows. And, from what you describe, it apparently fixes any problems with its file systems before it boots another system.

Good things to know malcomlewis! I Keep forgetting to hold the shift key down when shutting Windows down via the Start Menu.

OK> remember fastboot was enabled when I started Leap from the Grub2 menu(image 1 in above post) AFTER I ran the make_config for grub to get Win10 in the Grub2 menu.

But?? That was not all of my ‘problem’.
If I started Leap via the Grub2 Menu and Windows had not been started I COULD NOT read or mount the Windows partitions.

BUT, if I started Leap via the Windows Boot manager(see image 2 in my post above), and ‘fastboot’ WAS enabled. I COULD read and mount the Windows partitions.

Once I changed Windows to disable Fastboot, I can read/mount Windows partitions regardless if I boot Leap via Grub2, or via the Windows Boot manager.