Can I get GRUB2 to choose OS at start up without having to re-install Leap 15

Current situation:

  • HP desktop DMC7700 CMT (Compaq),

  • Windows 10 and windows 7 on main SATA HDD(500GB)

  • Leap 15 installed on a PATA HDD(160GB) connected to the machine via an installed card(there are no MOBO connections for a PATA HDD).

  • Windows Boot manager starts first, lets me select between WIn10, Win7, and Leap 15 on the PATA HDD

  • I would like to forget Win7, and get rid of the EasyBCD boot stuff, and have GRUB2 recognize Leap 15, and Win 10.

  • I think someone in the past said there is an NST directory in Win10 that controls the Grub4DOS thing that comes up when I select Leap15. THEN i get a GRUB2 menu.

So, Windows boot menu, select Leap 15 out of three choices, Grub4DOSS shows up, I can select Leap 15 ,wait for it to boot, then get on with doing and learning.

Easy enough to get rid of EASYBCD portion, but I do still need to access both Leap 15 and Win10(for printing and tax prep).

I need to get serious about this. I don’t like all the hubbly-bubbly that has to happen to get to Leap 15, and still have access to Win10.

Can this be done ‘easily’ without having to re-install Leap 15 from scratch?

For some definition of “easily”, maybe. It depends in part on whether the PATA card has a boot BIOS, whether Windows is installed in UEFI mode (unlikely with Grub4DOS involved), and mainboard BIOS enumeration order (the card may need to be found before the SATA controller), among other things. Bootinfoscript output should help in trying to make this determination, but my guess is not “easily”, unless an expert is at the keyboard.

Would you dare to adjust the involved configuration files for a customised boot menu (besides the EasyBCD approach)?

So I guess the answer is no!

Depends on which configuration files are involved, and the degree of difficulty.

It could be easier. Move the PATA disk onto an SATA port by using a PATA to SATA converter instead of the PATA card, and you won’t have enumeration or BIOS issues to contend with. Another way to avoid those two issues would be to put a Linux /boot partition on the SATA HD, a possibly much simpler operation than a complete reinstallation.

How do you think about to become familiar with boot menu editors?


My AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4 has a GA-MA78G-DS3H board which offers a hard disk boot order menu. It can offer the built in pci controller card as the first option to boot from. If that works for your machine too, you may by default boot from the linux drive. Install grub2 on the linux disk and tell it to search for other systems.

A lot to think about!
@karlmistelberger>> I don’t think the HP Compaq CMT bios offers boot from drive connected to a pci card but I will take a look.

I don’t remember when I was installing on that PATA pci connected drive, if the installer recognized that Win10 was there on another drive(should have taken notes).

If it does, I don’t have that much invested in the install, and would consider a reinstall after getting rid of EasyBCD, and the NST directory in Windows, and just reinstall it again.

I will also look into the other suggestions by elf ring and mrmazda.

In many old BIOS it was called boot from SCSI, which essentially meant boot from an off-motherboard, non-[MFM,RLL,IDE] drive controller that hosts its own boot BIOS.

OK! the BIOS does allow me to boot from the disk on the pci card. It booted fine, but of course the Windows 10 OS was not on the GRUB boot menu.
Now to figure out how to get GRUB2 to recognize the OS on the SATA drive.
That i is assuming GRUB2 is already installed in the Leap 15 install.

GRUB2 is in the Leap 15 install, and the ‘grub’ setting for OS PROBE in the /etc/default/ directory is


I assume that grub is not finding the ‘on-board’ HDD with Windows 10 on it.

YES! Thank you for pointing me in this direction.(Think Linux first, then Windows, instead of Windows first)
All I had to do was run the script for updating the grub config files(s) and it found Win10 and added it to the GRUB2 boot menu.
Now It boots to Grub screen allowing me to choose Leap 15 and it’s ‘advanced’ options AND Windows 10 on the on board HDD.
If I select the Win10 option it takes me to the Windows Boot Menu where I can choose either Win 10 or Win 7.

No maybe I can get rid of easyBCD and all of its foibles.
Again, thank you!

You are welcome. Thanks for reporting. I think, cloning Leap 15 to a cheap SSD would boost performance considerably. That is what I observed with the Athlon 4850e which has a Kingston SSDNow V300 60GB (pretty obsolete nowadays) shared by openSUSE 13.1 and Xubuntu 18.04.

I still have a problem. Maybe booting from the PATA first is not the way to go.

After booting to Leap 15 from the Grub2(PATA HDD), I can’t ‘mount’ the Windows partitions.

If I boot from the Windows boot manager, they mount fine.

/etc/fstab/ is the same for both boot methods. The Windows partitions are not present.

Booting from the PATA and opening the file manager, and selecting a Windows partition, I get a big red warning box that says Windows is in hibernation and to close out Windows, or mount the partition as read only(ro).

If I boot using the windows boot manager, open the file manager, the Windows partitions mount with no error box.

I am just pondering if adding the Windows partitions to /etc/fstab/ will cause other problems after booting from the PATA HDD Grub2 menu.

I can post images and other information later when I get back to that desktop if needed.

Be sure that fast boot is off in Windows. It leaves the partition in a hibernation state

I will check to assure Fastboot is still disabled in Windows.

If I boot into Leap from the PATA HDD Grub menu, Windows has not been started, and the Windows partitions are ‘blocked’.

But if I select Windows 10 from the PATA Grub menu, it brings up the Windows boot manager.
If I select and boot Leap from there the Windows partitions are ready available.

Thanks for the tip
The Fastboot setting in WIn 10 was in fact ‘enabled’, AGAIN!
Gonna have to start checking Win 10 after each major update!

I’ll just note that disabling fastboot might not be enough. I found that I had to also disable hibernation in Windows.

I will keep that in mind if things go weird again.
I still don’t understand the relationship With how Leap boots to being able to ‘read’ the Windows partitions.
I will post some images later to illustrated,
1- But if I booted Leap via Grub2 boot menu first, I was not able to read the Windows partitions and got the big red box with a lot of warning type text.

2- If I booted Leap via the Windows boot manager (selecting Leap it brings up the Grub2 boot menu) I was able to read the Windows partitions, <without having to disable Fastboot and/or hibernation’.

There is a program that runs called os-prober (run the command manually as root to see), it checks all disks in the system and looks for the boot flag (or efi) and adds to the grub menu… that’s assuming you have it set to check for foreign operating systems via the YaST bootloader check box, or manually tweaked /etc/default/grub file…

All it does for dos type disks is add a chainloader command to boot that disk which has the ‘boot’ flag set on the partition.

For windows I always add a desktop shortcut called ‘Full Shutdown’ with the following command added;

shutdown /s /t 5

Or if you select shutdown from the menu, hold the shift key down it does the same thing, full shutdown.