Can I enable NVIDIA drivers without root access?

I want to enable the desktop effects (such as smooth minimising, smooth viewport switching, etc) but it says that “Desktop effects are not supported on your current hardware / configuration. Would you like to activate them anyway?”

My first question is how do I check to make sure whether the NVIDIA drivers are enabled or not? (I know they’re on the system, since ‘NVIDIA X Server Settings’ is in the list of applications).

My second question is how do I activate these drivers?

Note that I don’t have root access, since I’m using a university machine, so I can’t edit the xorg.conf or anything like that.

Thanks

openSUSE 11.3 64bit
GNOME desktop

My first question is how do I check to make sure whether the NVIDIA drivers are enabled or not? (I know they’re on the system, since ‘NVIDIA X Server Settings’ is in the list of applications).

See if this helps:

openSUSE Graphic Card Practical Theory Guide for Users

This command may reveal the active graphics driver, but it may not be conclusive:

/usr/share/hwinfo --gfxcard

Note that I don’t have root access, since I’m using a university machine, so I can’t edit the xorg.conf or anything like that.

That will be problematic then.

In the terminal it says that /usr/share/hwinfo is a directory. There are 2 files in there, ISDN.CDB.txt and ISDN.CDB.hwdb. I’ve tried the same command on those files, but it says permission denied.
I had a look at the graphic card practical theory guide, and came across this command:
cat /var/log/Xorg.0.log | grep ‘(‘II’)’’ 'NVIDIA

Here is the output:
31.376] (II) NVIDIA GLX Module 256.53 Fri Aug 27 20:50:26 PDT 2010
32.660] (II) NVIDIA dlloader X Driver 256.53 Fri Aug 27 20:29:45 PDT 2010
32.660] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
32.711] (II) NVIDIA(0): Creating default Display subsection in Screen section
32.711] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
32.711] (II) NVIDIA(0): enabled.
33.379] (II) NVIDIA(0): NVIDIA GPU GeForce 6150 LE (C51) at PCI:0:5:0 (GPU-0)
33.379] (II) NVIDIA(0): Assigned Display Device: DFP-0
33.380] (II) NVIDIA(0): Validated modes:
33.380] (II) NVIDIA(0): “nvidia-auto-select”
33.380] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
33.381] (II) NVIDIA(0): Initialized GPU GART.
33.384] (II) NVIDIA(0): Setting mode “nvidia-auto-select”
33.548] (II) NVIDIA(0): Initialized OpenGL Acceleration
33.584] (II) NVIDIA(0): Initialized X Rendering Acceleration
33.587] (II) NVIDIA(0): [DRI2] Setup complete

Does that mean the NVIDIA proprietary driver is being used or not? Is there not a single terminal command I can use to see what graphics driver I’m using?

Thanks for the help

protolocke wrote:

>
> Does that mean the NVIDIA proprietary driver is being used or not? Is
> there not a single terminal command I can use to see what graphics
> driver I’m using?
>
You can try


glxinfo | grep vendor

or more verbose without the grep and look at the vendor and version output.


openSUSE 11.2 64 bit | Intel Core2 Quad Q8300@2.50GHz | Gnome 2.28 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | Gnome 2.30 | Quadro
FX 3600M | 4GB Ram

/usr/share/hwinfo --gfxcard is a typo of deano-ferrari. It should be

/usr/sbin/hwinfo --gfxcard

glxinfo | grep vendor

This gave me:


server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

So I guess I am using the NVIDIA driver. But why is it that my video display is sluggish and that I can’t activate desktop effects without it saying that the desktop effects aren’t supported on my hardware setup?

protolocke wrote:

>
> So I guess I am using the NVIDIA driver. But why is it that my video
> display is sluggish and that I can’t activate desktop effects without it
> saying that the desktop effects aren’t supported on my hardware setup?
>
You run the proprietary driver, I do not really know why your system is
sluggish, but I had the same message when I activated desktop effects on my
notebook with OS 11.3 with nvidia (but the message is wrong there is a
thread somewhere which shows that others had this too with gnome but that
this message does not reflect reality), simply activate them even if it
tells you that they are not supported it should work without problems with
nvidia.

I checked your card NVIDIA GPU GeForce 6150 LE at nvidia.com and the driver
version you have (256.53) is the recommeded one.


openSUSE 11.2 64 bit | Intel Core2 Quad Q8300@2.50GHz | Gnome 2.28 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | Gnome 2.30 | Quadro
FX 3600M | 4GB Ram

/usr/share/hwinfo --gfxcard is a typo of deano-ferrari. It should be

Thanks for the correction Henk. Yes, it was late, and I was tired. The other results suggest all is ok to me.

I am glad all is OK with you.
We all make those silly typos from time to time. We Forum contributers are thouroughly overworked I guess. rotfl!