Can I disable plasma dashboard?

I do not know what exactly it is called but I think it is called plasma dashboard. When I start the desktop, on the top right hand corner, there is a small icon which has three options: Add Widgets, Lock Widgets, Show Dashboard. My question is how to disable this feature? The problem I have is that if I try to move the taskbar to top, it create interference with the taskbar.


There is a lot of talk about adding a configration
option to explicitly remove it. Actually that conversation
has been going on since it first appeared.

You didn’t mention if you are using KDE 4.0.X or 4.1 beta?
In 4.1 there are two cashews, one in the toolbar and the one
you see in 4.0.x. If you have the toolbar along the top,
the larger cashew will move beneath the panel. The smaller one
in the panel will disappear when you select Lock Widgets.

To my knowledge there is no easy way to disable the large
cashew in either version. It is an ongoing source of contention.

From a thread on dot.kde:

‘I patch and recompile the cashew out of existence with each update.’

So you can apparently hack the code and recompile it out…non-trivial.

KDE 4 is still in flux and finding its way. I agree though it is a problem
although it doesn’t interfere in 4.1 it makes for a cluttered appearance
when you have the toolbar across the top, which I do as well.

Thanks for reply. I am using KDE4 so I guess I will have to live with it.

What I want to know is how you moved the taskbar? Mine seems stuck at the top. If I create a new panel it appears at the top on top of the other one.

I tried deleting .kde and .kde4 but other than having to reset my preferences it did nothing. There must be a hack for moving the taskbar to the sides or the bottom. If anyone knows it please post.

BTW, I’m using KDE4.1 RC1

In KDE 4.1, you need to have the widgets unlocked via the cashew
so that the mini cashew is visible in the panel. Next click the mini
cashew. With the new ‘widget control bar’ showing grab an open are like
between the alignment buttons and the +Add Widget button. Then you can
move it around. I bet you tried grabbing the toolbar like I did. :^)
FWIW, It is listed in kde-devel as a bug…but basically it just needs to
be explained somewhere.

Thanks. I played with it until I finally figured out how to move it. I did try to grab the panel itself, but nothing happened. But I noticed as I moved the cursor over the panel (after opening the widget thing with the peanut on the taskbar) that at some point it changed to crosshairs. I clicked there and found I could move it.

Pure luck. :smiley:

Same for me. I installed SUSE 11 with KDE 4.0.4 and while it generally is real nice, I have come to despise the interference of the Dashboard Widgets. I feel a sense of loss of control now that a Right-Click on the Desktop doesnt give me anything but Widget control. I want my Desktop back.

I think the KDEs want to be Mac OS X when they grow up, but this feature provides little value and is intrusive.

Please offer the users an option to take Plasma Dashboard out of its misery.

I have Suse11.0 and I have managed to get rid of this crappy cashew thing. If you execute these commands, it’ll shrink the cashew size from 50 pixels wide down to 0 pixel wide:

cp /usr/lib64/ /usr/lib64/

perl -pi.bak -e ‘s/L\211\347\307EP2/L\211\347\307EP\000/g’ < /usr/lib64/ > /usr/lib64/

Moving the mouse to the top-right will not activate it because it is zero size. However, you can still press CTRL-F12 to activate the dashboard.

FYI: My /usr/lib64/ file is 1604024 bytes in size.

before you bash kde4 why don’t you upgrade to 4.1.2 it is a way better than 4.0.4 and 4.1.2 is being actively developed 4.0.4 is not
im really liking kde 4.1.2 and use it everyday very seldom do i use kde3

Have a look here

i just noticed something very interesting
if you right click on the desktop goto desktop settings and under desktop activity put it on plain desktop the cashew goes away but if you have it on default desktop it is there again so they are implementing something to satisfy some people that don’t like it