Can connect to local network, can't connect to the www

I was following the “Getting your wireless to work” sticky and I’ve my local network working as I can ping both the router as well as other computers in the network.

I however can not ping any external ip address (tried with which is googles and pingable from my other laptop).

It’s a broadcom card that was working fine up till recently (drivers obtained via fw-cutter), however it stopped working a few days ago and my attempts at getting it work to again seem to have done more harm than good now. IPv6 is disabled and the network is set to use ifup. Output from iwlist scan and ifconfig are both favorable indicating a working connection.

Also note this is one openSUSE 11.0 with KDE 4.3.

Did you set the router’s IP to be the standard gateway?
Can you get to the router’s webinterface?

Also: routers are not perfect. I’ve met situations where only shutting down the entire networking, i.e. cable modem off, router off, computers off, and bringing it up again solved connection matters.



I’ll reboot it in a little while.

Okay fixed it, while looking trough the settings once again it noticed it was set to retrieve the DNS via DHCP… but that should be manually in combination with the routers IP.
Now let’s see if I fix the original problem and can get it to connect while using encrpytion.

What are you using, Networkmanager? If so, try switching to traditional method and install and use WICD. Works great, incl. encryption(s).