Can connect through wvdial but not network manager (with usb stick zte 3806)

I’m in openSUSE 13.2 on a hp laptop.
As title says i can connect through wvdial,browse and all,but if i try with network manager it connects …but i can’t browse or even ping anything.
Here are the screens of my configuration of network manager (PIN isn’t needed as it was removed from a cellphone) :

and here is my wvdial conf

[Dialer Defaults]
Init1 = ATZ
Init2 = AT+CGDCONT=1,"IP",""
Modem Type = Analog Modem
ISDN = 0
Phone = *99***2#
Modem = /dev/ttyACM0
Username = .
Carrier Check = no
Password = .
Baud = 460800

I’ve searched on the net for various guides but they were all for other problems (mostly not working at all and isn’t my case as i can with wvdial).

If it was for me i would be happy already …but is not for me,it’s for an old (as in age old) relative that isn’t tech savy and just want it to browse facebook and such.
So i can’t just tell her to go to do all that’s needed to use wvdial,how to connect and disconnect and all.
Tried kppp and umtsmon but none of those work either.
If you need any info (i don’t know what would be useful info) just ask and I’ll post any info you might need.
Thx in advance.

I notice that your two configurations use different APNs:

    I use “” with a smartphone, maybe the other one is needed with a modem?

Buona fortuna…

I have tried both but didn’t change anything ( and since nothing changed i left it there).
As far as I know one is for promotions and one is for normal connections. She has one so I tried in the network manager as well.
One thing I noticed is that with wvdial I need to set google dns in /etc/resolv.conf (using nameserver ) or it won’t even connect, and using the network manager deletes that line so could it be a DNS problem ?

Maybe, but you can set DNS (or any other) manually in the NetworkManager configuration wizard as well…
Set IPV4 to “Automatica, solo indirizzi” and not “automatica”, filling the DNS server box with your choice.

Thx for your fast reply, tried that,and just to be sure even tried (again) with to no avail. Tried to mark the checkbox on the lower left as well and without,stil nothing.
I tried again wvdial to see if I could with that and I noticed network manager added a new ppo connection (though it doesn’t even have an ethernet cable connected) after I was connected with it.
I don’t really know what else to try.

EDIT: The problem both UMTSMon and KPPP have is …they don’t even see the modem whatever I use as port. Checked on yast as well as what is reported in wvdial and set that but they couldn’t see it/use/dialogue with it.

Try opening a terminal and typing:

mmcli -m 0 --3gpp-scan --timeout=300

just to be sure that NetworkManager / ModemManager correctly interface with that zte stick.
If you see the list of available carriers (and namely Vodafone…) ModemManager is talking to the zte.
Otherwise, some HW or driver problem might be there…

OK, seem like there is some interface problem, maybe that ZTE is one of those behaving in a strange way…
Need to do some research before going any further (or hope some UMTS wizard is reading this and kicks in… :wink:


It has been a while since i’ve used wvdial but one thing i’m sure about is that you need to disable NetworkManager if you want to use wvdial.
Also i remember being a member of a certain group but it has been a long while :).

concetta@Concetta:~> mmcli -m 0 --3gpp-scan --timeout=300
error: couldn't find modem at '/org/freedesktop/ModemManager1/Modem/0'

Doing it with sudo is the same. gives the same error even tho i was connected with wvdial ( then disconnected again and tried again…same result).

It could be. I hope to get this solved before monday (as it’s the day she comes to get it back ^^; )

This is taken from yast hardware info:

@jetchisel thx for your reply but as i stated in my OP i don’t want to use wvdial as this notebook isn’t mine and she needs/wants an easy way to connect/disconnect (and for her using wvdial isn’t an option).

Hi Shino, this is somewhat beyond my experience, but if no guru is showing up…
The ZTE 3806 is giving headaches to many people out there, apparently, and to NetworkManager: see this as an example.
To me, seeing it as /dev/ttyACM0 sounds somewhat strange, but would explain why wvdial works.
That device should call up the cdc_ether module as well, which sounds more familiar to me (try lsmod in a terminal and check whether both cdc_ether and cdc_acm are listed as active).
This might confuse ModemManager / NetworkManager.
I would try to blacklist cdc_acm and see if NetworkManager can connect via cdc_ether.
Or the other way around.

If nothing works, well, we have till Monday to find a trick!

Hi and sorry for the late reply, yeah i saw that guide and that’s where i thought i could try kppp and umtsmon. I’ve been searching for anything i could use since friday and I’m not giving up yet.

Yes ,I recall years ago when I didn’t have broadband and the only way to get some sort of it was using them (and I so hated them with a passion…but I still needed it) and there was the problem with wvdial where you actually had wvdial to find it as USB0 or it wouldn’t connect ( while most of the time would be recognised as ACM0 or just as a storage ) on older models of those keys (expecially the E72).
Now and with this model it works as ACM0 as well though.

Seeing as in the Hardware Info from yast the only module i see loaded is cdc_acm i wonder if it would use _ether (and in network manager the only choice is acm).
Since is the only thing that actually works I wonder if it would be possible to make a simple button that would give the command to wvdial to start and another to disconnect, if nothing else works (though i find it very weird that is giving such troubles now with network manager).

On a side note this morning I tried again the command:

mmcli -m 0 --3gpp-scan --timeout=300

and this is the result:

concetta@Concetta:~> mmcli -m 0 --3gpp-scan --timeout=300

Found 5 networks:
22210 - vodafone IT (umts, current)
22210 - vodafone IT (gsm, available)
22288 - I WIND (gsm, forbidden)
22299 - 3 ITA (umts, forbidden)
22288 - I WIND (umts, forbidden)

But still even if it is supposedly connected I couldn’t browse or anything.

This is the result of lsmod that I forgot to put on the earlier post:

concetta@Concetta:~> lsmod
Module                  Size  Used by
cdc_ether              13977  0 
usbnet                 37824  1 cdc_ether
mii                    13654  1 usbnet
cdc_acm                27956  4 

So i suppose they are loaded.

For now i solved the problem using qtwvdialer (a graphical frontend for wvdial)
For those interested here is the guide

And here is the link for the openSUSE package: stil would have liked more to use the network manager but at least it’s easier than using wvdial via terminal.](

Hi Shino, this actually lists the modem as “registered” to “22210 - vodafone IT (umts, current)” but not actually “connected”.
So you are not expected to surf in that state.
This at least shows that ModemManager / NetworkManager are actually engaging the modem and able to talk to it.
I would try the following, to show if NetworkManager actually connects:

mmcli -m 0 --simple-status

I tried the following:

mmcli -m 0 --simple-connect="apn=<your choice>"
mmcli -m 0 --simple-disconnect

but neither work if NetworkManager is in charge of the modem.

Looking at modinfo, I notice that while cdc_ether has a specific modalias for the ZTE K3806-Z

alias: usb:v19D2p1015ddcdscdpic02isc06ip00in*

the cdc_acm module has none, and seems to be engaged by a wildcard instead:

alias: usb:vpddcdscdpic02isc02ip06in*
alias: usb:vpddcdscdpic02isc02ip05in*
alias: usb:vpddcdscdpic02isc02ip04in*
alias: usb:vpddcdscdpic02isc02ip03in*
alias: usb:vpddcdscdpic02isc02ip02in*
alias: usb:vpddcdscdpic02isc02ip01in*
alias: usb:vpddcdscdpic02isc02ip00in*

So, before giving up, I would try blacklisting cdc_acm and give cdc_ether a chance of engaging NetworkManager.
Please note, I never used these “odd” ZTEs, so this is only what I would try, not a recommended fix…

Hi,Yeah,but as it was seen I tried to connect again and nothing changed,even though now it was properly seen.

I managed to set acm_ether in network manager (weird that now it uses that instead of acm like before, after plugging and unplugging it a few times). Still same result.
I think something else is either blocking it or not working as intended.

Still, thanks for all your effort and hints, she will have to cope with that (not like is that much different from clicking on network manager). At least she won’t have to go to terminal and all that.