Can built-in wifi/blutooth of motherboard be disabled in openSUSE?

Short background for motivation behind this question (can be skipped if too long):

Recently I have been having issues with the wifi and bluetooth on my desktop. It started when I updated the BIOS on my motherboard. Weird stuff like bluetooth would stop working when transferring data to and from drives connected to USB ports, ports would randomly stop working, ect… Not just openSUSE but also other distros like Fedora and Debian. At the time, I had Fedora and openSUSE installed on on separate nvme drives. After about a week on the new BIOS, I apply system updates to Fedora, it reboots, then when I log back in everything is a mess. Bluetooth is extremely laggy, wifi no longer works, the system can’t go 2 minutes without freezing up, ect… I then reboot into openSUSE, which is at this point fine. I apply updates, reboot, then when I log back in the situation is the same as on Fedora. I use Yast to rollback the system to a snapshot from 4 days prior and the problems persist. I even do a fresh install of Debian 12 and Fedora KDE without applying the available updates. There are still these problems. Just because swapping out random parts when hardware troubleshooting hardware issues can provide insight, I remove the two nvme drives with fedora and opensuse and install a spare blank one and do a fresh re-install of openSUSE tumbleweed. The issues are noticeably better, but bluetooth is still extremely laggy, occasionally freezes when downloading from internet, wifi sometimes stops working entirely, ect… Because the issues seem to be linked to when bluetooth and wifi are both doing stuff, I suspect that something may be wrong with the built-in wifi/bluetooth module of my motherboard. I order a wifi/bluetooth pcie card that is identical to the built-in module and magically everything works as intended. A few reboots reveal that this does not happen every time and it requires a bit of luck on the reboot. Everything points to this being an issue with the hardware and not the fault of Linux. I contacted Gigabyte technical support, the manufacturer of my motherboard. They essentially said they do not validate Linux and its drivers blah blah blah and that I should see if the issues persist on Windows (eww).

These are my questions:

  1. Is there anyway on openSUSE tumbleweed to (temporarily) disable both the built-in bluetooth and wifi of my motherboard, leaving only the pcie wifi/bluetooth module enabled? If the problems persist only when the built-in stuff is enabled and magically go away when disabled, then this would strongly suggest a hardware issues since both of these modules (being identical) use the same exact Linux drivers.

  2. Is there any way these issues actually are a Linux issue? I strongly suspect it is not, since I experience them on openSUSE tumbleweed, Fedora, AND Debian. Additionally, rolling back the update that seemed to coincide with this on openSUSE did not fix the issue, which again suggests hardware issues.

@Joel1 Hi and welcome to the Forum :smile:
You can use the command rfkill to soft-block these devices, for example;

rfkill list

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

rfkill block 0

rfkill list
0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

You just need to select the correct device if there are multiple ones.

It could also be drivers/firmware issues… but since you see across multiple distributions, might be easier to block and test…

But if it’s just a PCIe card in the computer, you can always remove, or check the system BIOS to disable?

2 Likes

I am far from surprised hearing about problems with the combination of WiFi and Bluetooth. Both work in the 2.4 GHz band and their protocols bite each other. Their are some tricks to work together but those have their clear limitations. With external devices things often work better, especially if they nicely separated from each other/

Bluetooth is 2.4 GHz only for the moment, recent WiFi devices can be also moved to the 5 GHz and that is a good idea. In the 5 Ghz band there is not this interference issue and you can use higher bandwidths.

So check if it is possible to move the WiFi from channels 1-11 to 36 and higher.

I should clarify my intent a bit. The reason I have installed a pcie wifi/bluetooth module identical to what is internal to the motherboard is that my suspicion is that the internal module is faulty for one reason or another and that if everything works fine when the external card is enabled and the internal disabled, that would be clear as day evidence that the board should be replaced under its warranty.

The output of rfkill list is:

1: hci1: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
3: phy1: Wireless LAN
	Soft blocked: no
	Hard blocked: no

What is a bit strange about this output is that I would have expected two listed modules for the bluetooth, but there is only one. Disabling device 3 using rfkill seems to disable wifi for both modules.

How would I move the WiFi channels? Is this something I do from within the OS settings?

@Joel1 You likely need to look at the output from journalctl to see if maybe missing some firmware, or the bluetooth has died? I suspect 2 is the onboard wifi, so soft block that one.

I guess you are using your WiFi to connect to an Access Point and if so, it is the Access Point you need to configure.

I have (sort-of) confirmed that the issue is hardware-related. Gigabyte made me reproduce the issue in Windows and the issue does appear to be somewhat there, although it doesn’t present itself the same way as in Linux. On Windows sometimes the wifi randomly dies, although bluetooth seems mostly unaffected. This is not too surprising, as I would expect the OSes to interact with hardware differently. But defective hardware is still defective hardware. The issue I was having is that running rfkill block 2 disables both of the wifi modules. There doesn’t appear to be a way to just disable both the bluetooth and wifi of one chip and let the other remain functional.

@Joel1 dang :frowning_face: So is it a physical mini PCIe card on the motherboard? If so just remove it?