Camera for skype not working

I would prefer not to use skype but relatives and friends use it so I have not much choice. I run Tumbleweed/KDE version 20180620 but the camera is not working. however when I open Multimedia -> xawtv the comera is working OK. On my other laptop installing xawtv was all that was required to get the skype camera working. From the Hardware Information I get:
HP Wide Vision HD Camera (/dev/input/event18)
driver uvcvideo
the command lsmod gives:

lsmod | grep uvcvideo
uvcvideo              114688  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_v4l2         28672  1 uvcvideo
videodev              200704  2 videobuf2_v4l2,uvcvideo
videobuf2_common       53248  2 videobuf2_v4l2,uvcvideo
usbcore               294912  7 xhci_hcd,usbhid,usb_storage,uvcvideo,btusb,xhci_pci,uas

So why does skype only show a black screen? Any ideas anyone?

Video card /driver maybe???

Thank you Souerland, I have checked the link before but it mainly writes about the old skype and older installs - there is nothing that I could see which would help me. gogalthorp, the video is working with xawtv - so how could it be the video card driver? If so, how do I check?

does the camera work in other apps
I mean does opensuse detect it?

Yes, I_A - the camera works with xawtv

I use skype but on an desktop without a camera and all I can think of is checking if you’re part of the video group and if you’re not adding yourself to it (in yast->user management)

Thank you, I_A, I checked and I am not in the video group. Strangely enough this group is not even listed in YAST when I go to groups and click the edit or add button. However in /etc/group it is listed as


so I used the command

usermod -a -G video uli
groups uli
uli : users video

So although I am now member of the video group I am still not able to see the video in skype (i restarted skype after this change)
I looked through ~/.config/skypeforlinux hoping to find an xml file for settings, preferences or whatever but there is nothing. May be the only way is to hope that Microsoft fixes whatever causes this or that my friends and relatives switch to jitsi - whatever comes first. In the meantime I have skype with audio only.

You have done this:

Fixing webcam screen problems

On some systems openSUSE might have library loading problem and webcam doesn’t show anything sensible (black or green screen is more common). To fix this open the terminal/Konsole and log in as superuser “su” and perform following steps:
mv /usr/bin/skype /usr/bin/skype.real
chmod 755 /usr/bin/skype.real
vi /usr/bin/skype

and put the following inside

LD_PRELOAD=/usr/lib/libv4l/ skype.real

If you use a 64-bit system and the fix does not seem to work, try running skype from the terminal window (as your normal user). If you get an error like:

ERROR: object ‘/usr/lib/libv4l/’ from LD_PRELOAD cannot be preloaded: ignored.

you might need to install the 32-bit version of the above-mentioned library with
zypper install libv4l-32bit

Finally set permissions for the script above:
chmod 755 /usr/bin/skype

Test your skype video. It should work now.

Please note that if your web camera is showing a green, scrambled or black image, this workaround may also help:

In the above-mentioned script in place of the line

LD_PRELOAD=/usr/lib/libv4l/ skype.real

try the following

LD_PRELOAD=/usr/lib/libv4l/ skype.real

and test your skype video.

And skype from Konsole is showing nothing?

skype is downloaded from:

Yes, sauerland, I have seen this, but it is all the older version of skype. Now skype is only 64bit and there is no /usr/bin/skype but /usr/bin/sypeforlinux.

LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skypeforlinux 
LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skypeforlinux

Does also not working here per default, but with as User:

LD_PRELOAD=/usr/lib64/libv4l/ /usr/bin/skypeforlinux

Its 64bit therefore /usr/lib64…

In the skype audio- and video-settings click under the name of your kamera.

I have to apologize, sauerland and enziosavio, I didn’t think the old fix for the old 32bit skype would work for the new 64bit skypeforlinux - but it does. After your mail I thought I might as well try it and now the camera is working for skype. Thanks again

Great, which one does it work?

That’s the script skypeforlinux now:

cat /usr/bin/skypeforlinux

LD_PRELOAD=/usr/lib64/libv4l/ /usr/bin/skypeforlinux