camera as usb device

hi all,

since I decommissioned the last Windows station in my house last week,
I am now trying to get pictures off a Sony Mavica mvc-cd 200.

I found on a forum : "tread it like any other block device.

So I’m trying to mount it like I would a usb key.

In /var/log/messages I see:

              Nov  6 19:11:48 nevereasy kernel:   555.814082] usb 2-1: new full speed USB device using ohci_hcd and address 2

Nov 6 19:11:48 nevereasy kernel: 556.006115] usb 2-1: New USB device found, idVendor=054c, idProduct=004e
Nov 6 19:11:48 nevereasy kernel: 556.006125] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Nov 6 19:11:48 nevereasy kernel: 556.006133] usb 2-1: Product: Sony
Nov 6 19:11:48 nevereasy kernel: 556.006138] usb 2-1: Manufacturer: Sony PTP

So my OpenSuse 11.3 box knows it’s a Sony, so mounting it should be a soft egg,
right?

Only I don’t know how to do it, because i’m not seeing the normal sda or hda i’m
used to.

Anyone can help me?

grt, Johan

It would help if we knew if you are using Gnome or KDE

Can you see the device in /media

hi,

I am using Gnome, sorry for not mentioning this.

No, nothing in /media.

grt, Johan

What do see in fdisk -l
https://www.youtube.com/watch?v=h191KrDK-I0)

this is what i have :

fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x47aae535

Device Boot Start End Blocks Id System
/dev/sda1 1 132 1051648 82 Linux swap / Solaris
Partition 1 does not end on cylinder boundary.
/dev/sda2 * 132 4115 32001024 83 Linux
/dev/sda3 4115 9730 45096960 83 Linux

So just the normal partitioning I think, 1 swap, 1 /, 1 /home.

grt, Johan

You did that with the device attached - right?

yes , and the camera is on saying " usb mode PTP"

What happens in F-Spot

It’s a kind of old camera, not that that should be a problem, except it is a Sony :frowning:

Some folks end up using XP in Virtual Box with some devices

hi,

nothing in f-spot.

but I made a change to the camera, now it’s on “usb mode normal” instead “PTP”

and now I have in /var/log/messages:

Nov 6 20:43:42 nevereasy kernel: 6069.236178] sr1: scsi3-mmc drive: 8x/8x writer cd/rw xa/form2 cdda pop-up
Nov 6 20:43:42 nevereasy kernel: 6069.236473] sr 7:0:0:0: Attached scsi CD-ROM sr1
Nov 6 20:43:42 nevereasy kernel: 6069.236642] sr 7:0:0:0: Attached scsi generic sg2 type 5
Nov 6 20:43:48 nevereasy kernel: 6076.188174] cdrom: This disc doesn’t have any tracks I recognize!
^C

so I tried again to mount it using sr1

           nevereasy:/media/sony # mount /dev/sr1 /media/sony

mount: block device /dev/sr1 is write-protected, mounting read-only
mount: you must specify the filesystem type

any idea what filesystem type I should use?

grt, Johan

vfat is my guess

check here
openSUSE: HowTo set disk access permissions for Fat32 (VFAT) on a desktop PC

hello,

tried that :

 nevereasy:/media/sony # mount -t vfat -o uid=jvermeulen,gid=users,utf8 /dev/sr1 /media/sony

mount: block device /dev/sr1 is write-protected, mounting read-only
mount: /dev/sr1: can’t read superblock

so I think I’m getting closer to Windows in virtualbox .

But thank you very much for the help so far!

grt, Johan

Is this actually a built in device or removable like a SD card?

Did you try in F-Spot again since switching to USB

hi again,

thanks for the help so far.

again one step further:

           nevereasy:/media # mount -t usbfs /dev/sr1 /media/sony

nevereasy:/media # cd sony
nevereasy:/media/sony # ls
001 002 devices

So it’s mounted!

still seeing no pictures though:

in Nautilus I’m getting a message :

unable to open file /media/sony/001/001 with unicode utf8

So I guess i have to select something else here…

Hi,
On the camera, change the usb mode to usb storage instead of PTP

hi all,

thanks again for the help.

The device has a mini cd inside, when inserting that nothing at all happens,
nothing in /var/log/messages or dmesg.

I’m not seeing a usb storage mode, only ptp and normal.

So on usb normal I’m able to mount the device, but not seeing any of the 57
pictures that are on the thing.

On ptp mode puzzling continues.

grt, Johan

I’m tending to think more and more: Virtual Box
Virtual Box (Sun Version) Install HowTo