Calibre not launching

Hi everyone.

Calibre is not launching anymore. From konsole:

python2: siplib.c:12299: sipEnumType_alloc: La declaración `sipTypeIsEnum(currentType)' no se cumple. 
Abortado (`core' generado)

These is my repo list:

Repository priorities in effect:                                                                                                                                                                                   (See 'zypper lr -P' for details)
      85 (raised priority)  :  1 repository   
      95 (raised priority)  :  1 repository   
      99 (default priority) :  4 repositories

# | Alias               | Nombre                      | Habilitado | Comprobación GPG | Actualizar | Prioridad | Tipo   | URI                                                                                          | Servicio
1 | MEGAsync            | MEGAsync                    | Si         | (r ) Si          | Si         |   99      | rpm-md |                                           |          
2 | X11:XORG            | X11:XORG                    | No         | ----             | ----       |   90      | rpm-md |                     |          
3 | openSUSE-20161018-0 | openSUSE-20161018-0         | Si         | (r ) Si          | Si         |   99      | yast2  |                                            |          
4 | packman             | packman                     | Si         | (r ) Si          | Si         |   85      | rpm-md |                          |          
5 | repo-debug          | openSUSE-Tumbleweed-Debug   | No         | ----             | ----       |   99      | NONE   |                                      |          
6 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Si         | (r ) Si          | Si         |   99      | yast2  |                                        |          
7 | repo-source         | openSUSE-Tumbleweed-Source  | No         | ----             | ----       |   99      | NONE   |                                     |          
8 | repo-update         | openSUSE-Tumbleweed-Update  | Si         | (r ) Si          | Si         |   99      | rpm-md |                                              |          
9 | tumbleweed++        | tumbleweed++                | Si         | (r ) Si          | No         |   95      | rpm-md | |

[FONT=arial]What could possibly be?

Take a look at this:

I personally install Calibre from the webpage and it’s rock solid even with my huge collection.

I’ve seen that post, that’s why I included my repo list. Strange thing is I’ve no other repo whose packages would conflict with calibre. It looks like there is a python/calibre missmatch compile issue (at least is what I could understood with some google search).
Anyway, I’ve installed calibre from its website and everything is working great again (large collection here too)

I appreciate your time to answer. Thanks!

I have exactly the same error. Did you report a bug?

I guess that calibre is using an enum type from a newer python-sip package. So python-sip needs an update. However someone should open a bug report.

There has been a bug report, and the maintainer says the fix has been accepted to Factory (which means, it will be in the next Tumbleweed snapshot):

So please be patient a bit, an update should be available in the next days I suppose…

This version works:

It is still waiting to be built in Factory. Once it is there it should be in Tumbleweed soon.

It’s been a month. How long does it usually take to be released in TW from factory?

On 12/28/2016 10:06 AM, bonedriven wrote:
> It’s been a month. How long does it usually take to be released in TW
> from factory?

You do realize this is a volunteer distribution don’t you. If things are
not moving fast enough for you perhaps you could consider volunteering
some of your time.
Also keep in mind we are in the middle of holiday season.

linux since 1994
S.u.S.E./openSUSE since 1996

Depends on various factors.

The then mentioned new version is in Tumbleweed already since more than 3 weeks though, and has even been updated to 2.74 meanwhile (2 weeks ago).
If it still doesn’t work for you, maybe check which version you have actually installed (and from where).

rpm -qi calibre

There has been a Qt5 update to 5.7.1 recently which may have broken it again, but calibre in Tumbleweed has been rebuilt against that AFAICS.

Traceback (most recent call last):                                                                                                                                                            
  File "/usr/lib64/calibre/calibre/gui2/", line 157, in __init__                                                                                                                         
    ac = self.init_iaction(action)
  File "/usr/lib64/calibre/calibre/gui2/", line 171, in init_iaction
    ac = action.load_actual_plugin(self)
  File "/usr/lib64/calibre/calibre/customize/", line 611, in load_actual_plugin
    ac = getattr(importlib.import_module(mod), cls)(gui,
  File "/usr/lib64/python2.7/importlib/", line 37, in import_module
  File "/usr/lib64/calibre/calibre/gui2/actions/", line 12, in <module>
    from import generate_catalog
  File "/usr/lib64/calibre/calibre/gui2/", line 15, in <module>
    from calibre.gui2.convert.single import NoSupportedInputFormats
  File "/usr/lib64/calibre/calibre/gui2/convert/", line 17, in <module>
    from calibre.gui2.convert.look_and_feel import LookAndFeelWidget
  File "/usr/lib64/calibre/calibre/gui2/convert/", line 12, in <module>
    from calibre.gui2.convert.look_and_feel_ui import Ui_Form
  File "/usr/lib64/calibre/calibre/gui2/convert/", line 290, in <module>
    from calibre.gui2.css_transform_rules import RulesWidget
  File "/usr/lib64/calibre/calibre/gui2/", line 12, in <module>
    from calibre.ebooks.css_transform_rules import (
  File "/usr/lib64/calibre/calibre/ebooks/", line 10, in <module>
    from cssutils.css import Property, CSSRule
  File "/usr/lib/python2.7/site-packages/cssutils/", line 110, in <module>
    from . import util
  File "/usr/lib/python2.7/site-packages/cssutils/", line 18, in <module>
    from _fetchgae import _defaultFetcher
  File "/usr/lib/python2.7/site-packages/cssutils/", line 7, in <module>
    from google.appengine.api import urlfetch
  File "/usr/lib/python2.7/site-packages/protobuf-3.0.0b2.post2-py2.7.egg/google/", line 2, in <module>
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 2991, in <module>
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 2977, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 3019, in _initialize_master_working_set
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 2548, in activate
    for pkg in self._get_metadata('namespace_packages.txt'):
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 2538, in _get_metadata
    for line in self.get_metadata_lines(name):
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 1474, in get_metadata_lines
    return yield_lines(self.get_metadata(name))
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 1470, in get_metadata
    value = self._get(self._fn(self.egg_info, name))
  File "/usr/lib/python2.7/site-packages/pkg_resources/", line 1579, in _get
    with open(path, 'rb') as stream:
IOError: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/protobuf-3.0.0b2.post2-py2.7.egg/EGG-INFO/namespace_packages.txt'

Here’s the rpm -qi calibre results:

rpm -qi calibre
Name        : calibre
Version     : 2.74.0
Release     : 1.2
Architecture: x86_64
Install Date: Sat 31 Dec 2016 05:54:20 PM CST
Group       : Productivity/Other
Size        : 54714686
License     : GPL-3.0
Signature   : RSA/SHA256, Fri 23 Dec 2016 06:07:16 AM CST, Key ID b88b2fd43dbdc284
Source RPM  : calibre-2.74.0-1.2.src.rpm
Build Date  : Fri 23 Dec 2016 06:06:06 AM CST
Build Host  : cloud111
Relocations : (not relocatable)
Packager    :
Vendor      : openSUSE
URL         :
Summary     : EBook Management Application
Description :
Calibre is an ebook library manager. It can view, convert and catalog
ebooks in most of the major ebook formats. It can also talk to a few
ebook reader devices. It can go out to the internet and fetch
metadata for your books. It can download newspapers and convert them
into ebooks for convenient reading. It is cross platform, running on
Linux, Windows and OS X.
Distribution: openSUSE Tumbleweed

Well, I’d say the problem is this:

I.e. actually not really a problem with calibre, but rather your python2 installation in general.

What permissions does the file have?

ls -l /usr/lib/python2.7/site-packages/protobuf-3.0.0b2.post2-py2.7.egg/EGG-INFO/namespace_packages.txt

Where from/how did you install it?

rpm -qf /usr/lib/python2.7/site-packages/protobuf-3.0.0b2.post2-py2.7.egg/EGG-INFO/namespace_packages.txt

AFAICS that file should not be there in Tumbleweed at all, because Tumbleweed (only) has python-protobuf 2.6.1 (not 3.0.0b2.post2). Though it may be part of some other package…