Calc hangs when I try to get external data

I have tried to get external data form numerous websites in calc,
When I insert the web address into the box for URL of external data source my calc document hangs.
I am trying to download sports results into my calc document from 

I queried with libre to see if there was a problem with their software but they replied that it works fine in Debian & Ubuntu.
I let the query run over night last nigh & my calc document was still hanging this morning & I hadn’t received an error report.

Is there a way for me to retrieve an error report when the document hangs?

I am running opensuse 13.1-X86- 64 bit

Sounds like this:

Btw, I can reproduce it here. And it makes no difference whether I use the KDE integration or not, so it’s not related to that.

I just tried with LibreOffice 4.2 from the LibreOffice:Factory repo and there it worked fine and DID NOT hang.

So you could install that as workaround:
(choose “install xxx (with vendor change)” whenever YaST asks…)

sudo zypper ar LibreOffice:Factory
sudo zypper dup --from LibreOffice:Factory

I’ve posted to the bugzilla my surprise that you can point Calc generally to a webpage with all sorts of stuff in it, and not specifically to the data, eg the HTML table on the webpage(which I’ve done).

I didn’t know that what these individuals are trying to do might be possible, and so far my admittedly sometimes questionable Google talent can’t come up with a tutorial or reference that this is possible. For it to work, some “smarts” in the code has to be able to parse the objects on the webpage and extract only objects with tags that could potentially contain importable data. Then it also becomes a question what happens if the page is comprised of multiple tables, and webpages often use tables for object placement instead of holding data.

And, that doesn’t even start to address the issue that HTML5 is obsoleting tables with its “flowing objects” approach.


AIUI, they are selecting “Insert”->“Link to external Data…” in Calc’s menu and enter the URL into the dialog that appears.
At least that’s how I reproduced the hang with LO… :wink:

And it works fine with LO here, so it should be a valid operation.

Thanks Wolfi it works fine for me aswell in LO

I would have posted earlier if I had not made a very big mistake.
When I tried to uninstall LO via bash I typed

 sudo zypper rm libre*

this crashed my machine.
Once I repaired it I found out that

 sudo zypper rm LibreOffice

removed enough files to install the new version.

Yes, I think so.
When I try to run that on my system, I get:

sudo zypper rm libre*
root's password:
Daten des Repositories laden ...
Installierte Pakete lesen ...
Paketabhängigkeiten auflösen ...

The following 4162 packages are going to be REMOVED:

Not really a good idea to say yes to that… :wink:

Once I repaired it I found out that

 sudo zypper rm LibreOffice

removed enough files to install the new version.

How did you install it?
If you install it from the LibreOffice:Factory repo, you don’t have to install the old version first.

For the version from the LibreOffice website, it might indeed be better (or even necessary) to remove the old version first though.

I found out too late that there is a big difference between Libre & LibreOffice.
I downloaded the package form the Libreoffice website & installed it.
I have never used the LibreOffice:Factory before but I definitely try it next time.