Cairo-dock pop-ups

Whenever I boot I get 5 pop-ups superimposed on each other that say;

“OpenGL allows you to use hardware acceleration, reducing CPU load to a minimum.
It also allows some pretty visual effects similat to Compiz.
However, some cards and/or their drivers do not fully support it, which may prevent the dock from running correctly.
Do you want to activate OpenGL?
(To not show this dialog, launch the dock from the Applications menu,
or with the -o flag to force OpenGL or -c to force cairo.)


There is nothing to check, like, “Do not show this dialog again”.

The comment about launching is pointless, because Cairo-dock has been auto-launched already.

When I click in Cairo → configure → community site, Firefox opens with two tabs at this ridiculous website with links to everything from vacation tours to Cairo to docks for your cottage, and Konquror opens at the same site. If I close the Konqueror window it springs right back to life a couple of times.

If I go to Cairo → configure → development site I get the right website in the same array of browsers with the same silly behavior.

The only things that I changed recently ( Cairo-dock had been working fine. ) is, a kernel upgrade and I reset the session manager to “Restore previous session”, which is the default. Somehow it had been set to “Start with an empty session.”

This is happening in Suse 11.2 on a KDE 4.3.1 desktop.

At the very least, how do I get rid of the pop-ups, or do I write off Cairo-dock? I tried it once before and it was so glitchy I dumped it. I liked this version of it, and got used to using it for certain things. It would be nice if I could keep it.

Do you have the video drivers for you video card installed?

Check that only one instance is running.

Yes, I have the driver installed and everything, including all the bells, whistles and 3D wonders, work as they should. The issue is the pop-ups.

How do I determine how many instances are running?

ps -A will list all the processes.

I had two instances running. on from cairo menu X at boot and the kde session.
Im to tired but check my threads to find how to disable the kde session.

Yup, ps -A shows five instances running. How the heck does that happen?

So today I have six instances running. So every time I log off a session is saved and added on.

Does anybody know how to stop this?

I assume the pop-up box is another issue. Does anybody know how to stop that?

thedarpone wrote:
> It would be nice if I could keep it.

unless you just use your machine to look at and admire the way the
screen looks it is easier sometimes to elect to run stable dependable
stuff, and let the eye candy wait until it is also dependable…


Actually I had it hidden. The only reason I wanted it to continue to function as it had is because I found it useful.

I had a problem like that once back in 3.5 the only thing that worked was to create a new user and move all my stuff except .kde to the new user. There is something in a configuration that is being run multiple times to start it multiple times. In my case it was basically caused by adding the KDE development repo.

If you live on the cutting edge you are sure to bleed. :stuck_out_tongue:

Cairo doesn’t work well with session management.
If you have session management enabled, then it will always launch an additional instance of Cairo without parameters, so you will always get the annoying dialog you described. You then have to close the dialog and the second instance every time :silly:

The only way to fix this is to disable session management. To do this, go to Kde systemsettings > Advanced > Session Manager. There, under “On Login”, select “Start with an empty session” and click on “Apply”.

Then, go back to the “Advanced” page, and open the “Auto Start” item. Look for the Cairo entry and make sure it says cairo -c under command. If it doesn’t, highlight the entry, click “Properties”, change to the “Application” tab, and change the “Command” contents accordingly.
This will always launche the normal version of Cairo at startup, without annoying dialog. I recommend not using the OpenGL version, as it doesn’t work properly yet.

Thank you Tokugawa-Ieyasu. You have confirmed my suspicions. This started when I set my session management to “Restore previous session”. I did that so Kmix would show up in the tray and interface with my multimedia key board.

So now I have to make a choice between Kmix and Cairo-dock, which isn’t hard. Good bye Cairo-dock.

You could simply make a new entry for KMix under Autostart.