CAD,CAM,CAE softwares installation

hi,i’m becoming crazy,i hope there’s someone that can help me,i installed OS 11 in my new pc,on my old pc i had both windows and OS,now i decided for OS only.

now OS runs without problems with all normal applications

the problem is that i need CAD,CAM…softwares on the pc for fun and job, working with OS (before they worked with windows) and here i start crying :frowning:
if there’s someone that has these softwares on his pc or has some suggests for installation…

i’m not a monster with computer science above all with programmation,cracks,bugs…so i hope my “technical language” :slight_smile: is understandable

i installed

  • autocad 2002 - installed,it runs for the moment,at the beginning it didn’t work,i modified something in gnome and then it worked,after that solid edge didn’t work,so i modified it in its system ,and now it works,slow but it works

  • autodesk inventor 11- installed,it doesn’t run ,i’ve problems with volo view application(i think that it’s incompatible or there’s something wrong with OS video card).this is the most important software that i need!!!

-pro engineer wildfire 2.0-installed,it works but not in all its applications…i’ve problems with FEM analysis,when i launch it it says that there’s no enough memory available…and it crashes.

-solid works and solid edge - installed after 4 hours,they are quite "slow "when i round designed components but they works

-cosmos designstar -this is the worst one,i can’t install it,during installation with windows i should crack it in DOS,but now i can’t copy that foulder where it should go because i can’t enter (or better i can’t find)inside installation program foulder

-mastercam 9.0-installed,i had problems during installation because it crashed when it reached 50%,don’t ask me what exactly,the only thing i know is that now after a night with him it’s working without problems

-Direct-Link Race Performance for ECU/ECM engine maps (it’a quite unknown software for engine maps),it crashes during installation…saying nothing

thank a lot to all people that can help me.


Did a quick google and found qcad and brl-cad

There’s more here


The links below might help you.
Linux for CAD
CAD Programs for Linux LG #54
CAD - Linux Forums
Linux Links - The Linux Portal: Software/Graphics/CAD

Your mileage installing CAD type software, especially Windoes versions, in Linux will vary greatly. Check out the post above and the link to Bricscad. It uses a Wine layer to run. At work, we do lots of Architectural CAD work. For the best functionality, just fire up a Virtualbox instance of Windoes…If you have to …I guess.


thank you very much,i’m browsing inside those links,this night i’m trying again to solve their bugs.
my real problem is that i need only those CAD,because i work on existing files,yes, i can save them in universal formats and import all in a CAD designed for linux but so i lose historical components constructions…

pro-e now is working good :slight_smile: i found on that link the solution,my main preoccupation now is autodesk inventor!


Hope you can update this thread in the future of the good things happened
I will be very interested.


well,yesterday night i lost 4 hours to solve this problem,result:every software needs a different video card setting,the nice thing is that they are all different!!!so i decided that i could disinstall two ones to avoid conflicts among all CAD softwares.
now the problem is that i decide i need absolutly inventor,pro-e,and cosmos,the first one is working(not in all its applications but it works,the second one has problems that i said before,the third one is a s***t,i don’t know the why i can’t open its files foulder.

i’m thinking that maybe it would be better if i install a windows partition or a double OS and windows system on my pc…

well done,today the doctor visited my pc(i know…computer science isn’t my job!),now all that i need is installed and above all is working,my friend should load different video card settings for every softwares and changed "something"i don’t know exactly where so then i formatted windows partition :slight_smile:
the only thing that i don’t like very much now is that it needs a lot of time during file saving phase…
thank you for all advices