C preprocessor "/lib/cpp" fails sanity check

whenever i try to run the ./configure command, this error appears. i tried installing almost everything gcc and cpp related, but that didnt fix anything. i also tried searching around, but none of the solutions seemed to work for me, the error just stayed the same. what should i try to do?

This is not much info you’re giving. From some configure files I have from ALSA, I see that there’s something more to the message. It says there should be a config.log with more information.

But we need more info. Which version are you running, which kernel (uname -r), architecture (32 / 64). Is it pretty much standard or did you mix in Factory packages???

sorry for the lack of information, i wasnt exactly sure what was important and what wasnt. there was a config.log, and it seems like it has something important. it is too long to fit in a post, so i guess ill just answer the questions you gave. my kernel version is 2.6.27.7-9-pae, im running a 32-bit architecture, and i have only installed stable releases of anything that could be relevant to this.

Can you give an example of something you’re trying to compile?

If that is about kernel modules, did you install just the kernel-source or did you install the ‘Linux Kernel Development’ pattern. The latter should be the case.
If that is about (kde)programs, you might need to install -devel versions of libraries or called programs. It’s already a good thing you didn’t mix Factory packages.

well, right now, im trying to compile misfit model 3d (Misfit Model 3D - Home)

all that it seems to require is qt and mesa, and i already have them and the -devel versions, i followed all the advice in the guide to compiling it on the website, but none of it seems to help.

我也遇到了同样的错误。我是在安装mysql的时候,./configure时候出现的这个错误。

错误信息如下:

linux-d5t6:~/mysql-5.0.45 # ./configure --prefix=/usr/local/mysql
checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking target system type… i686-pc-linux-gnu
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for gawk… gawk
checking whether make sets $(MAKE)… yes
checking “character sets”… default: latin1, collation: latin1_swedish_ci; compiled in: latin1 latin1 utf8
checking whether to compile national Unicode collations… yes
checking whether build environment is sane… yes
checking whether make sets $(MAKE)… (cached) yes
checking for gawk… (cached) gawk
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ANSI C… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
checking for g++… g++
checking whether we are using the GNU C++ compiler… yes
checking whether g++ accepts -g… yes
checking dependency style of g++… gcc3
checking how to run the C preprocessor… /lib/cpp
configure: error: C preprocessor “/lib/cpp” fails sanity check
See `config.log’ for more details.

I think it might be better to post in English, even not-so-good English, as nearly all people on the forum would not be able to read Chinese.

Also you should start a new thread instead of confusing people by adding to an existing thread. The reason for the problem may be different even though the symptoms look the same.

It looks like you are trying to build mysql 5.0.45? Why? openSUSE 11.1 provides 5.0.67. But maybe you are not running 11.1. You should give us more details, like your openSUSE version.