Bzflag won't start in fresh installation

All I get is:
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 153 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x5e3
Serial number of failed request: 192
Current serial number in output stream: 194

It ran fine in 42.3 and I’ve tried changing the display resolution but it made no difference.

Videocard involved? Any drivers installed? Which desktop environment?

EDIT: installed it, runs fine here. If you are running GNOME this might be a Wayland issue. But that’s what we need to know from you

Sorry. Plasma 5 and Cinnamon on an Amd Hd 7870. I haven’t tried running it on Wayland.

oops. I didn’t say what driver. There is no proprietary Amd driver for this card for openSUSE so it’s using whatever the system loaded. Perhaps you can tell me the command to find out.

Well, I just thought I’d tell you that I found the problem and what it was. It seems that the game wants to run at the maximum resolution of the display or the driver not sure which by default. On my old crt monitor it was 1280 by 1024 but this one is 1920x1080 though native is 1360 or 66x768 not sure which. First time I started it at 1360x768 it failed so I tried 1280x1024. It failed again so I thought there was a problem I didn’t know how to fix because it had worked in 42.3 but when I tried 1920 the game came up so I reset it to 1360 and all is well.

There you go.