Burned dvd's are unusable.

I need help/suggestions from you guys. After my burner died like a month ago(42 days) after nine yrs of service I decided to go and buy a new one. I got a cheap HP Dvd 1040i. I declined the warranty and of course after 42 days when I tried to open the tray a small metal part (a washer kind) flew from inside and it stopped working(reading or writing). The manager at the Staple store decided not to do anything for me(because I declined the extended warranty) and now I will have to deal with HP about it. Meanwhile I “borrowed” one from the same store.( i will return it back every 14 days) until i get some resolution one the HP one. This one is a Sony DRU 860S which unlike the other one has a SCSI data and power cable. Do I have to install anything else in order for it to work? It reads DVD’s it writes (using K3b) and reports as successfull, but then the disk is not usable. K3b recognizes it as "Complete Data DVD-R but then it cannot mount it. Any suggestions?
another question I have as this is not working I was trying to copy a DVD on my laptop(which can copy the regular DVD’s but when I tried a DL it failed twice at around 60-70%. Are there any restrictions/issues with k3b related to the size of the dvd that anyone knows of?
Thanks,

If the drive is within the manufacturer’s warranty period between Staples and the manufacturer, they must replace or repair.
When you say the new drive is scsi are you sure you aren’t confusing it with and ide connector.
SCSI is pretty rare and needs to be connected to a SCSI card - usually only professional server/workstation boards have a built in scsi.
If the drive is recognised, you shouldn’t need anything else. In your case it is recognised as since k3b is writing to it.
Try getting a rewriteable cd/dvd disk and see if it will write a couple of files to it. (That way you aren’t turning into a toast factory).
Also some drives don’t accept all dvd media and prefer some discs to others.
Usually aldi/lidl discs are good and relatively cheap to try with.
Try burning at a lower speed as well and get k3b to check the disc after writing.

The only restriction is the size of the disc you are writing to. If you are trying to write more than the disc’s rated capacity (usually 700mb for cd and 4.3 gb for dvd) you will get an error.

If this is UK then you had no need to go to the manufacturer this is covered by the sales of goods act

Sale of Goods Act | Consumer Information
The manager gave you the run around…
the-shop-doesn’t-want-to-know-they-say-it’s-the-manufacturer’s-responsibility/

What is the legal definition of quality | Consumer Information

42 days is not acceptable and I would like to know how a manager can argue it is.

Well is in Canada. The store policy is that it can be returned in 30 days. I denied the extended warranty based on the fact that my last DVD writer served me for 9 years(you get what you paid for -$500). This one was only $50, but I expected it to last at least a year. It lasted only 42 days(and I was away for a week or so) so in fact was around 30 days. The manager was an "arse’ but as I said I will buy and return every 14 days a DVD burner until I get something out of my old one from the manufacturer. That will be more than the $50 I paid that the store is going to waste.
Anyway my new one(SONY) doesn’t even work it fails to write to disks, so i will return it tomorrow and take a new one. I made a mistake and said that is a SCSI but in fact I meant SATA. I don’t think that is anything different from a SATA to a regular( I think IDE) one. it reads any disks but when i try to write data or iso files it errors out. I didn’t make any changes to the software I’m using(k3b), so I assume is just the burner. I will see tomorrow. Thanks for replies.

I can’t remember exactly, but I’ve had serious trouble like this. A friend asked me, if I had completely unplugged the machine when replacing the drive. Not just switch it off, but unplug the power cable. For reasons I still don’t understand it worked after doing that, while it didn’t before.
Maybe this will help you.

Thank you for your replies. I think that the problem is related to the fact that the computer was not even off when I installed the burner. The reason I’m saying that is that any disk I burn, k3b gives me details about the disk size and I noticed the the info related to SystemId, VolumeID and ApplicationId in the ISO96660 Filesystem info area are empty. When I try to mount it it complains that it cannot mount it. I was even able to make a copy of it(to a RW) but the copy had the same issue. Anyone knows if those info can be setup somewhere?
I tried to unplug the burner and install it after the computer was unplugged but so far it didn’t work. I unplugged my machine and I will try again tonight and if not I will try to reinstall k3b.
Not sure what else to do. I will let you know.

> Thank you for your replies. I think that the problem is related to the
> fact that the computer was not even off when I installed the burner.

ok, here is a rule to not break:

while the computer is running:

  • it is generally ok to plug in/out USB devices, and speakers, and
    microphones and ??? (i cant think of anything else)

  • NOT ok to plug anything else…not:
    – monitor/screen
    – keyboard (unless USB)
    – mouse (unless USB)
    – joy stick
    – hard drives (unless HOT PLUGABLY, 99% are NOT)
    – printers (unless USB)
    – scanners (unless USB)
    – modems (unless USB)
    – CD/DVD players/burners (unless USB)
    – mother boards
    – power supplies
    – RAM
    – CPU
    – sound cards
    – network cards

here is the deal: the chips inside almost all components have teeny
tiny wires that can be burned though with almost NO charge going the
wrong way…

it could be that your DVD player is now good only to be a door
stop…no kidding!

oh, one more rule: READ THE DIRECTIONS, i bet you got some info with
that new HP Dvd 1040i, and i bet it tells you exactly HOW to install
it…and, i bet it says to shutdown and unplug the computer…and,
probably says not to touch the contacts at the back of the drive…

reading is cheaper than buying a new drive…


platinum
Give a hacker a fish and you feed him for a day.
Teach reading the instructions and you feed him for a lifetime.

Thank you, platinum, for the lesson. I would have got the point in few words, no need to get a long speech.
Anyway the burner still works in XP so no physical damage to the burner and I was able to burn a disk successfully recognized on another machine, but k3b still doesn’t create a correct DVD after I reinstalled the application. I will try to use another application to see if that helps. If not I will have to conclude that the operating system got somehow corrupted. Is that possible? it just doesn’t burn correctly the disk even tough it says that the disk was successfully created and there are no errors. Anyone would know how to debug k3b?

Try k9copy from packman repo. This may be an application-specific or config issue.

What is the output from the command below?

/usr/sbin/hwinfo --cdrom

> I will have to conclude that the operating system got
> somehow corrupted. Is that possible?

yes


platinum

It is good you learned from your experience, but take this info to mind too please. Windows is very forgiving of device faults, most are just discarded. Any CD/DVD drive especially one that writes or may have litescribe, can be subtly damaged. SATA is very easy for this damage to propagate through the device. Today you may be able to read/write from the drive, tomorrow may be a different story. The PC power supply is a switching supply capable of very high static currents even when the unit is not on.

here is the output :
/usr/sbin/hwinfo --cdrom
24: SCSI 200.0: 10602 CD-ROM (DVD)
[Created at block.247]
UDI: /org/freedesktop/Hal/devices/storage_model_DVD_Writer_1170d
Unique ID: KD9E.16Hu15WU4YA
Parent ID: _+Pw.GGXU64Y4v72
SysFS ID: /class/block/sr0
SysFS BusID: 2:0:0:0
SysFS Device Link: /devices/pci0000:00/0000:00:0f.0/host2/target2:0:0/2:0:0:0
Hardware Class: cdrom
Model: “HP DVD Writer 1170d”
Vendor: “HP”
Device: “DVD Writer 1170d”
Revision: “DH22”
Driver: “sata_via”, “sr”
Driver Modules: “sata_via”
Device File: /dev/sr0 (/dev/sg2)
Device Files: /dev/sr0, /dev/scd0, /dev/disk/by-path/pci-0000:00:0f.0-scsi-0:0:0:0, /dev/cdrom2, /dev/cdrw2, /dev/dvd2, /dev/dvdrw2
Device Number: block 11:0 (char 21:2)
Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+DL, DVDRAM
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #7 (RAID bus controller)
Drive Speed: 94

Thank you techwiz for the explanation. It seems that as you said Windows is more forgiving on the hardware as I used it for many years and was not that careful with the static electricity but never had a problem. I will from now on do things properly as I do not want to go back to Windows. I did it just to verify that the burner is still working.
I tried a different application (brasero)with the same result(unreadable disk). I might have to reinstall the OS if I don’t get any other suggestions.
This is my only device with SATA connection(the hdd have ide cables). I noticed that at the boot up it’s checking if a RAID exists and cannot find it. I tried to add one but i was not able. Would that need to be somehow configured in Suse?
In windows I noticed that the drive is not setup to be on any region? how can that be setup in Suse? maybe it could help.
Lots of questions but maybe someone can get an idea on what to do.
thank you

I found this line from your hwinfo output interesting:

Attached to: #7 (RAID bus controller)

I’m not familiar with these controllers, but I wonder if the problem might be with either the controller itself, or RAID support config in your BIOS? Someone more knowledgeable than myself may be able to offer more advice about this.

I wonder if dmesg output might yield clues about any problems as well?

here are some excerpts from the dmesg:
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata3.00: ATAPI: HP DVD Writer 1170d, DH22, max UDMA/100
ata3.00: configured for UDMA/100
ata4: SATA link down 1.5 Gbps (SStatus 0 SControl 300)
scsi 2:0:0:0: CD-ROM HP DVD Writer 1170d DH22 PQ: 0 ANSI: 5
Uniform Multi-Platform E-IDE driver

ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata3.00: ATAPI: HP DVD Writer 1170d, DH22, max UDMA/100
ata3.00: configured for UDMA/100
ata4: SATA link down 1.5 Gbps (SStatus 0 SControl 300)
scsi 2:0:0:0: CD-ROM HP DVD Writer 1170d DH22 PQ: 0 ANSI: 5
Uniform Multi-Platform E-IDE driver

anyone has any clue if there is anything wrong in it? why it refers as scsi?
thank you

The dmesg output looks completely normal. (My IDE cdrom device uses ata-piix driver and looks like scsi device to kernel). Is there a possibility for you to try this cdrom device with another SATA controller PCI card?

I’m not sure how I can do that. The SATA connector is on the mainboard. Are there special controller cards in order to be able to connect multiple SATA devices? Now it is connected on the SATA1. There is another SATA0 where I connected it initially. Should I retry?
thanks for helping.

I actually meant that you could obtain (or purchase) a cheap PCI SATA controller for test purposes. Most have 2 or more ports, and these can usually be configured to be independent, or as part of a RAID config.

Now, I am not an expert in these things, but I wondered if your existing controller was in the wrong mode and was preventing your cdrom from working correctly. A similar problem and possible reason discussed here. In particular

Basically, once the mainboard SATA controller has beens et to AHCI (ie, enable all the nice SATA features) or RAID, the only devices that are then supported fully are HDD devices. This means that the SATA DVD won’t work, you’ll need an IDE or USB drive to load anything.

There’s a number of motherboards (especially from Intel, including various desktop, workstation and server motherboards) that have only a single SATA controller, no IDE controller, and therefore don’t support SATA Opticl drives when running in all other than boring Native mode. This is a serious shotcoming of these motherboards.

So, I wonder if that although the device is recognised, it may have problems operating correctly. Just a guess.

A guess like k3b related. Try xfburn.

Well, to be honest I feel completely lost now. I returned the last burner and got another one: a Sony DRU-870S. This time I handled everything properly, but it still doesn’t burn a DVD properly. I think that there is something the hardware doesn’t like on these SATA controller or is not setup properly in Opensuse. My motherboard is an MSI K8tNeo(6-7 yrs old). I read the specs and here is what it says about the controllers:

An IDE controller on the VIA® VT8237 chipset provides IDE HDD/CDROM with PIO, Bus Master and Ultra DMA 66/100/133 operation modes

  • Can connect up to 4 IDE devices

• Serial ATA/150 controller integrated by VT8237

  • Up to 150MB/s transfer rate
  • Can connect up to 2 serial ATA devices
  • Supports RAID 0 or RAID 1

• Promise 20378 On-Board
• Supports 2 serial ATA plus 1 ATA133

  • RAID 0, RAID 1 or RAID 0+1 is supported
  • RAID function work w/ATA133+SATA H/D or 2SATA H/D
    • Connect up to 2 SATA device and 2 ATA133 devices

i tried another app to burn(brasero) with the same result. The only difference is that brasero gives me an error:

BraseroWodim finished successfully session
BraseroWodim stopping
BraseroWodim got killed
Unsupported type of task operation
Session error : An internal error occured (brasero_burn_record burn.c:2641)

Anyone knows how to setup the SATA controller? I will switch between the 2 of them but i don’t think that i will be successfull. any other ideas? thank you

perhaps there something in here you can use:
http://cdrecord.berlios.de/private/linux-dist.html
the guy claims that the real cdrecord code is no longer delivered
with many distributions…

i can neither confirm nor deny his claims, and have NO idea if it will
help your situation at all…

i do know that i’m using what openSUSE distributes and have had
constant problems burning CD and DVDs and do not know if the problem
is my hardware, my software or my lack of brain power…

if you decide to compile and install the real code, and it ‘just
works’ i’d love to hear back from you, here…


platinum
Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.