'bumblebee' stop working

ok i’am install ‘bumblebee’ successfully and work very will so i have updated software nvidia driver after that ‘bumblebee’ stop no 3d no compiz work

i return to terminal to start ‘bumblebee’ again but the message appear to me :

You’re already member of the ‘bumblebee’ group, but
need to re-login to apply these changes…

how to re-login and start ‘bumblebee’ again

and how to remove ‘bumblebee’ and install it again to work perfectly

i’am using opensuse 11.4

I also updated my nvidia driver (prebuilt rpm) to 290 something. The nvidia side of things still functioned but the intel glx was broken. I was able to fix the intel by reinstalling the mesa, xorg-intel, xorg-drivers rpms from yast.
You can tell if intel or nvidia are working by running glxinfo and optirun glxinfo. This may or not be the same problem you have.

How did you install bumblebee, if you used a prebuilt rpm in yast, just find the package in yast and update that package.

Relogin? Either reboot or log out from kde and log back in.

After you reinstalled the Intel stuff, do you still have nvidia 3d working?
It is like choosing between pest and cholera… but the **** kids truly want their Minecraft not to lagg and that is to much to ask from the Intel gfx.
:confused:

Yes nvidia 3d was working the entire time oddly enough and also worked after restoring the mesa/intel packages. Hopefully this pattern continues.

I had no such luck, I fiddled with it until my hair went gray… but to no avail. Nvidia glx working with bumblebee but then no Intel glx on screen 0 - Intel glx working without Nvidia drivers.

Finaly I got mad, installed Linux Mint, 10 minutes later I had Intel+Nvidia glx with the help of ‘Ironside/bumblebee’. Was a happy camper watching Minecraft working and glxgears turning in never before seen fps. After the initial amazement I started to use Linux Mint/Gnome-weirdness, quickly my happiness faded away, w t f. (been using opensuse for a long time - Mint felt like it was early alpha software)

So to make a long story short, tried and failed with Bumblebee/Linux Mint…
… now newly reinstalled OpenSUSE running without nvidia :confused: but with a nice kde desktop.

Sorry about the rambling.

If nvidia works and intel doesnt most likely the nvidia package overwrote something intel should be doing, which the only solution ive found so far is the one i described earlier with reinstalling mesa/xorg packages.

If intel works but nvidia doesnt then check the log for xorg screen :8. I found in my setup it was complaining about the screen setup DLP vs CRT (or something like that). Changing the nvidia xorg.conf that came with bumblebee to the other monitor type fixed the problem.

So far those are the only 2 problems ive come across running 12.1 with prebuilt bumblebee and nvidia packages.

the first one… reinstalling didn’t work for me… and I never had any problem with the nvidia proprietary driver, it works but getting the Intel 3d working at same time - that solution eludes me. I tried reinstalling mesa/xorg but so far it’s a fail.
I will persist and try again tonight :slight_smile:

Hope it goes well so I don’t bring out my shotty and use my Asus for a clay pigeon…
:slight_smile:

edit: btw, I noticed there is 2 different ‘Bumblebee’ in the repositories, one “2.4-something” and one “1.7-something” from Ximi, witch one do you use?

yeah at one point there were more than that, but im using the 1.7 package

Ahhh, Victory!

Finaly… Asus U36JC + OpenSUSE 12.1 + Working nVIDIA blob lol!

I added this repository but didn’t install anything.

Index of /repositories/home:/Ximi1970:/bumblebee-unstable/openSUSE_12.1

Then I followed the instructions for installing “bumblebee-1.7…” from git with the NVIDIA-Linux-x86_64-290.10.run

  1. git clone http://github.com/MrMEEE/bumblebee.git
    2.cp NVIDIA* ./bumblebee/

  2. cd bumblebee/

  3. sudo ./install.sh

  4. Answered yes I’m sure to a bunch of questions, chose system nr 1 (with working power managment) and proxy.

  5. Added myself to the bumblebee group

  6. Rebooted

  7. And success at last :wink:

angry@asus:~> glxgears
/.../
295 frames in 5.0 seconds = 58.899 FPS
300 frames in 5.0 seconds = 59.819 FPS
300 frames in 5.0 seconds = 59.820 FPS
^C

happy@asus:~> optirun glxgears
_ON Enabling nVidia Card Succeded.
Starting up bumblebee X server:
/.../
6556 frames in 5.0 seconds = 1311.046 FPS
6589 frames in 5.0 seconds = 1317.747 FPS
6580 frames in 5.0 seconds = 1315.906 FPS
^CStopping bumblebee X server: .
_OFF Disabling nVidia Card Succeded.
Stopping bumblebee X server: 
Bumblebee server not running
tired@asus:~>

Thanks Pickle236 for your tips, if not for you I would have given up

btw - I think “bumblebee-2.4.1…” only works with Nouveau, at least for me :sarcastic:

Kind regards from Linux Uber Noobelicious me

A very interesting thread for those having problems getting bumblebee to work with openSUSE 12.1.

@thermalgrease

Are you saying that the the repo bumblebee package did not work correctly, and that you had to then install the git version instead?

https://github.com/Bumblebee-Project/Bumblebee

@ Pickle236

Are you in a position to write a brief ’ Bumblebee with openSUSE 12.1 How To’ in this section with your workarounds included?

Unreviewed How To and FAQ

I used the “outdated” version, I think Ximi1970 uses that one. And I installed from git so the install.sh could install the nvidia.run without overwriting any important. Perhaps it would have worked with installing from “Ximi1970+nvidia-repositories” but at least this worked :slight_smile:

https://github.com/MrMEEE/bumblebee

edit: before this I tried “hundred” different ways to get it to work but I used the “bumblebee-2.4.1…” repository, it refused to work with nvidia blob and intel glx at same time.

http://download.opensuse.org/repositories/home:/Bumblebee-Project:/Bumblebee-develop/openSUSE_12.1/

OK, thanks for the clarification. It might help others too.

I can confirm that the repo bumblebee does not work.

Also, I wonder if it is possible to run programs using the intel card in the same way optirun works for nvidia. Does anyone know?

I’m not sure if I understand you correctly but unless you use “optirun” everything is using the Intel gfx, so optirun is only needed when you need extra OpenGL powwa for games etc.

I have yet to try how hdmi, vdpau and other things work but the kids are happy with smooth graphics in Mincraft…

Can’t use hdmi out if only the intel gpu is running, and running things like vmware causes freezes and stuttering because of gnome-shell and probably poor nvidia drivers.

I’d rather run vmware using something like optirun but for the intel card.

I’d rather run vmware using something like optirun but for the intel card.

My understanding is the same as thermalgrease’s. I have read of HDMI not working for Optimus architecture under Linux, when the intel driver is active, but you’ll have to google for more info about this yourself.

Don’t have to google for it because hdmi does not work with the intel gpu. I own the laptop and tested this. So, what it comes down to is that I just want programs to run smoothly. Either the desktop effects in gnome-shell are horribly coded, or the nvidia driver is. Or, maybe both!

Don’t have to google for it because hdmi does not work with the intel gpu. I own the laptop and tested this.

Your choice. Sometimes one has to do some work or a little research themselves. There may be existing bug reports for example. It has a better chance of being fixed if others make the effort to create, (or add to) bug reports.

the bumblebee package in the repo by Ximi1970 should work with the driver packages in the nvidia repo. I know the Ximi1970 package has some scripts that look for the nvidia module, maybe these are missing/not implemented for the 2.4 package.