Bumblebee not working properly - "could not load GPU driver"

Hello there,

I’m running openSUSE Tumbleweed with KDE 5.6.1 right now on my Vaio S13 notebook (i3-3110M, GeForce 640M LE, 8gb DDR3, 256gb SSD). I tried following the instructions here


but I’m still unable to get things to work. I get the following error when trying to run with optirun:

  897.385964] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

  897.386017] [ERROR]Aborting because fallback start is disabled.

similar with optirun --status

Bumblebee status: Error (3.2.1): Could not load GPU driver

I tried using this command

echo "options bbswitch load_state=-1 unload_state=1" > /etc/modprobe.d/50-bbswitch.conf

But it didn’t help.

I can disable the graphics card through

tee /proc/acpi/bbswitch <<< OFF

and check it with

cat /proc/acpi/bbswitch

but still can’t run primus nor optirun.

Any help? What other info should I provide?

Note that those instructions are for Leap and 13.x versions Tumbleweed takes special handling. Did you attempt to install the NVIDIA driver options?? This probably does not work on Tumbleweed since it uses more advanced kernels. If you use Tumbleweed probably better to follow the Optimus without bumblebee thread since it uses the normal NVIDIA driver which can be installed the hardway


Thank you for clarification!

Do you think if I installed Leap it should be ok? I don’t really care about rolling release, I just wanted the newest version of KDE, but I learned that it’s possible to install on Leap too.

I could try! It’s a pretty new installation so it doesn’t matter really.

At times those bumblebee_nvidia instructions work with Tumbleweed too, but the current 4.5.0 kernel gives headaches… also with the suse-prime-alt (without bumblebee…) route.
Bumblebee worked out of the box with Leap here, so that might be a safer option.
But before reinstalling please check that the nvidia modules are indeed in place:

ls /lib/modules/4.5.0-3-default/updates/nvidia*

(or change accordingly if you are running a different kernel version)
You should see at least nvidia.ko and possibly nvidia-modeset.ko and nvidia-uvm.ko.
If no nvidia module shows up, something went wrong with the install: it takes time to download the nvidia sources and to build the kernel modules; you should see a file named /usr/src/NVIDIA-Linux-x86_64-361.28.run (or any other version) of about 87 MB: if not so, you might download it from the Nvidia site (it works with Leap too…) and move it to /usr/src/, then force reinstall nvidia-bumblebee.

If the nvidia kernel modules are in place, try to rebuild the initrd by:

dracut --host-only --force

then reboot.

If still no joy, maybe you have better chances with Leap.

Thank you for your help!

I checked the command and indeed I did see nvidia.ko and nvidia-uvm.ko. Run the dracut command and rebooted - nothing happened unfortunately.

I will try Leap then. I wanted to check the brtfs system earlier, so another reason to format. :slight_smile: I will report back in couple of hours