Bumblebee not working after kernel upgrade to

Hello everyone,

I have a Lenovo P1 (2nd) with an Nvidia Quadro T2000 and Intel Graphics. To use switchable graphics I want to use Bumblebee (https://en.opensuse.org/SDB:NVIDIA_Bumblebee). After a new installation of OpenSUSE Leap 15.1 with kernel-default-4.12.14-lp151.28.36.1.x86_64 I followed the instructions of https://forums.opensuse.org/showthread.php/537906-Cuda-Nvidia-bumblebee-codecs-quot-safe-quot-way and everything worked fine.

Unfortunately, my wifi-card (Intel® Wi-Fi 6 AX200 160MHz) works only with kernels 5.1+ (source: https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html) so I had to do a kernel update:

I ran:

zypper ar -f -p 20 https://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel:stable
zypper -vv dup --allow-vendor-change --from kernel:stable
uname -r

After that the wifi-card works, but Bumblebee does not:

optirun --status
Bumblebee status: Error (3.2.1): Could not load GPU driver
optirun glxgears
 4526.224967] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

 4526.225044] [ERROR]Aborting because fallback start is disabled.

(Both worked fine before the kernel upgrade)


systemctl status bumblebeed
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2020-02-24 16:15:48 CET; 18min ago
 Main PID: 5456 (bumblebeed)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bumblebeed.service
           └─5456 /usr/sbin/bumblebeed

Trying to load the kernel module:

sudo modprobe bbswitch
modprobe: FATAL: Module bbswitch not found in directory /lib/modules/5.5.5-4.gbfcbf21-default

Please let me know if I should add more information. When booting the “old” kernel Bumblebee works fine.

All help is welcome and an (easy?) workaround to get the wifi-card working on the 4.12 kernel would also be useful. Thanks a lot in advance! (I thought of the obvious workaround to use a usb wifi adapter, but it would be great if there was an other solution.)


Your better to open a bug report about your wifi card against the kernel, they may backport the fixes to get it working for you (Will see the 5.3.x kernel in Leap 15.2)?

openSUSE:Submitting bug reports - openSUSE

You need to look at using the kernel stable repo and the bumblebee kernel stable repo…


They currently match the 5.5.6 kernel…

And apparently you didn’t install a Nvidia driver matching that kernel…

Okay, isn’t that somewhat frowned upon? Because it explicitly says that the driver is only supported from 5.1+. One might just say: “get the new kernel…”

Upgrading to the new 5.5.6 kernel didn’t solve my problem unfortunately. However, I tried many things and what finally worked for me is using my nvidia card with SUSE Prime on a completely new install with kernel 5.5.6.

And apparently you didn’t install a Nvidia driver matching that kernel…

I really doubt that this was ever the problem. There aren’t that many different driver versions from nvidia for openSUSE. I might be mistaken though.

So even though the problem couldn’t really be resolved, I have a way that works for me. Thanks a lot for your help.