Bumblebee is not connecting to hdmi external monitor using intel-virtual-output

I used to have my laptop connect to an external monitor using the “intel-virtual-output.” However, I had some technical issues with bumblebee that had to reinstall the Mesa drivers. Now I can’t get the second display to work. When I try to connect the second monitor, I get the following response:

intel-virtual-output -f
No VIRTUAL outputs on ":1".

Some information on my system:

lspci -nnk | egrep 'VGA|3D' -A3
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 630 [8086:591b] (rev 04)
    Subsystem: Acer Incorporated [ALI] Device [1025:118a]
    Kernel driver in use: i915
    Kernel modules: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)
    Subsystem: Acer Incorporated [ALI] Device [1025:118b]
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia_drm, nvidia

lsmod | grep nvidia
nvidia_uvm            901120  0
nvidia_drm             49152  2
nvidia_modeset       1097728  1 nvidia_drm
nvidia              18239488  2 nvidia_modeset,nvidia_uvm
drm_kms_helper        204800  2 i915,nvidia_drm
drm                   491520  13 i915,nvidia_drm,drm_kms_helper
ipmi_msghandler        65536  2 nvidia,ipmi_devintf

xrandr  --listproviders
Providers: number : 1
Provider 0: id: 0x43; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 3; outputs: 1; associated providers: 0; name: modesetting
    output eDP-1

xrandr --listmonitors
Monitors: 1
 0: +*eDP-1 1920/344x1080/193+0+0  eDP-1

Your help on this matter is greatly appreciated.

There are several reasons and solutions.
In my case it was the driver that was used by the system after installation.

sudo prime-select get-current

If it returns “intel” that means that you are using the modesetting driver, that is not capable for virtual output emulation.
for all the possible entries use

sudo prime-select

It lists all the drivers that can be used as primary one. If you see there an “intel2” entry with the following description:

intel2: use the Intel card with the Intel open-source driver (xf86-video-intel). If you use this driver in a Plasma session, make sure to first disable vsync in the Plasma compositor settings to prevent video corruption

then you are lucky as you have the good old xf86-video-intel driver.
To make it available use

prime-select intel2

And try again with intel-virtual-output…