Bumblebee for Optimus Cards


I have an Acer 5755G and a fresh OpenSuse 12.3, used to have Ubuntu 12.04 and bumblebee worked as a charm there.

the OpenSuse repos don’t have bumblebee in the list of stable packages and bumblebee project does not have any guide for OpenSuse, however they ask for knowledge.
First I tried the repo provided by Overman79 but nothing happened.
I tried to follow the guide here but ended up with a crashed desktop.
Anyone knows of a better guide how to install bumblebee in 12.3?

Thank you in advance.

Don’t know, but I pinched some comments from our private forum that one of our team made

  • Bumblebee, i.e. the switching of the graphics cards), I use the version from the Overman97 repo.
  • bbswitch: the NVIDIA card is turned off completely when running on the Intel
  • the NVIDIA driver install from the Bumblebee-Project repo (of which I think it should no longer be in /home: since the market (at least over here) is flooded with hybrid NVIDIA’s (and ATI’s)
    What needs attention:
  • primusrun. For some reason the script does not know the location of the NVIDIA libGL. I modified it a bit, adding /usr/lib64/nvidiia and /usr/lib/nvidia to primusrun’s search path for libGL.
  • symlinks need to be made from /usr/lib64/nvidia to /usr/lib64/nvidia-bumblebee and the 32bit analogy.

Ref: Index of /repositories/home:/Overman79:/Laptop/openSUSE_12.3

The page on my blog you referred to is for 12.2 - it says that explicitly. Did you try to apply it to 12.3?

I tried to make up some sort of a howto in one of the threads, but on an update it did not work anymore. I found that users no longer belonged to the bumblebee group, which seemed to be recreated during the update.


Saved my day!

Works also for 12.3.

WARNiNG: **replace the Factory and 12.2 versioning by 12.3. It may work now, but cause issues in the future.

As I said, following this I ended up with a non starting desktop. I think I will wait. The only reason I need it is to save battery but I see that currently it uses only the intel embedded so I am fine.

Please have a look in this thread: https://forums.opensuse.org/english/get-technical-help-here/hardware/484188-setup-bumblebee-primus-opensuse-12-3-a.html?highlight=bumblebee .