Bumblebee driver with GT635M

Hi everyone,
I recently wiped my laptop and gave OpenSUSE 13.2 a spin. (I normally use Fedora, but Fedora wasn’t running very well on my laptop). Now I’m REALLY happy with how everything is working with openSUSE, but I can’t seem to get my steam games running.
I’ve got a Intel graphics chip and a nvidia GT635M, so I installed the bumblebee driver with the help of this guide: http://linuxandblues.com/linux/opensuse-13-2-easy-nvidia-bumblebee-guide-update-23-december-14/
But I guess I’m missing something. When I launch steam using ‘optirun steam’, and I try to run Counter-Strike Source, It pops up a window, plays the valve sound and it flips away. I already tried going into the launch settings of CS:S and added ‘optirun %command%’ but this gives the same problem.
Here’s the terminal output:
swap interval = 0 swap limit = 1 ##### The program ‘hl2_linux’ received an X Window System error. This probably reflects a bug in the program. The error was ‘BadWindow (invalid Window parameter)’. (Details: serial 132 error_code 3 request_code 15 minor_code 0) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.) Missing shutdown function for DevShotGenerator_Init() : DevShotGenerator_Shutdown() Missing shutdown function for MapReslistGenerator_Init() : MapReslistGenerator_Shutdown() Missing shutdown function for COM_InitFilesystem( m_StartupInfo.m_pInitialMod ) : COM_ShutdownFileSystem() Missing shutdown function for Steam3Client().Activate() : Steam3Client().Shutdown() /home/dave/.local/share/Steam/steamapps/common/Counter-Strike Source/hl2.sh: line 67: 3792 Segmentation fault ${GAME_DEBUGGER} “${GAMEROOT}”/${GAMEEXE} “$@” Game removed: AppID 240 “Counter-Strike: Source”, ProcID 3792 Is there something I forgot during the Driver installation? I also don’t have a Nvidia control panel, is it normal? They seem to be working as there is a significant difference in running glxspheres with or without optirun.

I installed some packages and managed to get primusrun steam running but then I get the error “OPENGL GLX content is not using direct rendering” and it shuts down. I’ve had this issue on Fedora before, installed 32-bit libraries and it was resolved. However, I do not know how to solve this on openSUSE.


Did you install the 32 bit nvidia-bumblebee.

You should not follow some random web page instruction. Though look ok it is incomplete

This page explains it


Hi, thanks for the reply.

So if I run:

zypper in nvidia-bumblebee
systemctl enable dkms
zypper in nvidia-bumblebee-32bit
I should be okay without any troubles? I can leave my previously installed packages or do I have to remove them?

Well I don’t know which packages you installed. Soooooo would not hurt. I suspect you simply just got the 64 bit package because the page you referenced did not include instructions to add the 32 bit which is needed for steam. In any case the important part is the version numbers match for the 64 and 32 bit. If they don’t things may not work. It is easiest to see and deal with versions in Yast-Software management.


I installed those packages and now - after a reboot- I can’t get into the graphical interface.
Tried reinstalling all the packages, removing them, etc.

Guess it’s a reformat then >:(

It is likely you do have an Optimus system and thus need bumblebee packages but just having a Intel + NVIDIA GPUS does not mean it it optimus. If a notebook it probably is.

Looking again at the instruction from the page you referenced. it does not tell you to install the nvidia-bumblebee package at all. So that was totally missing and you were running the OS nouveau driver for the NVIDIA card. This will not work with steam

You can avoid reinstalling if you can boot to the rescue mode (in the advanced menu at boot) or boot to a terminal (press e at the boot screen find line stating linux go to true end of that line and add a space and a 3 press F10 to continue). Once in a terminal log in as root and run yast. This is the text version and you navigate with tab and arrow keys. You can then install uninstall what you need to.

You should still be able to boot up in failsafe/rescue mode and resolve from there.

Ok I just did a reinstall.
Can someone link me a full guide of how to install bumblebee with proprietary nvidia drivers please?

EDIT: when following the official NVIDIA bumblebee guide from OpenSUSE (https://en.opensuse.org/SDB:NVIDIA_Bumblebee)
Should I run the Bumblebee with open source graphics driversFirst? Or do I have to jump straight into:
OPTIONAL: Install NVIDIA driver

A good guide for installing bumblebee on OpenSUSE 13.2 is found here: https://forums.opensuse.org/showthread.php/505270-ultimate-tutorial-installing-Bumblebee-driver-for-SUSE

Solved the issue:

Here’s what I did:
Did a clean install + updates.
Then follow this official page: https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Run through Preparation

Bumblebee with open source graphics drivers

**OPTIONAL: Install NVIDIA driver

Everything is working flawlessly now. Steam runs perfectly with primusrun, etc.
Only weird thing is that the Nvidia Control panel won’t launch.

Edit: lesson learned - stop following non-official cr*p guides :slight_smile:

Thanks for the answers

I don’t have Optimus so I can’t test it. What exact program are you trying to run for “NVIDIA Control panel” the nvidia-settings program should be there. But then with Optimus I don’t really know if you can use that since all rendering goes through the Intel GPU.:stuck_out_tongue:

optirun nvidia-settings


primusrun nvidia-settings

This didn’t work.
But everything is working brilliantly so it doesn’t matter :slight_smile:

Thansk for your help everyone!