Bumblebee - cant access secundary GPU

I recently switched my laptop to Suse 13.1, I’m used to using Debian but it didn’t work very well on the laptop.

I followed the guide on Smithfarm to the letter, everything worked but when I try to run:

$ optirun /opt/cxoffice/bin/crossover

It says ‘error cannot access secundary GPU … NVIDIA: …’

cat /var/log/messages shows me failed to load module “nvidia”, no driver available, no screens found.

lspci | grep ‘VGA’ outputs 2 lines:
00:02.0 VGA etc Intel
01:00.0 VGA NVIDIA etc

In /etc/bumblebee/xorg.conf.nvidia it mentions PCI bus ID, I uncommented it and tried:
BusID “PCI:01:00:0” ← this was default, but commented out.
BusID “PCI:01:00.0”
BusID “01:00.0”

These didn’t help … so I commented that line out again.

I checked whether Nvidia stuff was installed:
$ zypper se nvidia
i dkms-nvidia
i x11-video-nvidia

I’m not sure what to check next. Oh … I’m member of the video and bumblebee groups. Bumbleed.service is running, I checked with

systemctl status bumblebeed.service

I’d appreciate some help with this, gaming doesn’t work very well on the Intel ;).


Hello and welcome.

Though I can not help you personaly (I have no doubt others will come here and try), I want to give you some information on how to post computer output (of which you posted several, thank you) here in the forums (for next time!).

Please copy/paste that output straight from your terminal window in between CODE tags in the post. You get the CODE tags by clicking on the # button in the tool bar of the post editor.

When possible copy/paste the prompt, the command and the next prompt in one sweep. Then there is no need for you to tell: “command xyz gives me …”, because it is all there.

Thanks Henk. I usually do that, but I was lazy because I had to type everything over on another machine as I couldn’t post from the machine having the problems, so I was constantly having to gooseneck over at the other screen, it was annoying :P.

I first posted the question as a comment over at blogspot and copy/pasted here.

Thanks for the welcome!

I’ve never had to poke with xorg.conf for Bumblebee, so the problem is probably not there. I se no 32-bit versions for Nvidia, although I know nothing about crossover I would recommend to open up the Laptop repo in Yast and install all 32-bit related, there’s more 32-bit only code out there then you would believe. This might not solve your problem but it will rule out some possibilities for it.

Thanks. Appreciate the help.

While going over the logs I found some other error messages. In my attempts to fix I removed the nvidia packages and installed the bumblebee-nvidia package. I think it broke more than it fixed.

I reinstalled the laptop (it was a clean install anyways) and instead of following the entire guide on that Smith blog, I only installed the bumblebee, primus, dkms and nvidia packages.

Everything seems to work now.

If I find that it slurps too much power I’ll look into it again and see what I can do. For now, I just want things to work properly.

The basic idea with Bumblebee is to save power and keep the laptop from running too hot, performance is just a bonus, so at least test the dkms-bbswitch package.

The Crossover application uses WINE for installing and running Windows programs and games on Linux.

Crossover seems to work well with optirun or primusrun.

cat /proc/acpi/bbswitch says the card is OFF, before and after I ran a game via optirun/primusrun. It seems to work properly, fan turns down shortly after I close a game. I can do optirun firefox and check the output in a console, it will show ON.

The thing is, on Suse all the games seem to perform quite a bit less than on Mint/Ubuntu. The performance isn’t any better than using the integrated intel GPU.

I know bumblebee isn’t primarily about performance but how else am I supposed to run games on the Nvidia card? I can’t make it primary in the BIOS or disable the intel.

optirun /opt/cxoffice/bin/cxdiag shows its using the Nvidia, its definitely not using the intel.

When I tried to switch Nvidia drivers, I ran into an issue mentioned elsewhere on the forums and left unresolved (zypper, mv cannot move directory not empty). I decided to reinstall once more.

I installed the proper drivers, including 32-bit versions which are required with bumblebee/primusrun if you’re running 32-bit applications like Wine or Steam.

Everything works and its fast too. I’l mark the thread resolved.