Building repository 'Packman Repository' cache

nasheayahu@kbbn7server:~> sudo zypper -n update

Building repository 'Packman Repository' cache ........................................................................................................................................[done]
Signature verification failed for file 'repomd.xml' from repository 'update-sle (15.5)'.

    Note: Signing data enables the recipient to verify that no modifications occurred after the data
    were signed. Accepting data with no, wrong or unknown signature can lead to a corrupted system
    and in extreme cases even to a system compromise.

    Note: File 'repomd.xml' is the repositories master index file. It ensures the integrity of the
    whole repo.

    Warning: This file was modified after it has been signed. This may have been a malicious change,
    so it might not be trustworthy anymore! You should not continue unless you know it's safe.

    Note: This might be a transient issue if the server is in the midst of receiving new data. The
    data file and its signature are two files which must fit together. In case the request hit the
    server in the midst of updating them, the signature verification might fail. After a few
    minutes, when the server has updated its data, it should work again.

Signature verification failed for file 'repomd.xml' from repository 'update-sle (15.5)'. Continue? [yes/no] (no): no
Retrieving repository 'update-sle (15.5)' metadata ...................................................................................................................................[error]
Repository 'update-sle (15.5)' is invalid.
[openSUSE:update-sle|http://cdn.opensuse.org/update/leap/15.5/sle] Valid metadata not found at specified URL
History:
 - Signature verification failed for repomd.xml

Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository 'update-sle (15.5)' because of the above error.

How do I correct this?

It’s telling you what to try, and why. Wait a while, then try again. Repeat the wait again if necessary. Another option might be to use a different Packman mirror if you’re pressed for time.

1 Like

By simply reading the terminal output from the TO, one will easily find that the packman repo is not involved at all. The signature verification failed for the update-sle repo…

Signature verification failed for file 'repomd.xml' from repository 'update-sle (15.5)'.
Repository 'update-sle (15.5)' is invalid.

The rest is corrrect: wait until the mirror is properly synced and try again…

2 Likes

But it’s no simple matter to do any such thing. The inane forum software insists I need copious whitespace bordering on the left and on the right consuming ~50% of total horizontal screenspace even though the browser window containing the forum tab is fullscreen width 1920px, so that it is thus necessary to read that TO whilst manipulating a forced horizontal scrollbar. Such disruption of the reading process interferes with its absorption.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.