Building my Wireless Driver, Please Help! Thanks =)

Okay, I got openSUSE installed, and now am trying to build my wireless driver, using the instructions here:

The wireless driver is here: - 802.11 Linux STA driver


  • The (parenthesis: ) are my notes to show you what I was doing.
  • Lines with “#” before them are what I typed into Terminal.
  • Lines below (Output: ) are what was output by Terminal.

(run in su:)
lspci -n | grep 14e4

04:00.0 0280: 14e4:4727 (rev 01)



# mkdir hybrid_wl
# cd hybrid_wl
# tar xzf <path>/hybrid-portsrc_x86-32_v5.100.82.38.tar.gz

# make

if 'make' is not a typo you can use command-not-found to lookup the package that contains it, cnf make
(NOTE: with "cnf" it is saying "Can Not Find")

(install "make" command:)
# zypper in -t pattern devel_basis

(It installs 93 packages)

# make

kbuild_nopedantic=1 make -C /lib/modules/`uname -r` /build M=`pwd`
make: *** /lib/modules/2.6.34-12-desktop/build: No such file or directory. Stop.
make: *** [all] Error 2

# zypper in kernel-source

(It installed 3 more packages)

# make

kbuild_nopedantic=1 make -C /lib/modules/`uname -r` /build M=`pwd`
make: *** /lib/modules/2.6.34-12-desktop/build: No such file or directory. Stop.
make: *** [all] Error 2

Please help. Thanks!

p.s. The problem might be derived from the fact I had to install openSUSE in Kernel (F6) > Safe Mode
If I need to install more things, please let me know ASAP! I am wired to my ethernet until then, which means I can’t move from this spot until my wireless is working!

Is there a particular reason you’re building it rather than just installing the prebuilt package from the repository?

I believe this thread will help you with that.
Install Broadcom Drivers from Packman

Yes, because my particular one (DW1501 Wireless-N) does not come in the repository. Another person in another thread got it working by doing what I am doing here.

This is helpful, but I think I still need to build it manually, because mine is not supported by default.

BUMP not solved yet =)

Please help!

Please post the result of

/sbin/lspci -nnk

While your listing is not a real copy/paste of your computer session, one can not be sure if what one reads there is correct. But it seems as if you try to run make while being root. Please do not do that. One should only use root when stricktly needed. Building software can be done by every user. It is only the install itself (when files are going to be stored/changed in system directories) that one needs to be root.

Second thing is that I see you use


to become root. You should use

su -

These little remarks are not realy helping you with your problem (others are allready discussing with you), but I hope they are helpfull in you having a save and secure system.

Non-sense, the ID 14e4:4727 is supported, either by wl or brcm80211.

modinfo wl
filename:       /lib/modules/
license:        MIXED/Proprietary
srcversion:     AA312C702630BDAA93A381C
alias:          pci:v0000**14E4**d0000**4727**sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004357sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004353sv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Dsv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Csv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Bsv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Asv*sd*bc*sc*i*
alias:          pci:v000014E4d00004329sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004328sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004315sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004313sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004312sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004311sv*sd*bc*sc*i*
vermagic: SMP preempt mod_unload modversions 
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           nompc:int
parm:           name:string

modinfo brcm80211
filename:       /lib/modules/
license:        Dual BSD/GPL
description:    Broadcom 802.11n wireless LAN driver.
author:         Broadcom Corporation
srcversion:     03148DF62D6592C2ED55319
alias:          pci:v0000**14E4**d0000**4727**sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004353sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004357sv*sd*bc*sc*i*
depends:        mac80211,compat_firmware_class,cfg80211
vermagic: SMP preempt mod_unload modversions 
parm:           msglevel:int
parm:           phymsglevel:int
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           macaddr:charp
parm:           nompc:int
parm:           name:string

No need to compile anything, so instead of insisting you have to do something unnecessary, you should follow the advice(s) already given to solve your problem.

Okay, I reinstalled openSUSE and am back to this.

You’re right! I did not have to build my driver!

I did this:

pre1a) Installed openSUSE
pre1b) Connected with ethernet to internet
pre1c) Installed ALL updates, including in YaST

  1. Open YaST
  2. Package Search
  3. searched for broadcom-wl
    pre4a) Found my kernel type by typing in Terminal: “uname -a” (without quotes)
  4. Installed package ending in “desktop” (that is my kernel type)
  5. Terminal:

zypper in broadcom-wl broadcom-wl-kmp-desktop

NOTE: a small error came up at the end of the output, but obviously it was not a problem because it turns out it worked!
6) Reboot
7) click the start button (or whatever you call it)
type: “Network”
8) choose “Network Connections”
9) the Wireless tab is no longer greyed out! Choose that tab…
10) click “Add” button on the right-hand side
11) in pop-up, click “Scan”
12) choose your network
SKIP) (number is bad luck)
14) press OK
15) Click on network you just made, to highlight it
16) Press OK
17) Enter your password in the pop-up (if you have a network password)


For all people who happen to read this thread in the future.

Read carefully to get an idea about wha it does not matter how some vendor calls some device.

If you don’t believe me, then maybe you believe a kernel developper (lwfinger) and what he has to say about “device names” and device IDs.

For all people who happen to read this thread in the future, also read this thread carefully (especially postings #6 and #8) …

… to get an idea about why it does not matter how some vendor calls some device.

If you don’t believe me, then maybe you believe a kernel developper (lwfinger) and what he has to say about “device names” and device IDs.


Still want to build my own

output says teh broadcom-wl driver only supports b/g
I have a Wireless-N card

Original post link shows that the driver I want to build supports wireless N.
I notice a significant decrease in performance without wireless-N and I want it back!

Please help.

I’m not sure wireless N is well supported at all.

And you still don’t need to.

Not really:

Still no need to build that driver manually as it is part of compat-wireless packages from driver:wireless repo.

However, although the brcm80211-driver will be the better choice in the future, atm it is still in a stage of maturing.

I very much doubt that this is related to missing “draft-N” support of your driver, especially as the driver you are using atm does support draft-N (at least officially).

I also doubt that brcm80211 will be significantly better at the moment, but if you really want to try that one, there is still no need to compile anything, however you would have to take care of external firmware for that driver and of course also you would have to take care of blacklisting other driver(s) which might interfere.

Yes really. “broadcom-wl” is NOT THE DRIVER AT THE LINK. The driver at the link I need to COMPLILE MYSELF there is no auto-install.

YES THERE IS, Please stop trying to argue with me and HELP WITH MY ISSUE.


Thank You!

BUMP still need help to fix error

(I moved this topic to a different section because it is not regarding Wireless:

If so, then why

a) are the versions the same?

b) does the packman page link to the exact same download page?

This is the same driver and my other remark was about brcm80211, not wl.

I need to compile it myself because the ones supported are not made for my computer. I need to compile it myself so that I can get the exact version for my own computer, so that it can support Wireless-N

openSUSE_99999999999, I don’t know if you’ve noticed, but one of the users trying to help you out is a maintainer of one or more wireless driver packages. The other user is an administrator here and also knows his stuff. (Just look at their reputations) They’re not trying to blow smoke up your ass. They’re just trying to get your wireless working the easiest way possible. Believe them when they tell you that you don’t need to compile the driver to make it work. I know you want to think your computer is very unique and special. It’s not. It’s just a collection of retail parts that anyone can get.

Stop arguing with them and follow their instructions and you’ll have it working in no time. Now, if you WANT (rather than need) to compile your driver for the learning experience, I’m sure they would be happy to help with that as well if you tell them you’re on a learning quest to begin with.

BUMPING posts here is NOT a normal practice. You seem very impatient and unwilling to follow simple instruction.

So what kernel version are you running openSUSE_99999999999? If the versions don’t match your running kernel, all you need to do is grab the src rpm and rebuild it;

wget -c
rpmbuild --rebuild

The you need to install the rpm for your arch down in /usr/src/packages/RPMS with the sudo command, only the install, not the rebuild.

Now, I’m not sure which kernel your running, but maybe to reconfirm, post the output from uname -a