Building and installing makemkv

There are two user repositories that contain package for makemkv. As I cannot install either of them I have been trying to build my own package from one of their source RPM.

Package number 1:
Will not install the prebuilt x86_64 package because I am missing
This version of libavcodec is not available for Leap 42.1, I have 52, 55 and 56, but not 54. Did not work by linking 55.

I was able to download libavcodec54 from, installed it, but then installing this makemkv package it requires another library, I cannot go on like this so this method is no longer an option.

Package number 2:
It requires the package mmdtsdec which is not available for Leap 42.1 as x86_64 package.

Building from source rpm:
I then installed gcc5 and tried to build the package myself with one of their RPM spec file.
Building/Compiling throws out a lot or errors from several /usr/include/qt5/ files.
Like: /usr/include/qt5/QtWidgets/qaction.h:95:80: error: ‘nullptr’ was not declared in this scope
Among many other errors.

Makes me think how did those people manage to build makemkv on their Leap 42.1

Building from oss and bin archive:
Trying to build according to the instructions on makemkv for makemkv-oss and makemkv-bin.
Running ./configure on the unpacked archive makemkv-oss-1.10.0.tar.gz I got the same errors as previous.

According to the instructions the some packages must be installed with apt-get (well ubuntu packages so the packages may not exist for openSUSE).

I am running the latest Plasma 5.7, Frameworks 5.24.0 and Qt 5.7.0
I guess that makemkv is not compatible with this version of KDE and Qt.

There is a guide for openSUSE
I have tried to install the packages mentioned there.
The development packages for pattern devel_C_C++ was installed
The Qt5 packages was not possible to install
It could not find Qt5Core-devel, Qt5Bus-devel, Qt5Gui-devel, Qt5Widgets-devel
Though I do have installed libQt5Widgets-devel, libQt5Core-devel, libQt5Gui-devel