Buildin Keybord and touchpad lock up during linux boot

Symptoms:

  1. keybord worked fine to begin with until after nvidia driver instalation.
  2. Keybord works fine during initial boot, stops working after I selected boot option in boot manager.
  3. Absolutly no reaction when pressing a key from OS or the laptop itself (can`t switch on/off numlock, capslock and ScrLK LEDs)
  4. the capslock and ScrLK LEDs are constantly on.
  5. Dosn`t work in console (regular and ctrl+alt+f1)
  6. USB mouse still work

what I`ve done (:

Installed the Nvida driver with the 1 click guide opensuse.org/nvidia. I be live the update also installed some other updates. I used the console command: “sax2 -r” to get the nvida driver running (I be leave), rebooted and here the keyboard stopped working.
Luckly my USB mouse still works, so I updated the OS using the build in updater, but no luck, Ive tryed reinstalling SUSE, getting the same experience, every time I install the nvidia driver I lose my keyboard. I have now and then been lucky and gotten the keyboard running like right now(pushing some keys during start up , but I dont belive that did it), but when I reboot it dosnt work anymore. Im running KDE btw.

System specs:
Brand Zepto
Model Znote 6635
CPU Intel Core 2 (2,0GHz)
Ram 4GB
GPU Nvidia GeForce 8600m GT
Wlan Ar5008 (zpro)
Lan Netlink BCM5787m Gbit

think that was the usefull specs

Im new to Linux, so far Im having a good impression of it (except for the above)
Hope I got all the details you guys need.

Try sax2 -r and then pick the Generic 104 PC key keyboard. Test it, Save, Exit.
Do the same in KDE4’s Systemsettings.
Reboot (just to make sure). Let us know if this helped.

I’ve tryed it now, still the same. Writeing from my cellphon.
I any thing else witch I might be able to do?

Thank you for you quick response, here is a little longer response now that I’m able to use my keyboard.

I’ve just switched my HD around, so I’m back on windows again.

The thing that seams odd to me are these:

1)The error seams to happen immediately after I select boot option in the boot manager, would have expected the kernal to load first.

2)It’s only the buildin keyboard and the touchpad witch doesn’t work. I would have expect the drivers need for that to be somewhat standard, if you don’t need the ekstra keys. (haven’t tryed with a USB keyboard as I don’t have one)

3)In rare situations it seams like the problem disappears, but after a reboot it will be back.

4)The failsafe mode doesn’t help at all.

5)Why dos it happon after I install the Nvidia driver? I know I made it redetect devices, but when I look in the configuration setings haven’t changed it was still Generic 101 PC key keyboard, (I did try and change it to the 104 as suggested).

I realy want this to work. this relese is nearly works perfect on my PC except for this.
Love the KDE user interface.

Any help would be greatly appreciated.