Build evdev package to fix trackpad issue on Lenovo's laptop with clickpad (2014).


I’va have the Thinkpad with clickpad. It looks like this:

So, all three buttons placed on the top of the touchpad.

I have solution: it need to download sources for synaptics and evedv, grab patch from Arch repo and build rpm for openSuse.
But I’ve never created rpms, totally have no experience with that.

I’ve posted bash script for ubunutu bellow and ask for translations that script to openSuse (versions of libs the same). Ideally, will be great, if someone help with small tutorial who to adapt this script and build in the OBS. :wink:

The script is:

echo --------------------------------------------------------------------

sudo apt-get install libevdev-dev libevdev2
sudo apt-get build-dep xserver-xorg-input-evdev xserver-xorg-input-synaptics



dpkg-source -x --no-check xserver-xorg-input-evdev_2.9.0-1ubuntu1.dsc
dpkg-source -x --no-check xserver-xorg-input-synaptics_1.8.0-1~exp2ubuntu2.dsc


tar -xzf xf86-input-evdev-trackpoint.tar.gz

mv xf86-input-evdev-trackpoint arch
mv xserver-xorg-input-evdev-2.9.0 evdev
mv xserver-xorg-input-synaptics-1.8.0 synaptics

cp synaptics/src/{eventcomm.c,eventcomm.h,properties.c,synaptics.c,synapticsstr.h,synproto.c,synproto.h} evdev/src
cp synaptics/include/synaptics-properties.h evdev/src
cp arch/*.patch evdev

cd evdev
patch -p1 -i 0001-implement-trackpoint-wheel-emulation.patch
patch -p1 -i 0004-disable-clickpad_guess_clickfingers.patch
patch -p1 -i


cd ..
sudo dpkg -i xserver-xorg-input-evdev_*.deb
sudo apt-get remove xserver-xorg-input-synaptics

sudo mkdir /etc/X11/xorg.conf.d/
sudo cp arch/90-evdev-trackpoint.conf /etc/X11/xorg.conf.d

echo If everything was OK, than logout/reboot and enjoy fully working ThinkPad Trackpoint/ClickPad
echo If you want to deactivate touch area of ClickPad for pure TrackPoint usage
echo edit /etc/X11/xorg.conf.d/90-evdev-trackpoint.conf and change "0" to "1" at line
echo Option "AreaBottomEdge" "0" 
echo Regards, T_Send

My Trackpoint nub works in OpenSUSE Tumbleweed but I need to speed it up about double or triple.

Did you solve your challenge? And/or do you have any idea how I can speed up my Trackpoint cursor?

openSUSE 13.2 Trackpoint Cursor Speed Too Slow

Hi! I’ve build own package from sources. This problem doesn’t related to the click or cursor speed. You can easily change it in GNOME\KDE settings I guess.

You can find the commands to speed up the trackpoint nub on this ArchWiki link:

and here: