build custom kernel

When I build the kernel 2.6.30 source, the rpm package is very big and needed or root filesystem 800-900 Mb. I use “make rpm” as described in Configure, Build and Install a Custom Linux Kernel - openSUSE.

Help to understand why this is happening.

I’m afraid I don’t understand the question. What exactly IS the problem?

I made custom compiled kernel on OpenSuSE 11, but using classical method (make bzImage && make modules && make modules_install). Same thing happened to me. I investigated a little bit and found out that huge amount of hard disk space was took by freshly compiled modules (I believe it was arround 500 megs). Funny thing is that I tried to strip down kernel max.rotfl!

Don’t know why is that happening, but I believe some more experienced OpenSuSE (when it comes to kernels) user could explain.

Usually, the SUSE kernel is split in different packages like -default, -base, -devel, -extra and -source. If you build it as a whole, (ie, no splitting) it’s possible you’ll get a large filesize

If you’re asking WHY it’s so big, I’ve found that when I did an old fashioned kernel compilation, when I was building all the modules and whatnot, it ended up bloating to like 700-800 megs. Once it’s finished, built, and running, and you clean up the source, it’ll go back down to normal.

I build kernel with the same configuration on Debian, and got modules ~70 mb.
What 800 MB???

Hi there,

have the same problem, searched for solution and found this thread. Build a custom kernel :

  • openSuSE 11.2 x86_64 (up-to-date)
  • openSuSE 11.2 Kernel Sources
  • Cloned Config fromm openSUSE default kernel
  • just some minor changes via menuconfig

Everything’s fine, BUT:

All modules are approx. 10 times bigger :O.

E.g.:

All modules in /lib/modules/2.6.31.12-0.1-default/kernel/drivers/acpi = 350 KB [origin openSuSE Kernel]

SAME modules in /lib/modules/2.6.31.12-0.1-default-nb-100317/kernel/drivers/acpi = 3.7 MB [my custom build]

This sums up to ~ 120 MB vs. ~ 1 GB (all modules). What did I wrong ?

Regards, pepun

Well, replying to myself:

Disabled “> Kernel hacking > Compile the kernel with debug info (CONFIG_DEBUG_INFO)” and modules are as small as they should be :slight_smile:

I’m not sure why this was enabled, cause i simply cloned the original openSuSE-kernel-config and made some minor changes.

Regards, pepun.

1 Like