Buggy GTK look on KDE

Hello everyone.

I am wondering if someone can point me in right direction.

After installing Tumbleweed, I ran “Virtual Machine Manager”, currently at version 1.3.2.
At first, it was displayed fine.

I didn’t felt like creating new virtual computer at the moment so I exited.
Next time I ran it, the screen was messed up (Image at imgur).
No spacing between menu items, no button borders, message disappearing if I try to click on checkboxes, and so on.
I tried restarting the program, and computer, but that didn’t help.

I tried googling and searching the forum for “gtk gui cache” and “virtual machine manager cache”, figuring that if I delete it, it might work.

I couldn’t find much.

Later, I tried running eclipse ee (Mars 4.5.2), and saw the same thing (Image at imgur).
No spacing, button borders missing and so on.

I really don’t feel like reinstalling openSuse once again, so I would be grateful if someone can point me in right direction on what to delete/refresh so it would start behaving normal again.

Kind regards,
Ranko

I see this too, mainly in gtk2 applications, a.o. easytag. From what it looks like the settings in KDE’s GTK-modules don’t have any effect. I thought this was due to my install ( added GNOME 3.20 last week ), but it seems something else is going on.

I’m seeing this too, in pavucontrol and pulseaudio-equalizer-gtk (at least).
I tried changing the setting in the “GTK applications style” tab of System Settings, but there was no change at all in the application window.
I am using plasma 5.6.1.

cristiano@xmper8q3:~> lsb_release -a
LSB Version:    core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch
Distributor ID: openSUSE
Description:    openSUSE Tumbleweed (20160117) (x86_64)
Release:        20160117
Codename:       Tumbleweed

Cris

I fiddled a bit with lxappearance till I got something reasonable. But now I dont see the scroll box within the scroll bars in firefox and thunderbird.

Plasma creates a .gtkrc2.0 in /home/user
Maybe you can try customizing it from there.

I see it here on xfce 4.12
Every time I login to plasma5 it destroys my xfce 4.12 styles
so as soon as I login to xfce I delete the .gtkrc2.0 created
by plasma 5 in my /home/user to revert back my xfce setup.

If that can help, it seems that from Plasma 5.5 to 5.6, the package breeze-gtk was split and renamed “gtk2-metatheme-breeze” and “gtk3-metatheme-breeze”.

Not exactly. GNOME 3.20 doesn’t support theming engines anymore. AFAIK these packages are new. They might use some of the same files though. All in all this is not related to Plasma changes, but rather to GNOME moving to 3.20 in TW.

Uninstall kde-gtk-config5, that creates that config according to KDE’s settings at login.
Or set what you like in systemsettings5->Application Appearance->GTK.

GTK3 doesn’t support theming engines since 3.16, that’s why gtk-oxygen doesn’t work anymore.
But the “breeze” theme does not use a theming engine.

But, in GTK 3.20, they again made incompatible changes that break existing themes.
The breeze theme has not been adjusted yet, see https://bugs.kde.org/show_bug.cgi?id=361066

AFAIK these packages are new. They might use some of the same files though. All in all this is not related to Plasma changes, but rather to GNOME moving to 3.20 in TW.

breeze-gtk was an old, inofficial theme actually named “breezyGTK”.

gtk2-metatheme-breeze and gtk3-metatheme-breeze are a new, official breeze theme for GTK.

In Leap 42.1, we still only have one package breeze-gtk, which contains the new theme though. This was done to not having to introduce new packages in a released product, and to prevent update problems.

Just to note this is not the case in the KDE Frameworks repo, which was updated to 5.6. It’s worth mentioning…

(I blocked breeze-gtk version for a while before realising the new availability of the above packages! ;))

Yes.
That’s specific to the Leap 42.1 standard repos, to prevent update problems as mentioned.

In the additional repos (which are the development repos for Factory/Tumbleweed, so they contain the packages that are going to be submitted to Tumbleweed) the latest version is packaged as gtk2-metatheme-breeze and gtk3-metatheme-breeze, although the stuff contained is exactly the same.

This helps with some applications:
https://bugs.kde.org/show_bug.cgi?id=361066#c8

virt-manager that openSUSE uses at KDE is still messy though.

This will prevent from breeze being used at all, the theme is called “Breeze” not “breeze”, so GTK3 will fall back to the default.

You can just as well choose a different GTK3 theme in “Configure Desktop”->Application Appearance->GTK.

The reason for the problem is as mentioned: GTK 3.20 breaks existing themes, and breeze has not been updated yet.