Buggy DE - Plasma 5 and MATE

I installed default kde (kde4) from openSUSE 13.2 DVD. It was working fine.

Today I noticed Plasma 5 Pattern in the the Software Management Tool (yast) and I checked to install it. Also I installed MATE pattern.

  1. While I found later that MATE’s caja has bug - reopening of multiple caja windows https://bugzilla.opensuse.org/show_bug.cgi?id=905808
  2. While, whenever I login into kde (plasma 5), I get dialogbox “could not sync environment to dbus opensuse bug”, I click ok and I’m forcely logged out.

edit: I didn’t add additional repositries for kde5 just installed plasma 5 pattern. It asked to uninstall kde4 and i said ok

This problem is unrelated to installing MATE.
It’s a bug in Plasma5 that got exhibited by the latest dbus security update.

See here for fixed packages for 13.2 (commentä5) and a workaround (comment#6):

The fix should get released as update for 13.2 as well in the near future (together with a complete update to Plasma 5.1.2), but I cannot tell how long this will still take.
The update is available in the update-test repo though:

I’m not relating both the bugs. Just saying that I got two bugs

wolfi323 your packages are for Tumbleweed. Would it be right to install it on my 13.2 system. Meanwhile the workaround works.
I commented out #/usr/lib64/libexec/ksyncdbusenv in /usr/bin/startkde

And any solutions for mate bug yet.

I created packages for 13.2 as well. See comment#5 as I wrote.

And again, the running update for 13.2 is available from the update-test repo, see my previous post for the URL.

But that workaround should be ok as well, and will automatically be removed when you install the update… :wink:

And any solutions for mate bug yet.

I don’t use MATE, but I experienced the same problem when I tried it out months ago.
There are a few threads about this problem here already, e.g.:

Uninstalling caja would help of course.

And the bug report you mention does have a workaround as well. Have you tried that?

Another workaround is modifying the caja.desktop file. See the threads above.

Sorry, I misread your original post a bit at first.
I understood you meant that Plasma5 worked fine, but since installing MATE you get that error.

I noticed later on that actually KDE_4_ was working fine, but then it was too late to edit my post…

OK for mate I got two bugs

  1. Infinite caja windwos - Commenting out -
#include /usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc

in ~/.gtkrc-2.0 solves it

The Panel encountered a problem while loading "GNOMEMainMenuFactory::GNOMEMainMenu".

Do you want to delete the applet from your configuration?

Installing gnome-main-menu solved the problem

The mate issue is a feature/bug not yet fixed
if part of a visual resource is missing caja will crash,
there;s an interesting bug in debian’s bugzilla

seeing how caja provides mate’s desktop, when logging into mate you’ll get infinite windows, the fix would be not commenting out resources but using a theme/visual style that has all of them.

on a 32 bit openSUSE 13.2 there’s a few components of adwaita missing (gtk+2 window border) this causes caja to crash wich in turn stops the mate desktop from loading.
Can someone with Mate installed check and see if the adwaita theme is complete (you can use Mate’s settings app) how do you check for missing gtk+2 resources?
About the main manu the gnome menu works but there is a another one for mate:

sudo zypper in caja-gnome-main-menu

how-to get mate up and working without pulling your hair
remove caja
logg into mate, use the theme selector (I don’t know the apps name it’s in the menu) and select a different theme (wallpaper too as that crashes caja if it’s missing)
install caja
mate should run

PS, regarding Plasma 5:
The update to 5.1.2 which also contains a fix for this problem has been released yesterday.

But you don’t have to change anything after installing it, as the update will revert your modification automatically…