BUG: Update applet ignores checking interval


in Plasma when I right-click on update applet and select update interval to monthly, after every reboot applet still checks for updates.

If you stay logged in for a long time, then it will probably do the next check after one month.

Personally, I turn off the update-applet (in system tray settings). That’s because I prefer to use Yast online update or the “zypper up” command for updating.

Well, update applet worked as expected in 42.3 - no check for updates every login, but on setted interval.

Then maybe a bug report would be appropriate.

opebSUSE:Submitting bug reports

That’s the only relevant change between Leap 42.3 and 15.0 I can see:

Thu Jan  4 14:02:21 UTC 2018 - fabian@ritter-vogt.de
- Fix refresh logic on startup:
   * 0001-Only-save-the-last-update-timestep-on-success.patch
   * 0002-Show-that-the-last-check-failed-if-no-updates-availa.patch
   * 0003-List-known-updates-on-startup.patch  

The summary of this patch:

 Currently it's possible that it just says "No updates available" although
 PackageKit knows the opposite. This is because it doesn't even ask PK on
 startup. With this, it always lists available updates, only
 refreshing the cache if necessary. 

So the intention seems to be to show already known updates on login, but not actually look for new updates.

I can’t tell at the moment if that is working as intended though, if a refresh is done in any case on login it would indeed be a bug I suppose.
(although it would be in line with what KDE4’s Apper did, and plasma5-pk-updates in Leap 42.1… :wink: )

“Tested milion times…”, well maybe tested, but not used. Bugs are present all around. Redshift starts twice, update applet doesnt work properly, proprietary nvidia drivers still has terrible tearing - I have to manualy enable “Force full composition pipeline”, audo volume indicator still shows bad volume for Firefox, icons on the desktop are still corrupted when woke from sleep with nvidia driver and Plasma, etc.
Really? This is linux desktop? If so, then it is really dead.

Sure it is tested (and probably even the “million times” is true).

But not everything can be tested, bugs always slip through, and sometimes things have to be released with known bugs otherwise you’d never be able to release anything. Especially in a Linux distribution which contains ten thousand packages from hundreds or thousands upstream projects.

The problems you mention are known and being worked on, if not it’s better to file a bug report than rant about it here.
The nvidia driver can only be fixed by nvidia though, and the suspend/resume problem you mention is a bug (or design problem) in that driver, a workaround will be in TW soon (Qt 5.11, Plasma 5.13) but probably not backported to Leap 15.0 (I don’t know).

That the update applet is not working is an over-exaggeration now, and as mentioned I’m not even sure there is a bug yet.
The question is, are you really being offered new updates, or does it just look like it’s searching for updates (because it waits for PackageKit’s response)?

Really? This is linux desktop? If so, then it is really dead.

Then stop using it.

Good luck.

Oh, and btw, I would prefer if you wouldn’t hold SUSE’s marketing speech against openSUSE volunteers or fellow users that try to help you (in their spare time, unpaid). :wink:

PS: regarding the redshift problem, see https://forums.opensuse.org/showthread.php/531285-How-to-stop-Redshift-from-starting-automatically

OK, I am sorry about my rant. I am just little upset, that some things are still not sorted out.

Thank you for your help and status about bugs fixing.

Well, still not sorted out is a bit of an overstatement as well.
Leap 15.0 just got released.

Many problems that “still didn’t get sorted out” are problems that nobody noticed during beta testing.

openSUSE is a community distribution, and depends on actual people (like you and all others here) to do the beta testing on a voluntary base.
Bugs that do get reported in time will (mostly, not always) be fixed in the release.

So, IMHO, if a release is bad, it is because the community (that includes me) failed, to some degree at least.

But I don’t think that’s the case with 15.0, actually there were largely positive impressions except for certain problems like the DNS one when upgrading via “zypper dup” that just wasn’t considered to be a show stopper by the release manager (and it actually isn’t a bug in 15.0 per se).

Thank you for your help and status about bugs fixing.

You’re welcome.

Now, back to topic.

The question is, are you really being offered new updates, or does it just look like it’s searching for updates (because it waits for PackageKit’s response)?

I cannot test it right now… :wink:

After login (reboot) update applet starts to do something and then it gives this error:

Download (curl) error for ‘http://download.opensuse.org/update/leap/15.0/oss/repodata/repomd.xml’:
Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org

It does always after reboot. My internet connection works just fine.

That can happen when it runs before the internet connection is active - usually when NetworkManager is configured with a user connection where KWallet is involved. FWIW, I don’t use the updater at all (and instead disable it), and I tend to have my wireless connections set up as system connections so that they are active before login.

During the checking for updates, my internet connection works fine. I can browse internet while it still checks for updates. I dont use KWallet.