BUG - kernel updates (5.3.18-lp152.10 and 5.3.18-lp152.9), they leave me a black screen

Hello, the latest kernel updates (5.3.18-lp152.10 and 5.3.18-lp152.9), they leave me a black screen, which does not allow the system to enter, the only thing that responds is to restart with ctrl + alt + sup.

Today’s update also cleared the kernel 5.3.18-lp152.8, which did work fine.

AMD Ryzen 5 3400G processor with Radeon RX Vega 11 Graphics

regards

Did you try the recovery mode option of either remaining kernel?

Did you try booting without starting graphical mode, by appending a 3 to the end of the linu line after striking the E key at the Grub menu?

Did you try booting by appending plymouth.enable=0 to the end of the linu line after striking the E key at the Grub menu?

same problem

same problem

same problem

Exactly when does the screen turn black? Are there any messages on the screen before it turns black?

Loading Linux 5.3.18-lp152.10-default ...
Loading initial ramdisk ...



pci 000:00:00.2: amd-v: unable to read/write to IOMMU perf coun tier.

that’s it

is there any way to view the “journalctl” on a live-usb?

I only see the first two of those line (on one computer). That’s Bug 1166664. But I think you have a different bug, so that probably needs a separate bug report.

I am using a kernel (5.5.9, I think) from

http://download.opensuse.org/repositories/Kernel:/stable/standard/

If you are able to boot to a command line, then you can try installing a kernel from there.

At the grub boot menu, hit ‘e’. Scroll down to the line that begins “linux” (or “linuxefi”), then hit END to get to the end of that line, and append " 3" to boot to init level 3 (command line). I don’t know if it will work. But if the system successfully deleted earlier kernels, then it should work.

is there any way to view the “journalctl” on a live-usb?

There probably isn’t any to view. At least for my 15.2 systems, “rsyslog” was installed, so there is no permanent journal. There’s only a temporary one for the last boot. But “/var/log/messages” might have useful information.

I browsed through recent bug reports. Is this bug the same as what you are seeing:

Bug 1169038 - radeon KMS driver isn’t loaded on recent Leap 15.2 kernels

[quote="“icomputo,post:6,topic:140170”]

pci 000:00:00.2: amd-v: unable to read/write to IOMMU perf coun tier.

[/quote]https://www.kernel.org/doc/Documentation/admin-guide/kernel-parameters.txt lists several iommu parameters. Among them might be one worth trying, such as iommu=off or iommu.strict=0.

is there any way to view the “journalctl” on a live-usb?
If /var/log/journal/ exists on the installed system, yes. If it doesn’t, then create it, try booting again, then check it from live boot. See --root=ROOT in man journalctl for how.

Hi
That’s related to amd virtualization, unlikely to be the real issue…

@OP, if you press the esc key, do you see more output on boot, else look at removing the ‘quiet’ entry from boot command via editing the boot options from grub and pressing ‘e’.

There’s also iomem=relaxed and other iomem* to try.

It doesn’t work

Thanks for the information

Then you may need to do a rescue.

Do you have bootable media, such as what you used for install?

this is the solution published at 1169038 – radeon KMS driver isn't loaded on recent Leap 15.2 kernels


Thanks!  Your quick followup is really appreciated.

I'm building a test kernel with the possible fix. now  It's being built in OBS home:tiwai:bsc1169038 repo.  Once after the build finishes, it'll appear at
  http://download.opensuse.org/repositories/home:/tiwai:/bsc1169038/standard/

Please get kernel-default.rpm from there later, install on your system, and test whether it loads radeon driver properly.  Note that the kernel release number might be lower and it'll appear at the end of GRUB menu.

I am seeing how I can install that new kernel, from the rescue console options of the usb-live, since it does not give me internet access.

Can you first download the RPM to a file somewhere. And if you can do that, then you should then be able to install without Internet.

rescue:/ # mount /dev/sde1 /mnt
rescue:/ # cd /mnt
rescue:/ # rpm -Uvh kernel-default-5.3.18-lp152-1.1...rpm

error: Failed dependecies:
         /bin/sh is needed by kernle-default-5.3.18........
         awk is needed by kernel-default-5.1.18-..........
         coreutils is need....
         distrubution-realease is need.......
         mkinitrd >= 2.7.1 is need....
         modutils is need......
         perl-bootloader  ..... in need.....
         suse-module-tools is need.......

Try:


mount /dev/sde1 /mnt
for d in dev sys proc run
do
   mount --bind /$d /mnt/$d
done
chroot /mnt
mount -a
 ### now try your rpm command
exit  ### exit chroot session

It’s actually possible that networking will work in that chroot environment – but I don’t know enough of what you are doing there.

Solution, thank you all


                              New kernel installation not an U pgrade, but a new I nstallation, so rpm -ivh rather than rpm -Uvh. If rpm complains the new kernel is an old version, then add the --oldpackage switch to rpm. If sde is a USB stick you booted from to rescue with, then after mounting /dev/sde1 on /mnt, you need to bind mount as follows:

mount -o bind /dev /mnt/dev
mount -o bind /sys /mnt/sys
mount -o bind /proc /mnt/proc
chroot /mnt

At this point change to the directory containing the new kernel rpm and run rpm, or just prepend that path to the filename.

I’m glad you have it working.