Bug in KDE Live install? I Re-enter the WiFi password after every reboot - work around?

A few days ago the wife gave the go ahead to install Leap on a spare laptop she was saving. Just in case her daily driver crapped out. This spare is actually a decent but inexpensive Lenovo ideapad model 330-17IKB with ram upgraded to 12GB and an upgraded to a sata SSD. It is a model with an 8th Gen Core i5 and a 17 inch display. I got onto the BIOS easy enough and got the Leap 15.2 KDE Live dvd to boot up. Easily connected to my WiFi and poked around to see if all the hardware was recognized. Good to go I thought. I clicked the “install” icon and soon Windows was gone and in its place was Leap 15.2.

At the beginning of the process the installer recognized that the connected WiFi was available and asked to use it for updates and to add on-line repositories. When it finished I rebooted and remove the dvd. That’s when something odd was happening. Every reboot I had to enter the root password and the WiFi password and to use KWallet each and every time. This is going to be unacceptable for the wife to have to do this. I began searching in here and tried several things being suggested but nothing helped. It’s 2021, right? WiFi setup “should be” pretty straight forward by now.

This is a very common topic in this forum - many folks seem to have this and similar issues with the WiFi password not being saved. I then moved on to search other distro forums and found many of the same issues with all the same suggestions that I found here. Eventually I stumbled on a Linux Mint post from 2016 that gave the answer that worked.

https://forums.linuxmint.com/viewtopic.php?t=229611

(Edited from the post) In the Connection editor, I deleted the WiFi connection, Next, go to system settings ->account details and disable KWallet (I’ve never had a use for this). Reboot. Then when I connected again, the connection was re-added – without KWallet interfering, and now I can change/save settings and the password gets remembered.

I hope others might find this helpful. I just wanted to share my experience. I’m grateful that there are many people here who jump right in to help others who are struggling to get things to work. And I thank you all. Sometimes the solution is really simple. It is a shame that this easy suggestion is nowhere to be found in the sticky.

Peace.

If you take a look in /etc/ you’ll find in a Network Manager sub-directory, a file with the WLAN password as plain-text – the file is not world-readable and, it’s owned by the user “root” …

  • Which is why a portion of the population do not consider KWallet – and other password wallets – to be a “nuisance” …
    [LIST]
  • When one uses a password wallet, the passwords are held in an encrypted “safe” which ain’t world nor group readable – meaning, without system privileges, nobody can find that file and, even if they have system privileges, they can’t decrypt the thing …

[/LIST]

It is not a bug and does not need a workaround.
If your wireless password is not a secret from users of the laptop you can configure Network manager to connect to your access point for all (and no) users without password re-entry.

  1. Right-click on the NetworkManager icon in the system tray.
  2. Select “Configure Network Connections”.
  3. Select your wireless connection (you may need to supply thhe root password).
  4. In the “General” tab
  5. ensure the All Users box is enabled.
  6. In the “WiFi Securtry” tab
  7. Enter your password.
  8. From the drop-down list select “Store password for All Users (unencrypted)”.
  9. OK

I missed noticing step 8 and had to ask for help a few days ago – https://forums.opensuse.org/showthread.php/549912-NetworkManager-connection-permissions