[BUG] [HELP!] Uncorrect Settings For The Second Display During Installation

I tried to install opensuse into my computer for the first time.
No problem with booting the system.
However, when it comes to the installation, I mean, after YaSt (hope I name the applicaion for the installation correctly) took over the control, something went wrong:

Hard disks stopped reading or wring as there was no more task for them.
If I click the Enter on my keyboard, hard disks will begin to read or write.
So the system is not halted but waiting for my input.
But the monitor was just black (or dark gray?) with a mouse cursor that I can move, and it can go beyond the left, right and bottom borders of the screen, but not the top.

There are three display ports on my thin ITX mainboard, one HDMI to which my display is connected, one LVDS and one DP. And there are on options in the BOIS that I can switch them off.
The BUG is clear that opensuse system took my only display as a second one instead of primary one and set it to work under extended desktop mode instead of mirror mode.

Could anyone tell me how can I modify any file on the installation medium that can changes the setting for the display?

Thank you very much!

This might sound like a silly question, but are your two other monitors on as well while booting up? If not, retry booting up with both of your other monitors on, as well as your primary monitor.

Thank you.
But the mainboard has 3 different display ports doesn’t mean that I have 3 monitors. I have but ONE that hooks to the HDMI port.

So exactly how many monitors are connected. the original post seems to imply more then one then you say only one???

I have Only One monitor while there are three display ports on the mainboard.

Let us be clear since “second display” is in your title. Exactly how many displays do you have??

Is this perhaps a notebook? If so is there any other GPU other then the one on the CPU? ie hybrid graphics?

Show as root

lspci

ONE. Only ONE. That’s what I have.

This is a DIY computer. I used a Thin ITX main board for it to make it fanless. The CPU on the main board is G3220. No other graphic card installed.

I think the installation enviroment recognized it as a Second one. The program seems to believe that there’s another primary one which is Not exist in the fact. This happened once when I installed Manjaro with KDE. It boots up as my only monitor is an extended desktop- no panels, no menus. Luckily, with a full-loaded system, I was able to change the settings. However, it occurs in the step of a screen of "Initilizing… " should be shown this time.

Is there a way to use the rescue mode to modify some settings and then begin the installation with some commands?

Thanks for anyone that try(ied) to help.

OK still not sure what you have LOL

What is recognized a second one??? A second what card, monitor??? Remember we can not see over your shoulder.

If this is an Intel CPU with a Intel GPU on it then it should work. But if some other GPU is involved that needs to be address.

You can try using the fall back drivers

at the first menu screen press e find the line starting linux or linux-efi go to true end (it wraps) add a space and nomodeset then F10 to continue. this should force the fallback drivers

I have only one monitor. My wife can see only one monitor on my desk. Anyone, if he is here, can see only one monitor in this room.

However, the computer, more precisely, the tumbleweed installation Dvd believes that I have two monitors. It puts all the things to the nonexistent monitor so I can not interact with the installation program. This is the question.

I am so sorry. Is my English that poor?

The hardware senses which port a monitor is attached too and should use that port.

How do you know that the output is going to a different port did you plug use a vga cable?

You may also be able to set things from the UEFI (BIOS)

I have never heard of what you describe so it is hard to figure out the real problem

No other vga cables plugged.

I know the output is going to a different port because:

  1. My monitor shows me a mouse cursor that I can move freely with nothing to click on in the desktop.
  2. If I press Enter on my keyboard, the installation will go ahead just as I click the “Next” for the installation.
  3. I had once encountered the situation that the Linux (Manjaro with KDE) believes there were two monitors while I have only one: Cursor on desktop with wallpaper, no panel, no menu. When I finally got into the setting center, there wereTwo monitors.

This mainboard has no options for primary display ports in its BOIS……

I just wondering is there a way that I can boot to the rescure mode and type cammands one by one to finish the installation?

Or to install in a VirtualBox for one time and remember exactly the keybord sequences and then do it agang in the physical machine? Blind install… I have several Harddisk… great risk…

No that is not right. If the mouse is on screen the correct port is being used the driver is just not working right. Use nomodeset and that should get a working display but using primitive drivers.Are you seeing the boot screen or is that the one that is blank. If so it may be a incorrect BIOS setting since grub depends on info from the BIOS

Remember we can not see what you see you have to tell us exactly.

I took some photos of my screen. But I am not permitted to post attachments here. So I uploaded them in google photos. Here is the link:

Some look small, but you can click on them to view the text on them.

Thank you for your paitence.

Looks like the screen is fine but the drivers are not being loaded.

Did you test the ISO image checksum before you installed?

nomodeset should sidestep the problem and allow possibility to fix things

Gogalthrop, Thank you. nomedeset DID help. I have installed tumbleweed in my computer now.

But there still 3 problems to be solved:

  1. I can login only with root. Another username I created during the installation can’t login.
  2. How to install the driver for my graphic? It’s a Intel haswell CPU G3220. Currently the monitor is set to 1366*768, no other options available.
  3. About the network, the first time I logged in, I was able to connect to my router through wifi. I can ping 8.8.8.8 normally. But can’t access any website with firefox. Tried the application for weather broadcast, didn’t work either. Then I restar my computer, this time, no network availabe in the settings even when Netmanager is already running.

Maybe I should start a new thread?

avoid logging into a GUI as root. Are you sure of the password you set and the name remember that Linux is case sensitive

Intel drivers come in the kernel should have nothing to install May need a newer kernel but TW is pretty much cutting edge. I use NVIDIA so need some one that knows more about Intel to comment

Yes we like one thread per problem. Glad to see you got it installed;)