Bug 847153 - Installation Overview, Yast2 Syntax Error message


I posted the above bug on bugzilla over a week ago. The only action done on it, was to have it assigned to the Yast mailing list. It’s not even been assigned a priority. Is that a normal response time? I can’t install 13.1RC1 on my hardware for testing at all right now. I’m sitting dead in the water and would like to do something to help with testing. Does anyone have any suggestions on how I can get past this error message?



That looks like a duplicate of Bug 834646.

For me, the install continues anyway, though the progress is not visible. After a while, normal progress indicators show up. Perhaps I had to click a “continue” button for the install to continue.

I’ve only seen this on systems with Intel graphics.

Thanks for the quick response Neil.

I tried searching for a similar bug before I posted, but put yast in my search terms so it never came up. I updated my bug with a link to yours. I will also try the install again and see if it finishes.

Thanks again for the help,

Search for duplicates doesn’t always find them.

In this case I recognized something similar. I think your message is slightly different, but they have made changes to Yast in the meantime which could have caused that change.

I just tried installing RC1 again. I hit close on the error message dialog box and then it just sits there for 1/2 an hour. No Hard Drive lights or anything. I can get to various Yast debug options by hitting Shift-F7 or Shift-F8 but that’s it. I also tried installing with NO KMS Video Driver, in Text-Mode, and in Kernel Safe Mode. They all have the same error message. I’m not sure what to try next.

On 2013-10-29 17:06, dbayerdorffer wrote:

> https://bugzilla.novell.com/show_bug.cgi?id=847153

Comments on bugzillas can get attention from the developers if you post
in the factory mail list. There are few, maybe none, in these forums.

You say:

> I can get to the log file with Shift-F8 but have no way to read it or save it
> on removable media.

If you go to a terminal (Ctrl-Alt-F1…F10) you may manually mount a usb
stick and copy the logs there, from the CLI. Might work.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Then I think what you are seeing is subtly different from the bug that I saw. It might be the same underlying bug, but acting a bit differently.

At that stage, with nothing happening, try CTRL-ALT-F2 (assuming a graphic install). It should get you a virtual terminal window, where you can hopefully find the logs, mount a disk somewhere, and copy the logs there for reporting.

Thanks for the tips Neil and Carlos for getting at the Log File. I have done that and uploaded it to Bugzilla.

On 2013-10-29 20:26, dbayerdorffer wrote:
> Thanks for the tips Neil and Carlos for getting at the Log File. I have
> done that and uploaded it to Bugzilla.

Good! That will help the devs, when they can get to it.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Just a heads up to everyone that this is still happening in 13.1 RC2 and I updated Bugzilla to reflect that.

Thanks for the reminder. I have also updated the similar Bug 834646, which is still there for RC2.

The openSUSE crew have fixed this bug. It’s corrected in yast2-packager-3.0.7.

Thanks everyone!