BTRFS not anymore mountable and new installation of leap 15 not possible

**After a crash and some human errors btrfs filesystem is damaged.
I want to leave it without deleting partition to play around…
BTRFS cannot be mounted anymore

But trying to install a new leap 15 system hangs in analyzing partitions.

What is the clue?
I have already tried to set hidding flag, does not work.
The partition table is in GPT format.
I don’t see anymore options to change partition format in gparted like in cfdisk for disks which has not GPT format.

Any idea how to solve?

BTW: Disk is not damaged. I’ve run a smart long self test, everything ok
**

are you trying to reinstall LEAP without reformating the root partition?
I don’t think this can or should be done
maybe try the upgrade option from the install disk this should prevent the need to format the root partition

I want to install leap to a new root partition but I don’t want to format old root partition to keep data.
I try to restore later. I have some data which backup is a week old and I would like to recover this data but now I have no time…

What I read from this.

You have a disk that is partitioned and one of the partitions has a Btrfs file system that is damaged.

You Want to install Leap 15.0 and intend not to use that partition at all in the installation, but to use another partition (that either already exists, or that you plan to take from free space on the disk) for the / partition of the to be installed system.

In the beginning of the installation the installer scans the disk for existing partitions (and also if there might be already a system on it) and then hangs. You presume it hangs on interpreting the partition with the broken Btrfs.

When the above is the correct interpretation of what happens, my idea is that that is a bug. When trying to find out what is on the disk, this must never hang, whatever is found there. The result could be something like: “found partition /dev/sdNX with unknown contents”, but not a hang.

The problem now is how to proceed. When you are not interested anymore in what is on that partition, you could just wipe the contents from a rescue boot with

dd if=/dev/zero of=/dev/sdNX

(and be very, very sure you use the correct N and X here, else you might destroy the wrong partitions contents).

Maybe others know a way on how to gather enough data for a bug report. Because just saying: “This is the situation and now it hangs”, might not be very helpful to solve the bug.

OK now I get it you want to keep your old root and repartition your hard disk
why not do this before installing leap ie use gparted to prepare all your partition
then when installing with yast just select the mount points you want a partition to have ie go in advanced disk setup don’t accept the initial disk reformat proposal the installer gives you

That’s all correct!! I know I can empty the partition but as I noted I want to keep partition and data on it to try to recover some data…

It comes not to this point. After asking for keyboard and
Probe UBS devices
Probe FIrewWire devices
Probe hard disks
the installation hangs with analyzing disk
Not even console switch works (ok I don’t know it works at this stage if not hanging…)

It seems that it tries to mount partition because it’s a btrfs partition.
Now what I have done is changed partition disk with cfdisk to Plan 9 partition but still hanging…
I’m rather confused…

Now I try to to a btrfs restore. It restores some files but not the root filesystem.
What I want is home directory of root which is /root
How can this be restored?

If /home is part of the btrfs partition you need to recover the entire partition. A couple of questions arise:

  • These ‘human errors’ you’re talking about, they could be anything, could you elaborate?
  • Have you tried the expert partitioning, or doesn’t the installer get far enough?
  • Are you aware that invoking more actions on the damaged filesystem may cause extra difficulties to get the btrfs fs fixed?
  • Have you tried to boot from a previous snapshot from the GRUB menu? Even if read only, it might allow you to access data on (parts of the) filesystem
  • Your backups are where? NB. Btrfs was never meant as a replacement for backups.

I do not want to be too pedantic, but that should have been part of your backup policy. At least when you put there other things then what a fresh installation does.