btrfs installation impossible, error -3008

Trying to install 12.3 from Gnome-live with btrfs I get the this error:

Formating partition /dev/sda9 (40.00 GB) with btrfs
system error code was: -3008
/sbin/mkfs.btrfs ‘/dev/sda9’: error checking /dev/sda9 mount status

Whenever I ignored the error an tried to continue :

error code -3047
/bin/mount -t btrfs -o subvolid=o’/dev/sda9’’/tmp/libstorage-TCcEEL/tmp-mp-SAVePd
mount: wrong fs type, bad option, bad superblock on /dev/sda9
missing codepage or helper program, or other error

I have GPT partitions on my harddrive and gdisk does not show any errors. The error will not only happen when I try the sda9 witk 40 GB. It also comes up when I accept the installers standard partitioning. It also does not matter, wether I create the partition in advance or use the suse-installer. I also tried to create a btrfs with Ubuntu before suse-install. No luck :slight_smile:

One thing I recognized: When I used the suse-installer to create a partition, gdisk -l /dev/sda shows it as primary with code 0700. Other linux-partitions are shown as linux-filesystem with code 8300.

On the same machine (Lenovo Thinkpad T430, uefi ohne secureboot, intel-Grafik) I already installed Ubuntu, Arch and Fedora sucessfully, but with ext4.

I also tried to install Opensuse Gnome-live with btrfs on my old desktop with AMD Athlon 3200+ probiert. Same problem !

So my first thought, that the uefi-Bios may cause the problem seems to be wrong. I also created a boot-partition with ext4, which does not help.

Any idea to solve this? Opensuse with Gnome and btrfs with snapper sounds good for me and I am quite disappointed that it did not work.

regards,

Robert

Try a separate /boot partition formatted ext2/ext4 I’m not at all sure that Grub know about btrfs yet.

I have already tried that. No sucess :frowning:

But I have thought about this issue again and have found a solution :slight_smile:

I have used the installation-DVD and everything went fine. Opensuse is running well with btrfs even without a separate extx-boot-partition. There must be a bug with the live-cd. I am just wondering if I am the only one who had that problem.

Maybe there were not many people trying to install it the way I have chosen.

Thanks anyway,

Robert

Well btrfs is still kind of shaky. It still does not have any proper fschk functions that work as far as I know. So if something goes wrong it reduces you chances of recovery. It has some fancy bells and whistles but I don’t think too many people are actually running on a production system. I certain won’t. It is still too much an experiment.

That was true, but no longer is. btrfs is going to be the default fs on SUSE, it is considered stable.

On 2013-03-21 22:56, Knurpht wrote:
>
> gogalthorp;2539213 Wrote:
>> Well btrfs is still kind of shaky. It still does not have any proper
>> fschk functions that work as far as I know. So if something goes wrong
>> it reduces you chances of recovery. It has some fancy bells and
>> whistles but I don’t think too many people are actually running on a
>> production system. I certain won’t. It is still too much an experiment.
>
> That was true, but no longer is. btrfs is going to be the default fs on
> SUSE, it is considered stable.

What, they have finally produced a valid fsck module?


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 03/21/2013 05:56 PM, Knurpht pecked at the keyboard and wrote:
> gogalthorp;2539213 Wrote:
>> Well btrfs is still kind of shaky. It still does not have any proper
>> fschk functions that work as far as I know. So if something goes wrong
>> it reduces you chances of recovery. It has some fancy bells and
>> whistles but I don’t think too many people are actually running on a
>> production system. I certain won’t. It is still too much an experiment.
> That was true, but no longer is. btrfs is going to be the default fs on
> SUSE, it is considered stable.
It may be the default option for install but that does not mean I have
to use it.

I have same problem as topic starter.Live CD KDE edition x86_64. I tried to launch installation program direct (not using live mode) but somewhere in the middle of installation process I got an error message about error while copying root live image (or root filesystem image, can not remember exactly).

On 2013-06-05 21:36, badcoder wrote:
>
> I have same problem as topic starter.Live CD KDE edition x86_64. I tried
> to launch installation program direct (not using live mode) but

The topic starter switched to DVD installer as a solution. You should
try the same.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I had the same error when installing it in a virtual machine from an ISO file.
The ISO was being shared through a BitTorrent application. Closing the application solved the problem.
Hope this helps someone.

Salvador

On 2013-06-06 20:36, salvaribeiro wrote:
> I had the same error when installing it in a virtual machine from an
> ISO file.
> The ISO was being shared through a BitTorrent application. Closing the
> application solved the problem.

That’s a funny one… it should not matter, unless the torrent was writing to it.

Unless… the host was Windows? Windows might lock read to a file when two apps open it, if one of
them uses r/w mode. You have to explicitly open the file allowing shared use, IIRC.

Sharing a file in Linux works differently.


Cheers / Saludos,

Carlos E. R.
(from oS 12.3 “Dartmouth” GM (rescate 1))