btrfs-balance start problems

Short story,today I’ve installed from scratch Leap 15 on a new 970 evo ssd.
Everything it seems ok,but I’ve one big problem.
For the life of me,I cannot enable btrfs maintenance processes.
I’ve tried everyhing for two hours,read every topic,but nothing.
The cron daily and cron weekly folders are empty,no trace of the two files ( and btrfs-balance ).
I’ve forced reinstall of the packages “btrfsmaintenance” and “btrfsprogs” ,but in vain.
If I go to Yast–Services,and I try to enable from there for e.g “btrfs-balance” it gives me the following error : “This service cannot be enabled/disabled because it has no “install” section in the description file”.Same message for btrfs-trim.
In usr/share all the scripts are present in btrfsmaintenance folder.
Maybe a good soul can tell me what to try next,because I’m getting really desperate.
Thanks a lot!
Best Regards

The Btrfs services are part of systemd.

Take a look at the output of the CLI command " systemctl list-unit-files | grep -i ‘btrfs’ ".
You’ll see that the “btrfs-balance.service”, “btrfs-defrag.service”, “btrfs-scrub.service” and “btrfs-trim.service” are all “static” – because there’s no “Install” section in the service description file …
The system “static” services are called by other system services if and when they’re needed …

The systemd Btrfs “Timer” services are the ones which control the Btrfs housekeeping tasks.

If you examine the status of the systemd Btrfs “Timer” services – “systemctl status btrfs-balance.timer” and so on … – you’ll see when that service is next planned for execution.

Thank you.
You saved me from a lot of frustration.

linux-gp5n:~ # systemctl list-unit-files | grep -i 'btrfs'
btrfsmaintenance-refresh.path                                          enabled  
btrfs-balance.service                                                  static   
btrfs-defrag.service                                                   static   
btrfs-scrub.service                                                    static   
btrfs-trim.service                                                     static   
btrfsmaintenance-refresh.service                                       enabled  
btrfs-balance.timer                                                    enabled  
btrfs-defrag.timer                                                     disabled 
btrfs-scrub.timer                                                      enabled  
btrfs-trim.timer                                                       enabled  
linux-gp5n:~ # 

It seems that I’ve enabled "btrfsmaintenance-refresh.service "
Do I leave it enabled or disabled?
Best Regards!

This is helper service that configures other services based on settings in /etc/sysconfig/btrfsmaintenance. You can also enable/disable/schedule them manually.

Simply “systemctl disable” it – because it’s a systemd service without an “Install” section it’ll auto-magically change to “static” …

Really? Have you tried to actually look at the service definition?

Oooops!!! Sorry!! You’re correct!! :shame:

You should leave the “btrfsmaintenance-refresh.service” ‘enabled’ …

Thank you all for answers,sorry for the late reply.
I didn’t touch "btrfsmaintenance-refresh.service"so I think now I’m good to go.
Best Regards!