Browsing NAS; Can see first level folders but nothing beyond

Using openSuse 11.0 + GNOME. Attempting to view Samba share on a D-Link NAS. When I attempt to browse via…

Computer-> Places -> Network Servers -> Windows Network

it doesn’t show up. However, I can get to the top level share by typing smb://

But, when I open any folder, the contents appears blank. I was just using this from a Vista and an Ubuntu machine not more than 2 days ago and it worked fine then. Not sure what gives.

Inside of those folders are more folders and files but none of them are visible. I don’t remember any of the folder names to try to navigate it manually. All help is appreciated.

Newbie to Linux. I tried Ubuntu first and smabe seemed to work great but Ubuntu didn’t recognize my Nvidia raid. I tried open suse next and the raid was recognized but now I am basically experiencing the same thing but with a Linksys EFG120 NAS device. I can see it, I can get to Disk 1 but when I open it I cannot see any of the files. I tried writing to it and it seems to make new folders and I can delete them. ???

Forgot to mention. Same thing happens for our Tritton ASAP. I can see first level of folders. No files underneath.

Experiencing the exact same thing.

BTW the same thing happens in Fedora 9. As for Ubuntu, it also had a problem with samba. You could browse network shares and copy individual files but you could not copy folders. This got fixed in the 8.04.1 release.