I absoultely cannot figure this out… No matter which browser (FireFox, FireFox4, Seamonkey, etc) I try to use, I always get this error message:
/usr/bin/seamonkey: line 130: 3352 Segmentation fault $MOZ_PROGRAM “$@”

Replace “seamonkey” with whichever browser stated previously. I am pulling my hair out trying to figure this problem out. Can anyone out there shed some light on this?

Much appreciated,

can you start firefox from a terminal ? Open a terminal (like konsole for example) and type : firefox.

What I typed before was actually typed from a console prompt (Konsole to be exact)…


Did you try a new .mozilla folder
Rename the current one .mozilla-OLD (All your bookmarks are in there)

Try now

hmm … it looks like ‘firefox’ is actually a symlink to /usr/lib64/firefox/ (on my 64bit system).
Try : /usr/lib64/firefox/firefox (if you’re running a 64bit system), otherwise /usr/lib/firefox/firefox

Yes, that too !

ezdagor wrote:
> /usr/bin/seamonkey: line 130: 3352 Segmentation fault

are you having any other problems with…hmmmmmm, what operating
system, version and desktop environment are you running?

did you do this before install attempt?

did the system run ok for a while and then suddenly begin throwing
these errors?

if you run a Live CD do you get the same error?

have you checked your RAM?

were any of these helpful:

CAVEAT: [posted via NNTP w/openSUSE 10.3]

I’m running openSuSE 11.3
KDE 4.4.4 “Release 2” is my WM.

Yes, I checked the DVD. There are no errors with it.

Well, it all worked fine before I upgraded from oepnSuSE 11.2 to 11.3
And now, it appears that barely any web browsers work… I tried using Opera… but, I am unable to get the flash plugin working (i’ve tried everything) for some reason. And that is the problem… I need a way to watch Youtube and Hulu, etc. I tried downgrading to “legacy” versions of Firefox… no luck. The tally is: Firefox, Firefox4, Seamonkey, Chrome all do not work for me. I’m tearing my hair out over this.

No, I do not use a “live” version. RAM is fine, as far as I can tell.


You didn’t comment on this

To me, this sounds like broken dependencies. I’d check with xulrunner and v8 and mozilla-js. I’d make sure that they, and firefox, seamonkey and Google chrome are all set back to default settings. In otherwords, Firefox and seamonkey should be gotten from OSS, and thereby xulrunner and mozilla-js also from OSS. Google chrome comes from the Google chrome repo, so just make sure that matches. See, with firefox 4, they changed things around a bit, which could have caused some of the dependency issues. They made the changes to xulrunner and javascript.