Browser problems with php

No matter what browser I use, trying to open phpscript it asks me to save file or to open with some application.

Probably has to do with some system settings/local apache settings, as it happens within my local apache.

I noted php (on system level) is registered to Kate.
I do not know exactly what is causing the problem.

Just want to be opened as index.html
http://localhost/index.php and not to ask me to save file.

How do I correct this?
Thanks

The file association for a particular file type can be set via

KDE System Settings > Advanced > File Associations

If you want to view a PHP script as it would appear on a website, you have to do it through a web server. PHP files are programs, and need to be run by the PHP interpreter in the web server. Accessing the file directly won’t do it.

Just want to be opened as index.html
http://localhost/index.php and not to ask me to save file.

As ken_yap mentioned, if you’re trying to view the results via a browser, set up an apache web server first.

Yes, that was original question. How do I make apache open?
I seem to miss some setting and I do not know which one.

install yast-http-server, start yast-network services-http server to configure things to your need. Then remove the index.html from the webserver’s root (default /srv/www/htdocs/ ) and replace it by your index.php, that should work.

I dont have http server there listed. Strange, apache is installed by Yast…

Anyways, if you say what settings, I can alter httpd.conf (or anyother conf) manually… I may ever use webmin…

You need to install yast-http-server module to get the yast interface it is not installed by default.

Yap, that was it.
It reinstalled PHP5, with vendor change, and things begin to work.

Thanks.