brother printer

My printer was picked up ok but the scanner wasn’t. It’s aHL-L23900w.

For the scanner, you could use the following solution:

  1. connect the scanner to your computer
  2. open a terminal and type # lsusb
  3. it should show the ID of you scanner (mine is: Bus 001 Device 005: ID 04b8:1115
    Seiko Epson Corp. XP-342 343 345 Series) 1. under /etc/sane.d create a file called brother.conf (sudo nano /etc/sane.d/brother.conf)
  4. in this file, write the following: usb 0x*[first part of the ID]*
    0x*[second part of the ID] *-- mine is usb 0x04b8 0x1115 1. save and exit
  5. under /etc/sane.d open the dll.conf file (sudo nano /etc/sane.d/dll.conf)
  6. make a new line at the bottom of this file and write samsung
  7. save and exit
  8. now you can test if yast recognize your scanner

And, if you did not before, do not forget to install sane-backends (and xsane)


Mostly Brother drivers are 32 bit so install glibc-32bit and libusb-1_0-0-32bit and libusb-0_1-4-32bit if necessary.

For this printer (HL-L2390DW), there seems to be a 64bit driver:

I found that driver but have no idea how to install it. The directions are confusing.

I have the HL-L2390DW. OpenSUSE is the THE best distro for this printer I’ve found.

Download the Brother printer installation file from Brother: linux-brprinter-installer-2.2.3-1

After then opening a terminal and changing my directory to the one that contains the Brother file, I enter the following in the terminal:

*sudo bash linux-brprinter-installer-2.2.3-1 HL-L2390DW

I follow the prompts - yes-yes-yes (choose the auto option at the end of the list)-no-yes-yes.

Then reboot.

Then everything, printer and scanner, work great.*

It is a rpm-package, so you can open/install via Yast (rightclick on the icon and then open with YastSoftware) or you can use the cli: rpm -ivh nameofthepackage.rpm

Sure. On the Brother site. But Brother’s bash script does the same thing, just a lot easier.

Everything installs at the same time. Printer-Scanner-Scanner key, all-in-one script.

I tried right clicking>open with yast software>entered my root password. Then a popup opens with “error” at the top with the brother EULA notice. I click OK button and everything just goes away and nothing happens.

I’m getting this error

[/manny@localhost:~> cd /home/manny/downloads 
bash: cd: /home/manny/downloads: No such file or directory 
manny@localhost:~> cd downloads 
bash: cd: downloads: No such file or directory



ls -al ~/

Its mostly named Downloads, not downloads…

Ok thanks. I tried individual drivers and it worked ok finally. I didn’t know about capitalization. Learned something today :slight_smile:

Maybe two stupid questions:

  • did you download the rpm file from the drivers website?
  • which language do you use? (if your desktop is not in English, the chance is real that the download directory will not exist, it will have another name)

Sorry, I did not see the last three posts - forget my answer

Check for a Firewall setting on your computer. Disable the Firewall on your computer and try the network scanning again. Temporarily change your firewall/security settings to allow network connection. Your computer’s firewall/security software may be preventing the network connection from being established.

I got everything working. I’m stopping there :slight_smile: